Jump to content
Froxlor Forum
  • 0

All emails going to maildrop


Naim

Question

The postfix place all email to maildrop.

all configs are default(from froxlor conf menu)

 

Additional information:

all software was installed from ports

OS freebsd 8.2

 

hosting# cat /usr/local/etc/postfix/main.cf

 

smtpd_sender_restrictions =

permit_sasl_authenticated,

reject_sender_login_mismatch,

permit_mynetworks,

reject_unknown_hostname,

reject_unknown_recipient_domain,

reject_unknown_sender_domain,

 

smtpd_recipient_restrictions =

permit_mynetworks,

permit_sasl_authenticated,

reject_sender_login_mismatch,

reject_non_fqdn_hostname,

reject_non_fqdn_sender,

reject_non_fqdn_recipient,

reject_unauth_destination,

reject_unauth_pipelining,

reject_invalid_hostname,

reject_rbl_client sbl-xbl.spamhaus.org,

reject_rbl_client ix.dnsbl.manitu.net,

# sqlgrey enable check_policy_service inet:127.0.0.1:2501, postgrey

# enable

check_policy_service inet:127.0.0.1:10023,

check_recipient_mx_access cidr:/usr/local/etc/postfix/mx_access,

 

 

smtpd_sasl_auth_enable = yes

smtpd_sasl_authenticated_header = yes

smtpd_sasl_local_domain = $myhostname

smtpd_sasl_security_options = noanonymous

broken_sasl_auth_clients = yes

smtpd_sasl_type = dovecot

smtpd_sasl_path = private/auth

 

soft_bounce = yes

 

# Maximum size of Message in bytes (0 = unlimited)

message_size_limit = 0

mailbox_size_limit = 0

 

smtp_tls_security_level = may

smtpd_tls_security_level = may

smtpd_tls_auth_only = no

smtp_tls_note_starttls_offer = yes

smtpd_tls_key_file = /etc/ssl/hosting.some_real.domain.key.unencrypted

smtpd_tls_cert_file = /etc/ssl/hosting.some_real.domain.crt

# Just an example for CACert.org

smtpd_tls_CAfile = /etc/ssl/cacert.class3.crt

smtpd_tls_loglevel = 0

smtpd_tls_received_header = yes

smtpd_tls_session_cache_timeout = 3600s

tls_random_source = dev:/dev/urandom

 

virtual_alias_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_alias_maps.cf

smtpd_sender_login_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_sender_permissions.cf

virtual_mailbox_base = /var/customers/mail/

virtual_mailbox_domains = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_mailbox_domains.cf

virtual_mailbox_limit = 0

virtual_mailbox_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_mailbox_maps.cf

virtual_uid_maps = static:2000

virtual_gid_maps = static:2000

virtual_create_maildirsize = yes

virtual_mailbox_extended = yes

proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps

$virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains

$relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps

$recipient_canonical_maps $relocated_maps $transport_maps $mynetworks

$smtpd_sender_login_maps

virtual_mailbox_limit_override = yes

virtual_maildir_limit_message = Sorry, this user has overdrawn their diskspace quota. Please try again later.

virtual_overquota_bounce = yes

virtual_transport = virtual

## Dovecot Settings for deliver, SASL Auth and virtual transport

# uncomment those line to use Dovecot

mailbox_command = /usr/local/libexec/dovecot/deliver

virtual_transport = dovecot

dovecot_destination_recipient_limit = 1

alias_maps = $alias_database

smtpd_sasl_path = private/auth

 

queue_directory = /var/spool/postfix

command_directory = /usr/local/sbin

daemon_directory = /usr/local/libexec/postfix

data_directory = /var/db/postfix

mail_owner = postfix

myhostname = hosting.some_real.domain

mydomain = hosting.some_real.domain

myorigin = $mydomain

inet_interfaces = all

unknown_local_recipient_reject_code = 550

mynetworks_style = host

debug_peer_level = 2

debugger_command =

PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin

ddd $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/local/sbin/sendmail

newaliases_path = /usr/local/bin/newaliases

mailq_path = /usr/local/bin/mailq

setgid_group = maildrop

html_directory = /usr/local/share/doc/postfix

manpage_directory = /usr/local/man

sample_directory = /usr/local/etc/postfix

readme_directory = /usr/local/share/doc/postfix

 

 

 

 

cat master.cf

# Uncomment or add the following lines in your master.cf file

# to use the SSL 465 port (recommended)

#smtps inet n - n - - smtpd

# -o smtpd_tls_wrappermode=yes

# -o smtpd_sasl_auth_enable=yes

# -o smtpd_client_restrictions=permit_sasl_authenticated,reject

 

 

dovecot unix - n n - - pipe

flags=DRhu user=vmail:vmail argv=/usr/local/libexec/dovecot/deliver -f ${sender} -d ${recipient}

relay unix - - n - - smtp

flush unix n - n 1000? 0 flush

trace unix - - n - 0 bounce

verify unix - - n - 1 verify

proxymap unix - - n - - proxymap

anvil unix - - n - 1 anvil

scache unix - - n - 1 scache

discard unix - - n - - discard

tlsmgr unix - - n 1000? 1 tlsmgr

retry unix - - n - - error

proxywrite unix - - n - 1 proxymap

#smtp inet n - n - 1 postscreen

#smtpd pass - - n - - smtpd

#dnsblog unix - - n - 0 dnsblog

#tlsproxy unix - - n - 0 tlsproxy

Link to post
Share on other sites

3 answers to this question

Recommended Posts

Maybe i need to add more confs and logs?

 

The postfix place all email to maildrop.

all configs are default(from froxlor conf menu)

 

Additional information:

all software was installed from ports

OS freebsd 8.2

 

hosting# cat /usr/local/etc/postfix/main.cf

 

smtpd_sender_restrictions =

permit_sasl_authenticated,

reject_sender_login_mismatch,

permit_mynetworks,

reject_unknown_hostname,

reject_unknown_recipient_domain,

reject_unknown_sender_domain,

 

smtpd_recipient_restrictions =

permit_mynetworks,

permit_sasl_authenticated,

reject_sender_login_mismatch,

reject_non_fqdn_hostname,

reject_non_fqdn_sender,

reject_non_fqdn_recipient,

reject_unauth_destination,

reject_unauth_pipelining,

reject_invalid_hostname,

reject_rbl_client sbl-xbl.spamhaus.org,

reject_rbl_client ix.dnsbl.manitu.net,

# sqlgrey enable check_policy_service inet:127.0.0.1:2501, postgrey

# enable

check_policy_service inet:127.0.0.1:10023,

check_recipient_mx_access cidr:/usr/local/etc/postfix/mx_access,

 

 

smtpd_sasl_auth_enable = yes

smtpd_sasl_authenticated_header = yes

smtpd_sasl_local_domain = $myhostname

smtpd_sasl_security_options = noanonymous

broken_sasl_auth_clients = yes

smtpd_sasl_type = dovecot

smtpd_sasl_path = private/auth

 

soft_bounce = yes

 

# Maximum size of Message in bytes (0 = unlimited)

message_size_limit = 0

mailbox_size_limit = 0

 

smtp_tls_security_level = may

smtpd_tls_security_level = may

smtpd_tls_auth_only = no

smtp_tls_note_starttls_offer = yes

smtpd_tls_key_file = /etc/ssl/hosting.some_real.domain.key.unencrypted

smtpd_tls_cert_file = /etc/ssl/hosting.some_real.domain.crt

# Just an example for CACert.org

smtpd_tls_CAfile = /etc/ssl/cacert.class3.crt

smtpd_tls_loglevel = 0

smtpd_tls_received_header = yes

smtpd_tls_session_cache_timeout = 3600s

tls_random_source = dev:/dev/urandom

 

virtual_alias_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_alias_maps.cf

smtpd_sender_login_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_sender_permissions.cf

virtual_mailbox_base = /var/customers/mail/

virtual_mailbox_domains = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_mailbox_domains.cf

virtual_mailbox_limit = 0

virtual_mailbox_maps = proxy:mysql:/usr/local/etc/postfix/mysql-virtual_mailbox_maps.cf

virtual_uid_maps = static:2000

virtual_gid_maps = static:2000

virtual_create_maildirsize = yes

virtual_mailbox_extended = yes

proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps

$virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains

$relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps

$recipient_canonical_maps $relocated_maps $transport_maps $mynetworks

$smtpd_sender_login_maps

virtual_mailbox_limit_override = yes

virtual_maildir_limit_message = Sorry, this user has overdrawn their diskspace quota. Please try again later.

virtual_overquota_bounce = yes

virtual_transport = virtual

## Dovecot Settings for deliver, SASL Auth and virtual transport

# uncomment those line to use Dovecot

mailbox_command = /usr/local/libexec/dovecot/deliver

virtual_transport = dovecot

dovecot_destination_recipient_limit = 1

alias_maps = $alias_database

smtpd_sasl_path = private/auth

 

queue_directory = /var/spool/postfix

command_directory = /usr/local/sbin

daemon_directory = /usr/local/libexec/postfix

data_directory = /var/db/postfix

mail_owner = postfix

myhostname = hosting.some_real.domain

mydomain = hosting.some_real.domain

myorigin = $mydomain

inet_interfaces = all

unknown_local_recipient_reject_code = 550

mynetworks_style = host

debug_peer_level = 2

debugger_command =

PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin

ddd $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/local/sbin/sendmail

newaliases_path = /usr/local/bin/newaliases

mailq_path = /usr/local/bin/mailq

setgid_group = maildrop

html_directory = /usr/local/share/doc/postfix

manpage_directory = /usr/local/man

sample_directory = /usr/local/etc/postfix

readme_directory = /usr/local/share/doc/postfix

 

 

 

 

cat master.cf

# Uncomment or add the following lines in your master.cf file

# to use the SSL 465 port (recommended)

#smtps inet n - n - - smtpd

# -o smtpd_tls_wrappermode=yes

# -o smtpd_sasl_auth_enable=yes

# -o smtpd_client_restrictions=permit_sasl_authenticated,reject

 

 

dovecot unix - n n - - pipe

flags=DRhu user=vmail:vmail argv=/usr/local/libexec/dovecot/deliver -f ${sender} -d ${recipient}

relay unix - - n - - smtp

flush unix n - n 1000? 0 flush

trace unix - - n - 0 bounce

verify unix - - n - 1 verify

proxymap unix - - n - - proxymap

anvil unix - - n - 1 anvil

scache unix - - n - 1 scache

discard unix - - n - - discard

tlsmgr unix - - n 1000? 1 tlsmgr

retry unix - - n - - error

proxywrite unix - - n - 1 proxymap

#smtp inet n - n - 1 postscreen

#smtpd pass - - n - - smtpd

#dnsblog unix - - n - 0 dnsblog

#tlsproxy unix - - n - 0 tlsproxy

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...