Jump to content
Froxlor Forum
  • 0

Froxlor not generating .conf files


ecorg911

Question

Hello, I have recently installed Froxlor on a fresh copy of Debian Lenny (amd64)

 

I have setup Froxlor for use with Lighttpd, exactly as per instructed.

 

Although when I create a domain, no .conf files are created in the designated dir's e.g. for lighttpd = /etc/lighttpd/froxlor-diroptions

 

I have setup use for Lighttpd using the configuration menu and I have double checked the include string in the lighttpd.conf so it imports froxlor .conf files.

 

Froxlor is not creating BIND entries either, I'm not sure whether is a permission problem and proxlor is failing to write these entries, but I have tried chown the directories for the web server (www-data) and still no luck :/

 

Any help would be greatly appreicated, as this problem is very puzzling.

 

(I have also attached Lighttd's conf file below)

 

###############################################################################
# Default lighttpd.conf for Froxlor.
###############################################################################
var.basedir  = "/var/www"
var.logdir   = "/var/log/lighttpd"
var.statedir = "/var/lib/lighttpd"

server.modules = (
"mod_rewrite",
"mod_redirect",
"mod_alias",
"mod_access",
"mod_auth",
"mod_fastcgi",
"mod_cgi",
"mod_accesslog"
)

server.username      = "www-data"
server.groupname     = "www-data"
server.document-root = var.basedir
server.pid-file      = "/var/run/lighttpd.pid"
accesslog.filename   = var.logdir + "/access.log"
server.errorlog      = var.logdir  + "/error.log"

server.indexfiles    = ("index.php", "index.html",
					"index.htm", "default.htm")

server.name			 = "serverflux.com"
server.port          = 80
server.bind          = "88.198.35.227"
url.access-deny = ("~", ".inc")

fastcgi.server = (
".php" => (
	"localhost" => (
		"socket" => "/tmp/lighttpd-fcgi-sock-lighttpd",
		"broken-scriptfilename" => "enable",
		"bin-path" => "/usr/bin/php5-cgi",
		"min-procs" => 1,
		"max-procs" => 1,
		"max-load-per-proc" => 4,
		"idle-timeout" => 60,
		"bin-environment" => (
			"UID" => "www-data",
			"GID" => "www-data",
			"PHP_FCGI_CHILDREN" => "0",
			"PHP_FCGI_MAX_REQUESTS" => "10000"
		),
		"bin-copy-environment" => ( "" )
	)
)
)

#### external configuration files
## mimetype mapping
include_shell "/usr/share/lighttpd/create-mime.assign.pl"

include_shell "cat /etc/lighttpd/conf-enabled/*.conf"

include_shell "cat /etc/lighttpd/froxlor-diroptions/*.conf"

 

(P.S. sorry about the typo in title)

Link to post
Share on other sites

9 answers to this question

Recommended Posts

Hmm, I set the Cron Job up, although after trying to execute it (to test it), I recevied the following output:

 

Execute: http://xxxxxxxxxx.com/froxlor/scripts/cron_tasks.php

 

oky8og.png

 

I have chmod cron_init.php to 755 and I am stilling getting this error :S

 

File cron_init.php

Line 49: $keepLockFile = false;
Line 50: $debugHandler = fopen($lockfile, 'w');
Line 51: fwrite($debugHandler, 'Setting Lockfile to ' . $lockfile . "\n");
Line 52: fwrite($debugHandler, 'Setting Froxlor installation path to ' . $pathtophpfiles . "\n");

 

Can this be run under www-data, or does it need to be executed from root?

 

 

Edit: Running from root provides no output

 

php /var/www/froxlor/scripts/cron_tasks.php

 

Although there are still no .conf files generated for lighttpd..

Link to post
Share on other sites

 

1) ?bers Web wird das schonmal garnicht aufgerufen, der Cronjob ist f?r die Shell gemacht

2) ist cron_tasks.php nicht der "eigentliche" Cronjob der gestartet werden muss, sondern /var/www/froxlor/scripts/froxlor_master_cronjob.php

3) /var/www/froxlor/scripts/froxlor_master_cronjob.php has to be run as root

 

I have chmod cron_init.php to 755 and I am stilling getting this error :S

 

1) It's not the file that has thrown the permission-error it was the directory /var/run (*don't chmod anything there!* read next sentence)

2) don't randomly chmod some files if you're not sure what you do

Link to post
Share on other sites

Thank you. Point taken, noted for the future.

 

I executed the master script, and it's looking good, apart from BIND failed to start.

 

I couldn't find any error log in /var/logs, how would I go about finding some error output?

 

1) ?bers Web wird das schonmal garnicht aufgerufen, der Cronjob ist f?r die Shell gemacht

2) ist cron_tasks.php nicht der "eigentliche" Cronjob der gestartet werden muss, sondern /var/www/froxlor/scripts/froxlor_master_cronjob.php

3) /var/www/froxlor/scripts/froxlor_master_cronjob.php has to be run as root

 

 

 

1) It's not the file that has thrown the permission-error it was the directory /var/run (*don't chmod anything there!* read next sentence)

2) don't randomly chmod some files if you're not sure what you do

Link to post
Share on other sites

I've had a pretty good luck, and there is very little in the way of ducmentation on how to do this.

 

Edit: After checking the deamon log, I have found something relating to the Bind startup..

 

Nov 23 16:25:51 server named[2764]: loading configuration from '/etc/bind/named.conf'
Nov 23 16:25:51 server named[2764]: /etc/bind/froxlor_bind.conf:11: undefined ACL 'ns1.xxxxxxxxxx.com'
Nov 23 16:25:51 server named[2764]: loading configuration: failure
Nov 23 16:25:51 server named[2764]: exiting (due to fatal error)

 

I'm guessing it's throwing this error, due to the fact that the nameserver currently not on BIND?

Link to post
Share on other sites

After referring to this post:

 

http://forum.froxlor.org/index.php?/topic/100-bind9-fails-to-start/

 

I have managed to get it working.

 

Thanks d00p and stephen!

 

I've had a pretty good luck, and there is very little in the way of ducmentation on how to do this.

 

Edit: After checking the deamon log, I have found something relating to the Bind startup..

 

Nov 23 16:25:51 server named[2764]: loading configuration from '/etc/bind/named.conf'
Nov 23 16:25:51 server named[2764]: /etc/bind/froxlor_bind.conf:11: undefined ACL 'ns1.xxxxxxxxxx.com'
Nov 23 16:25:51 server named[2764]: loading configuration: failure
Nov 23 16:25:51 server named[2764]: exiting (due to fatal error)

 

I'm guessing it's throwing this error, due to the fact that the nameserver currently not on BIND?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...