Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
nightshift

phpmyadmin, webmail und webftp zum laufen bekommen und unter angelegten URLs aufrufen

Question

Hallo,

 

habe auf meinem V-Server (Debian Lenny) gerade anhand der hier gepinnten Anleitung froxlor installiert. Bin In Sachen Froxlor noch Neuling, SYSCP kenne ich allerdings auch noch gar nicht.

 

Ich m?chte gerne wissen wie ich phpmyadmin, ein Webmail System (Roundcube Webmail) und ein Web FTP Tool installiert bekomme und es unter allen Domains abrufbar machen kann die in Froxlor angelegt werden.

 

Ich habe derzeit einfach entsprechende Links mit der V-Server IP-Adresse hinterlegt also ipadresse/phpmyadmin usw....wie ist es machbar das alle in Zukunft f?r Kunden angelegten Domains auch url/phpmyadmin usw nutzen k?nnen. Sebstverst?ndlich enden diese Links noch im leeren und da ist auch das erste Problem. phpmyadmin wurde per aptitude installiert und der Ordner liegt im Ordner usr/src Auch das anlegen eines Links (in WINSCP im www Ordner mit dem Namen phpadmin und der Weiterleitung auf usr/src scheitert da ein 404 Fehler auftaucht.

 

Wenn es keine M?glichkeit geben sollte alle zuk?nftgen Domains mit dem Anfang /webmail /phpmyadmin usw automatisch und funktionierend zu versehen w?rde ich gerne wissen wie ich meine IP durch eine URL ersetzen kann (URLS liegt bereits vor und kann ich mittels IP-Adresse auf den Server leiten)

 

z.B. so (Domain nur Beispielhaft)

Ich m?chte halt ohne Einsicht der IP-Aresse arbeiten.

 

www.kundeninterface.de/phpmyadmin

 

 

Desweiteren habe ich bereits eine Domain auf dem Server geleitet per Namensservereintrag in Form der IP-Adresse. Intern wird er bereits korrekt auf den Space weitergeleitet bei Aufruf im Firefox. ?ndere ich die Startseite wird dies auch korrekt angezeigt, doch leider bekomme ich keinen Zugriff per FTP Client.

 

16:07:58 Status: Aufl?sen der IP-Adresse f?r trek-rs.de

16:07:58 Status: Verbinde mit 188.40.154.190:21...

16:07:59 Status: Verbindungsversuch fehlgeschlagen mit "ECONNREFUSED - Connection refused by server".

 

Ich versuche es mit dem Standard FTP Login das mit einem neuen Kundenaccount erstellt wird, dabei habe ich versucht unter den Einstellungen: Domainname: die URL trek-rs zu w?hlen um die im Admin Bereich festgelegte Subdomain zu ersetzen. Diese Einstellung wird augenscheinlich nicht gespeichert. Was ist denn da los ?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

Ich m?chte gerne wissen wie ich phpmyadmin, ein Webmail System (Roundcube Webmail) und ein Web FTP Tool installiert bekomme und es unter allen Domains abrufbar machen kann die in Froxlor angelegt werden.

 

Froxlor hinterlegt lediglich die Adressen zu besagten Services, einrichten tut es dabei nichts, das musst du selber machen und ist am besten auf Hersteller-Seite und/oder README des pakets zu machen

 

Ich habe derzeit einfach entsprechende Links mit der V-Server IP-Adresse hinterlegt also ipadresse/phpmyadmin usw....wie ist es machbar das alle in Zukunft f?r Kunden angelegten Domains auch url/phpmyadmin usw nutzen k?nnen.

 

Da m?sstest du manuell einen Alias in deiner Webserver konfiguration hinterlegen, das ist in Froxlor nicht vorgesehen

 

Sebstverst?ndlich enden diese Links noch im leeren und da ist auch das erste Problem. phpmyadmin wurde per aptitude installiert und der Ordner liegt im Ordner usr/src Auch das anlegen eines Links (in WINSCP im www Ordner mit dem Namen phpadmin und der Weiterleitung auf usr/src scheitert da ein 404 Fehler auftaucht.

 

in /usr/src?? da liegt normal nur der kernel-source, aber gut, eine einfache l?sung ist ein symlink, z.B.

ln -s /usr/src/phpmyadmin /var/www/phpmyadmin

Somit linkt /var/www/phpmyadmin auf phpmyadmin in /usr/src. Entsprechende vhost musst du allerdings auch selbst erstellen

 

Wenn es keine M?glichkeit geben sollte alle zuk?nftgen Domains mit dem Anfang /webmail /phpmyadmin usw automatisch und funktionierend zu versehen w?rde ich gerne wissen wie ich meine IP durch eine URL ersetzen kann (URLS liegt bereits vor und kann ich mittels IP-Adresse auf den Server leiten)

Mindestens eine Domain brauchst du sowieso als Froxlor-Hostname, sonst funktioniert das ganze nicht

 

16:07:58 Status: Aufl?sen der IP-Adresse f?r trek-rs.de

16:07:58 Status: Verbinde mit 188.40.154.190:21...

16:07:59 Status: Verbindungsversuch fehlgeschlagen mit "ECONNREFUSED - Connection refused by server".

 

l?uft denn der ftp-server ?berhaupt? ist er auch konfiguriert nach vorlage der Froxlor-Config-Templates?

 

Ich versuche es mit dem Standard FTP Login das mit einem neuen Kundenaccount erstellt wird, dabei habe ich versucht unter den Einstellungen: Domainname: die URL trek-rs zu w?hlen um die im Admin Bereich festgelegte Subdomain zu ersetzen. Diese Einstellung wird augenscheinlich nicht gespeichert. Was ist denn da los ?

 

Sorry, ich verstehe nicht was du damit meinst, bzw. was du da gemacht hast,

Share this post


Link to post
Share on other sites

Ich habe anhand der Debian Config-Vorlagen die im Froxlor ja vorgehalten werden alles configuriert, also die Anleitungen alle abgearbeitet und dachte das dann nach einem V-Server neustartet alles laufen sollte.

 

 

Ich habe bereits einen Hostnamen hinterlegt (dieser ist aber keine "echte URL") die bei der Denic registriert ist sondern einfach ein Name den ich auch im Verwaltungspanel des Betreibers angegeben habe.

 

Ich meinte die Einstellungen der Froxlor FTP Verwaltung. Ich habe aktiviert das neue Kundenaccounts automatisch eine Subdomain anhand des Hostnames bekommen. Da ich mit diesem als FTP Zugangs-URL ja nicht rein komme habe ich dort zu der Domain gewechselt die dem Nutzerkonto zugeteilt wurde.

 

Jene Domain habe ich eben in meinem Webinterface bei dem Domain Anbieter mit den Eintr?gen:

 

*.trek-rs.de TYP A

und

trek-rs.de TYP A

 

beide auf meine Server IP 188.40.154.190 umgeleitet, dies funktioniert ja auch im Browser doch tippe ich diesen Domain-Nanen im FTP Client ein, dazu den Kundenaccount Namen und das Kundenaccount Passwort bekomme ich keine Verbindung.

 

Eben jener Domain-Name wird von Froxlor auch nicht angenommen in dem FTP Einstellungen. Es wird immer wieder der Subdomain-Name genommen, anhand des Hostnames.

Share this post


Link to post
Share on other sites

Ich habe anhand der Debian Config-Vorlagen die im Froxlor ja vorgehalten werden alles configuriert, also die Anleitungen alle abgearbeitet und dachte das dann nach einem V-Server neustartet alles laufen sollte.

bei linux muss man nicht den server neustarten, das ist doch kein windows, du musst nur den service ansich neustarten, f?r proftpd als z.B.

/etc/init.d/proftpd restart

 

Ich habe bereits einen Hostnamen hinterlegt (dieser ist aber keine "echte URL") die bei der Denic registriert ist sondern einfach ein Name den ich auch im Verwaltungspanel des Betreibers angegeben habe.

Also sowas wie "kunde012345.hoster.de"? Sollte funktionieren damit, das ist eine "echte" domain.

 

Ich meinte die Einstellungen der Froxlor FTP Verwaltung. Ich habe aktiviert das neue Kundenaccounts automatisch eine Subdomain anhand des Hostnames bekommen. Da ich mit diesem als FTP Zugangs-URL ja nicht rein komme habe ich dort zu der Domain gewechselt die dem Nutzerkonto zugeteilt wurde.

es ist egal welche domain/IP du benutzt so lange sie auf den Server zeigt, sollten alle funktionieren, egal welcher kunde

 

Eben jener Domain-Name wird von Froxlor auch nicht angenommen in dem FTP Einstellungen. Es wird immer wieder der Subdomain-Name genommen, anhand des Hostnames.

 

Welcher domain-name wird wo in Froxlor nicht angenommen? Die FTP-Einstellungen haben mit der Domain ?berhaupt nichts zu tun. Bitte poste doch mal screenshots oder config-files und erkl?re genau was du meinst

Share this post


Link to post
Share on other sites

Habe es mal angehangen (links Auschnitt aus aktueller Filezilla Windows Version rechts Froxlor in 2. aktuellste Version da das heutige Update eben noch nicht bei den Debian Paketen dabei war)

 

Problem: Ich w?hle da wo ich es markiert habe die Domain trek-rs,de die ja dem Kundenaccount zugeordnet wird, doch irgendwie schaut es dann so aus wie aus dem Screenshot. pst.system ist mein Hostname

 

Das hier ist jetzt ein 2. Account den ich eingerichtet habe.

 

 

PS: Ich gebe bei Filezilla immer Port 21 an.

post-252-096191100 1280158834_thumb.jpg

Share this post


Link to post
Share on other sites

aaah, du hast @domain-ftp names gew?hlt, d.h. dein ftp-user ist nicht pstftp sondern pstftp@trek-rs.de, das hat mit der domain mit der er verbindet nichts zu tun, das ist lediglich der Benutzername des FTP users

Share this post


Link to post
Share on other sites

edit: Alle Probleme haben sich dank der Hilfe anderer erledigt doch habe ich nun eine weitere Frage zu den Mailkonten und eine zu SSL Schutz.

 

Wie lauten die Zugangsdaten f?r IMAP / POP3.

 

1.

 

Schicke ich Mails an eine im System eingetragene Adresse und habe dort eine Weiterleitung zu meiner Yahoo Adresse hinterlegt klappt es wunderbar und die Mail kommt an doch habe ich keine Ahnung wie die IMAP und POP 3 URL lautet. Versuche ich imap oder pop3.domain.de bekomme ich eine Verweigerung bei Roundcube hier: http://188.40.154.190/webmail/

 

 

2.

 

Wie kann ich kostenlos meine Domains oder besser alle Domains auf dem Server mit einem SSL Schutz versehen den User nicht best?tigen m?ssen im Browser.

 

Ich kenne nur Start SSL dort gibt es eine kostenfreie Variante und eine f?r 49 $ was noch zu verteten w?re. Ben?tige ich jetzt pro auf geschalteter Domain ein eigenes Zertifikat oder reicht f?r alle das f?r 49 $ USD (dazu die Frage: Was sind Muliple Domain Names ?)

 

Die Domains werden sich in verschiedenen Kundenaccounts befinden teilweise in Form einer Subdomain oder einer ganzen Domain. Geht das wohl der Beschreibung nach mit der 49 $ Variante ? Brauche ich dann f?r jede Domain eine eigene IP (habe eine Ipv4 Domain im Preis enthalten und eine Ipv6 Domain, da bekomme ich aber bis zu 6 kostenlos)

 

Wie und wo muss ich dann entsprechende Eintr?ge machen wenn ich das Zertifikat habe von startssl ?

Share this post


Link to post
Share on other sites

edit: Alle Probleme haben sich dank der Hilfe anderer erledigt doch habe ich nun eine weitere Frage zu den Mailkonten und eine zu SSL Schutz.

 

Wie lauten die Zugangsdaten f?r IMAP / POP3.

 

1.

 

Schicke ich Mails an eine im System eingetragene Adresse und habe dort eine Weiterleitung zu meiner Yahoo Adresse hinterlegt klappt es wunderbar und die Mail kommt an doch habe ich keine Ahnung wie die IMAP und POP 3 URL lautet. Versuche ich imap oder pop3.domain.de bekomme ich eine Verweigerung bei Roundcube hier: http://188.40.154.190/webmail/

Deine Email ist grunds?tzilch ?ber die MX Einstellungen im Nameserver erreichbar gemacht. Steht da mail.deinedomain.de dann ist das der Host.

Ist nicht wie bei Googlemail oder Yahoo, oder sowas wie 1und1 wo Du deren Regeln folgen musst. Hier machst Du ja Deine eigenen. So sehe ich es wenigstens, als weitgehender Rookie.

 

2.

 

Wie kann ich kostenlos meine Domains oder besser alle Domains auf dem Server mit einem SSL Schutz versehen den User nicht best?tigen m?ssen im Browser.

 

Ich kenne nur Start SSL dort gibt es eine kostenfreie Variante und eine f?r 49 $ was noch zu verteten w?re. Ben?tige ich jetzt pro auf geschalteter Domain ein eigenes Zertifikat oder reicht f?r alle das f?r 49 $ USD (dazu die Frage: Was sind Muliple Domain Names ?)

 

Die Domains werden sich in verschiedenen Kundenaccounts befinden teilweise in Form einer Subdomain oder einer ganzen Domain. Geht das wohl der Beschreibung nach mit der 49 $ Variante ? Brauche ich dann f?r jede Domain eine eigene IP (habe eine Ipv4 Domain im Preis enthalten und eine Ipv6 Domain, da bekomme ich aber bis zu 6 kostenlos)

 

Wie und wo muss ich dann entsprechende Eintr?ge machen wenn ich das Zertifikat habe von startssl ?

Ein SSL-Zertifikat ist verifiziert, wenn es denn weltweit g?ltig sein soll. So sieht der Verwender der https- Verbindung einmal dass es ein g?tliges Zertifikat hat und kann ruhig atmen und auf der anderen Seite ist nur dieses hinterlegte Zertifikat wirklich sicher, wie ich das sehe.

Richtest Du lediglich eine SSL Verbindung ohne ein Zertifikat ein, ist das nicht sicher, da ja nichts gegengepr?ft wird. :rolleyes:

Mmh, wieder ne Rookieantwort.

 

Naja, udn Multiple Domains heisst bei den Anbietern halt, dass du alle Subdomains mit versorgt hast.

Und ja, pro Domain brauchst Du ein Zertifikat.

 

Multi- Server oder so etwas w?re dann, nat?rlich zum entsprechenden Preis, eines dass Du auf beliebig vielen Domains und Subdomains verwenden kannst.

 

Ciao.

Share this post


Link to post
Share on other sites

Hi,

von mir mal eine Frage.

Hast du Plesk und gleichzeitig Froxlor auf deinen Server laufen? Sowas geht absolut nicht, da die sich gegenseitig komplett beeinflussen.

 

Oder hast du nur von Froxlor auf Plesk gewechselt?

 

Wenn ja, dann kann das Thema hier ja geschlossen werden.

 

Gru? Lindi

Share this post


Link to post
Share on other sites





×
×
  • Create New...