Jump to content
Froxlor Forum
  • 0

I broke apache :/


CZPortal4Gamers
 Share

Question

Hi, I'm totally dumb, i messed up something and couldnt figure out what, propably more things at once, so i will describe my situation. I wanted to enable php-fpm and even tried to switch to nginx after and now i cant turn on apache, even after uninstalling nginx.

Error:

● apache2.service - The Apache HTTP Server
     Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2021-08-21 18:48:37 CEST; 8s ago
       Docs: https://httpd.apache.org/docs/2.4/
    Process: 4109 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
        CPU: 57ms

Aug 21 18:48:37 ns55461 systemd[1]: Starting The Apache HTTP Server...
Aug 21 18:48:37 ns55461 apachectl[4112]: apache2: Syntax error on line 225 of /etc/apache2/apache2.conf: Syntax error on line 25 of /etc/apache2/sites-enabled/10_froxlor_ipandport_89.203.250.53.443.conf: Could not open configuration fil>
Aug 21 18:48:37 ns55461 apachectl[4109]: Action 'start' failed.
Aug 21 18:48:37 ns55461 apachectl[4109]: The Apache error log may have more information.
Aug 21 18:48:37 ns55461 systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Aug 21 18:48:37 ns55461 systemd[1]: apache2.service: Failed with result 'exit-code'.
Aug 21 18:48:37 ns55461 systemd[1]: Failed to start The Apache HTTP Server.
 

Link to comment
Share on other sites

Recommended Posts

  • 0
29 minutes ago, CZPortal4Gamers said:

Syntax error on line 25 of /etc/apache2/sites-enabled/10_froxlor_ipandport_89.203.250.53.443.conf

Whats the content of the file? I guess you did not switch back to Apache in Froxlor settings and it tries to load a nginx vhost to apache

Link to comment
Share on other sites

  • 0

- Login to your server to get a shell.

- Login to MySQL with froxlor or root user and switch to your froxlor database

- run: update panel_settings SET value='apache2' where varname='webserver';

- quit mysql and run the master cronjob manually with --force

Link to comment
Share on other sites

  • 0

Thanks, i knew that it must be somewhere, but i couldnt find that. Now im done with that, but yeah, there must be broken some config, because apache2 is crashing after startup and its propably connected to php-fpm and named, since they are not running too

Link to comment
Share on other sites

  • 0

[Sat Aug 21 16:53:43.317717 2021] [core:alert] [pid 19377] [client 45.146.164.110:33526] /var/customers/webs/n00b/cdklic.cz/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server con>
Ok, which module am i missing?

Link to comment
Share on other sites

  • 0
48 minutes ago, CZPortal4Gamers said:

image.png.c0de4cf2015ca550342163272a118964.pngThats how looks acme.conf

That's nginx syntax. You need to reconfigure or just delete all froxlor related configs in /etc/apache2/sites-enabled/ so you can reach froxlor via ip/froxlor like the installation. Remember to re-enable mod_php with "a2enmod php7"

If you can login to froxlor again, adjust all settings according to your needs.

Link to comment
Share on other sites

  • 0

Why shouldn't it be possible?

You sadly give way to less info on what exactly you did so I can only guess and tell you generic stuff. Just "didn't change anything" is just not possible if you did what I said...post errors, with all related messages and file contents or let us fix it for you -> https://froxlor.support/

Link to comment
Share on other sites

  • 0

permissions of /var/www/ and /var/www/froxlor? not even a few entries of error.log? permissions should be on "www-data" by default and mod_php enabled - as said, without more info about WHAT has already been done and what you are changing exactly after you get an answer here this will go back and forth all the time...Maybe until tomorrow there is more info from your site.

Link to comment
Share on other sites

  • 0

[Sat Aug 21 23:05:13.137847 2021] [php:error] [pid 129035] [client 194.228.11.236:52075] script '/var/www/froxlor/info.php' not found or unable to stat
[Sat Aug 21 23:06:01.838554 2021] [autoindex:error] [pid 129041] [client 194.228.11.236:52100] AH01276: Cannot serve directory /var/www/froxlor/: No matching DirectoryIndex (index.php,index.html,index.cgi,index.pl,index.xhtml,index.htm)>
[Sat Aug 21 23:06:19.627217 2021] [php:error] [pid 129031] [client 194.228.11.236:52115] script '/var/www/froxlor/index.php' not found or unable to stat
[Sat Aug 21 23:07:35.629618 2021] [autoindex:error] [pid 129033] [client 37.24.209.92:55116] AH01276: Cannot serve directory /var/www/froxlor/: No matching DirectoryIndex (index.php,index.html,index.cgi,index.pl,index.xhtml,index.htm) f>

Link to comment
Share on other sites

  • 0
14 minutes ago, CZPortal4Gamers said:

AH01276: Cannot serve directory /var/www/froxlor/: No matching DirectoryIndex (index.php,index.html,index.cgi,index.pl,index.xhtml,index.htm)

you sure there is the index.php in the folder /var/www/froxlor? This message says it cannot find it

30 minutes ago, CZPortal4Gamers said:

0755 are the folders and i've enabled php_mod. I dont know if any modules are missing or what, but i dont know what can be missing 😕

and what about owner/group? why not just post "ls -la /var/www/" and answer the question fully...would spare so much time...

Whats the output of "a2enmod php7.3" (or php7.4 depending on what you have installed)

Did you RESTART apache after your changes?

Link to comment
Share on other sites

  • 0

show content of /var/www/froxlor/ please...doesnt seem to have the content it should have (e.g. there should be a robots.txt in the root document but server says 404)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...