Jump to content
Froxlor Forum
  • 0
Infected

Service mysql has to be enabled to start service php7.3-fpm

Question

Guten Morgen,

ich habe eben ein Update meiner Software Pakete auf meinem System gemacht.

Danach wollte ich einen Mailserver einrichten.

 

Doch jetzt bekomme ich bei der Installation folgenden Fehler:

Service mysql has to be enabled to start service php7.3-fpm

 

Froxlor selbst läuft normal, jedoch würde ich die Meldung dennoch gerne loswerden.

 

Mein System:

  • Debian Stratch
  • Nginx
  • php-fpm
  • MariaDB

 

Ich habe folgende Stelle in Verdacht: https://github.com/Froxlor/Froxlor/wiki/nginx-with-php-fpm#4-enable-php-fpm-in-froxlor

Quote

# Required-Start:    $remote_fs $network mysql nscd

 

Kann mir bitte wer helfen?

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Ggfls hat das Update (wieso auch immer) den Dienst deaktiviert?

systemctl enable mysql

Share this post


Link to post
Share on other sites
  • 0

Was genau wurde denn aktualisiert? Hast du den Fehler Mal gegoogelt?

Share this post


Link to post
Share on other sites
  • 0

php7.3-fpm wurde aktualisiert.

Er scheint so, als wenn die Config Datei einen Lock verursacht hat.

 

Meine Lösung:

Ich habe den "mysql" Eintrag aus der init Datei raus genommen, das Paket neu konfigurieren lassen, dabei die alte Datei behalten und dann den mysql Eintrag wieder hinzugefügt.

 

Scheint jetzt sauber zu laufen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...