Jump to content
Froxlor Forum
  • 0
neomatt

ip/port Configuration

Question

 

 
Unter ssl ist meine Haupt-Domain (Haupt-IP) nur noch erreichbar, wenn ich die <ip>.443.conf aus /etc/nginx/sites-enabled entferne. Ansonsten sagt nginx im error.log:

no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking

Ich hatte schon gelesen, dass in den IP/Port-Einstellungen "create listen" deaktiviert werden muss. Ich sehe diese Einstellungsmöglichkeit jedoch nicht.

Was ist falsch an meiner Konfiguration?

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Na hast du denn irgendwo ein Zertifikat hinterlegt oder let's encrypt aktiviert für die Domain?

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank für die Antwort!

Ja, die Domains funktionierten bis gestern auch. Ich habe gerade die Checkbox "Erstelle vHost-Container" deaktiviert. Jetzt ist die <ip>.443.conf 'leer' und es funktioniert wieder.

Zwei Fragen habe ich noch (erstelle auch gerne eigene Einträge):

1. froxlor selbst ist unter http://ip/froxlor zu erreichen und nicht unter http://domain/froxlor. Warum ist das so?

2. Mit https://ip/froxlor wird ein Zertifikat einer konfigurierten Domain mitgesandt. Es ist immer das Gleiche, nur kann ich nicht sehen, warum dieses gewählt wird.

 

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, neomatt said:

Ich habe gerade die Checkbox "Erstelle vHost-Container" deaktiviert.

das ist ja nicht sinn der sache...

1 hour ago, neomatt said:

1. froxlor selbst ist unter http://ip/froxlor zu erreichen und nicht unter http://domain/froxlor. Warum ist das so?

weil du getan hast, was du getan hast, siehe ersten quote...ohne vhost gibt es keine zuordnung zur froxlor-domain

1 hour ago, neomatt said:

2. Mit https://ip/froxlor wird ein Zertifikat einer konfigurierten Domain mitgesandt. Es ist immer das Gleiche, nur kann ich nicht sehen, warum dieses gewählt wird.

default vhost, für IPs gibt es keinen vhost, das is ja domain-basiert. Findet der webserver keinen greifen default einstellungen und die passen meistens nicht

Share this post


Link to post
Share on other sites
  • 0
vor 9 Stunden schrieb neomatt:

Ich habe gerade die Checkbox "Erstelle vHost-Container" deaktiviert.

> das ist ja nicht sinn der sache...

Die Checkbox ist bei IP/Port Konfiguration für die IP deaktiviert. Aktiviere ich sie, dann steht in der nginx conf: <ip>:443 default host. Dann bekomme ich die Fehlermeldung: 'no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking' und die domains mit dns Verweis auf <ip> sind nicht erreichbar.

Was ist die Alternative zum Deaktivieren des vHost-Containers für die IP-Adresse?

Zu 1. : Ich erreiche froxlor nie unter einer Domain, auch wenn der vHost-Container (wie gesagt in der IP/Port Konfig) aktiviert ist.

Zu 2. : Das scheint damit ein Folgeproblem von 1. zu sein, keine Domain, kein richtiges Zertifikat.

Übrigens habe ich auch für die mail-Server-Subdomain zunächst immer das gleiche falsche Zertifikat erhalten. Ich vermute das Problem darin, dass bei den Froxlor-Einstellungen unter Host eine Subdomain eingetragen wurde (das ist schon etwas her). Der Grund war wohl, dass froxlor die Domain die unter Host eingetragen ist nicht wie die anderen Domains verwalten kann.

 

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, neomatt said:

Die Checkbox ist bei IP/Port Konfiguration für die IP deaktiviert. Aktiviere ich sie, dann steht in der nginx conf: <ip>:443 default host. Dann bekomme ich die Fehlermeldung: 'no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking' und die domains mit dns Verweis auf <ip> sind nicht erreichbar.

ja aber du hast ja nicht nur einen SSL vhost...es gibt ja auch noch den nicht-ssl vhost auf port 80. Dann deaktiviere doch eine evtl. vorhandene "SSL-Weiterleitung" und mach erstmal ohne SSL. Alternativ, wie auch schon gesagt: hinterlege ein Zertifikat oder aktiviere Let's Encrypt.

14 minutes ago, neomatt said:

Zu 1. : Ich erreiche froxlor nie unter einer Domain, auch wenn der vHost-Container (wie gesagt in der IP/Port Konfig) aktiviert ist.

Kann ja nicht sein, du hast ja bei der installation einen FQDN (eine domain) angegeben, dieser sollte natürlich auf die Server-IP auflösen und über diesen erreichst du dann auch froxlor

15 minutes ago, neomatt said:

Zu 2. : Das scheint damit ein Folgeproblem von 1. zu sein, keine Domain, kein richtiges Zertifikat.

naja, aber du MUSST ja eine Domain haben, denn du kannst die installation ohne gar nicht durchführen

16 minutes ago, neomatt said:

Übrigens habe ich auch für die mail-Server-Subdomain zunächst immer das gleiche falsche Zertifikat erhalten. Ich vermute das Problem darin, dass bei den Froxlor-Einstellungen unter Host eine Subdomain eingetragen wurde (das ist schon etwas her). Der Grund war wohl, dass froxlor die Domain die unter Host eingetragen ist nicht wie die anderen Domains verwalten kann.

Nein das ist kein problem, habe ich selbst auch jahrelang so gemacht, und machen sehr sehr viele Leute so für die ich das eingerichtet habe. Das geht wunderbar. Zertifikat für Mail-Dienste ist hierbei allerdings wieder ein KOMPLETT anderes thema

 

Mach doch am besten bitte mal von all deinen IP Einstellungen screenshots, dann weiss ich wenigstens was wo phase ist, alternativ stelle bitte alle vhosts Dateien die mit 10_* anfangen bereit (mit aktiviertem Vhost-Container bitte!)

Share this post


Link to post
Share on other sites
  • 0

Bilder der Konfig sind unten angehängt. Die 10_*-Dateien (eine für 80 und eine für 443) sehen so aus wie in

 beschrieben, doch die Checkbox "create listen" habe ich nicht unter der ip/port Konfiguration.

 

 

 

 

image.png

image.png

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, neomatt said:

beschrieben, doch die Checkbox "create listen" habe ich nicht unter der ip/port Konfiguration.

Weil du nginx nutzt...das braucht man da nicht.

 

Was genau ist denn jetzt eigentlich immer noch dein Problem? Ich hab doch jetzt hier schon zig Sachen klargestellt und erklärt, aber was ist es denn was du gerne hättest was jetzt nicht geht?

Share this post


Link to post
Share on other sites
  • 0
vor 3 Stunden schrieb d00p:

Weil du nginx nutzt...das braucht man da nicht.

 

Was genau ist denn jetzt eigentlich immer noch dein Problem? Ich hab doch jetzt hier schon zig Sachen klargestellt und erklärt, aber was ist es denn was du gerne hättest was jetzt nicht geht?

Mit der Einstellung "vHost-Container=nein" in IP/Port habe ich kein Problem mehr. Ich hatte mich nur zurückgemeldet, weil ich Du sagtest, diese Einstellung wäre nicht richtig.

Ich wünsche mir Froxlor unter SSL und mit einer Domain zu nutzen, was aktuell nicht geht, da ich froxlor nur unter <ip> erreiche und nicht unter <domain>. Unter <ip> kann ich, wenn ich Dich richtig verstanden habe, auch kein Zertifikat verwenden. Was ist bei meiner Konfig falsch, dass ich nicht https://domain/froxlor nutzen kann?

Vielen Dank für die Hilfe!

 

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, neomatt said:

Mit der Einstellung "vHost-Container=nein" in IP/Port habe ich kein Problem mehr. Ich hatte mich nur zurückgemeldet, weil ich Du sagtest, diese Einstellung wäre nicht richtig.

Ich wünsche mir Froxlor unter SSL und mit einer Domain zu nutzen

Ja, weil du genau dafür "Vhost-Container: Yes" brauchst...

24 minutes ago, neomatt said:

Unter <ip> kann ich, wenn ich Dich richtig verstanden habe, auch kein Zertifikat verwenden

korrekt, warum hinterlegst du dann in den einstellungen nicht einfach eins, oder aktivierst Let's Encrypt für den Froxlor-Vhost? Wo ist denn da das problem?

 

Share this post


Link to post
Share on other sites
  • 0
vor 4 Minuten schrieb d00p:

Ja, weil du genau dafür "Vhost-Container: Yes" brauchst...

Yes führt dazu, dass eine <ip>.443.conf geschrieben wird, die bei nginx -t zu dem o. g. Fehler führt und mir bei "nginx restart" alle Domains unerreichbar macht. Also no. ?

vor 6 Minuten schrieb d00p:

oder aktivierst Let's Encrypt für den Froxlor-Vhost

Habe jetzt gesehen, dass unter Einstellungen -> Froxlor vHost nichts eingetragen war. Habe das jetzt gemacht (3 Checkboxen: vHost verwenden, ssl mit LE, ssl-Weiterleitung). Leider ist nun froxlor nicht mehr unter der IP und auch nicht unter der Domain erreichbar. Ich bin aktuell ausgesperrt...

Share this post


Link to post
Share on other sites
  • 0
Just now, neomatt said:

Yes führt dazu, dass eine <ip>.443.conf geschrieben wird, die bei nginx -t zu dem o. g. Fehler führt und mir bei "nginx restart" alle Domains unerreichbar macht. Also no

na weil du ja auch ein zertifikat brauchst...wie oft muss ich das wiederholen?

1 minute ago, neomatt said:

Habe jetzt gesehen, dass unter Einstellungen -> Froxlor vHost nichts eingetragen war. Habe das jetzt gemacht (3 Checkboxen: vHost verwenden, ssl mit LE, ssl-Weiterleitung). Leider ist nun froxlor nicht mehr unter der IP und auch nicht unter der Domain erreichbar. Ich bin aktuell ausgesperrt...

lief denn der cronjob schon? Ansonsten mal manuell abfeuern mit:

# configs generieren
php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

# zertifikat anfordern (falls noch nicht passiert)
php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug

# falls hier erst ein zertifikat erstellt wurde, nochmal configs generieren
php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

Share this post


Link to post
Share on other sites
  • 0

Danke, habe gerade das nginx error.log gecheckt und gesehen: Klar, froxlor ist jetzt unter domain und nicht mehr unter domain/froxlor erreichbar!

Fazit: Das Problem an meiner Konfiguration waren die fehlenden Einstellungen unter Froxlor VirtualHost Einstellungen.

Nun sollte ich alleine weiterkommen! Vielen Dank für die tolle Unterstützung!

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, neomatt said:

Danke, habe gerade das nginx error.log gecheckt und gesehen: Klar, froxlor ist jetzt unter domain und nicht mehr unter domain/froxlor erreichbar!

auch das ist eine Einstellung :P Froxlor direkt via Hostnamen erreichbar machen :)

Schön das nun soweit alles klappt :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...