Jump to content
Froxlor Forum
  • 0
HaLoGeK

Error after trying to restart apache

Question

Hello ,  when i tried to restart apache 2 with this command " /etc/init.d/apache2 restart"


 

[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.servic                                                                          e failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
 failed!

 

After that i typed

cd /etc/apache2
apache2ctl configtest

And it said this

AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf:
Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.

 

In that .conf file is this :

 

# 03_froxlor_ocsp_cache.conf
# Created 06.05.2019 19:20
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

SSLStaplingCache shmcb:/var/run/apache2/ocsp-stapling.cache(131072)

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

 

 a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled

 

But now the error changed into this :

 

AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport_78.47.36.112.80.conf:
Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.

 

Share this post


Link to post
Share on other sites
  • 0

well, looks like you've not followed the configuration steps completely... you are missing libapache2-mod-fcgid

Share this post


Link to post
Share on other sites
  • 0

apt-get install libapache2-mod-fcgid
Reading package lists... Done
Building dependency tree
Reading state information... Done
libapache2-mod-fcgid is already the newest version (1:2.3.9-1+b1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

 

Share this post


Link to post
Share on other sites
  • 0

and activated the module? C'mon I just said you did not follow the configuration steps completely...please re-check that you really ran every command shown there (AFTER you've adjusted the settings/or activated FCGID for example)

Share this post


Link to post
Share on other sites
  • 0

How can i make the site work again , the site stopped working after i enabled ssl , can't i change the settings manually from the ftp ?

Share this post


Link to post
Share on other sites
  • 0

Remove all froxlor generated vhost configs, restart Apache, and access via http://[IP]/froxlor

No, settings cannot be changed via FTP...

Share this post


Link to post
Share on other sites
  • 0

I reinstalled the platform and started configuring all the services from webserver to others but encountered some errors on the way

 nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: en                                          abled)
   Active: failed (Result: exit-code) since Mon 2019-05-06 21:05:28 CEST; 9ms ag                                          o
     Docs: man:nginx(8)
  Process: 24128 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (cod                                          e=exited, status=1/FAILURE)
  Process: 24125 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process                                           on; (code=exited, status=0/SUCCESS)

May 06 21:05:27 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] listen() to […se)
May 06 21:05:27 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] listen() to 0…se)
May 06 21:05:27 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] listen() to […se)
May 06 21:05:28 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] listen() to 0…se)
May 06 21:05:28 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] listen() to […se)
May 06 21:05:28 centos-4gb-nbg1-1 nginx[24128]: nginx: [emerg] still could n…d()
May 06 21:05:28 centos-4gb-nbg1-1 systemd[1]: nginx.service: Control process…s=1
May 06 21:05:28 centos-4gb-nbg1-1 systemd[1]: Failed to start A high perform…er.
May 06 21:05:28 centos-4gb-nbg1-1 systemd[1]: nginx.service: Unit entered fa…te.
May 06 21:05:28 centos-4gb-nbg1-1 systemd[1]: nginx.service: Failed with res…e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package nginx-full (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up bind9 (1:9.10.3.dfsg.P4-12.3+deb9u4) ...
Adding group `bind' (GID 112) ...
Done.
Adding system user `bind' (UID 108) ...
Adding new user `bind' (UID 108) with group `bind' ...
Not creating home directory `/var/cache/bind'.
wrote key file "/etc/bind/rndc.key"
#
Created symlink /etc/systemd/system/multi-user.target.wants/bind9.service → /lib                                          /systemd/system/bind9.service.
dpkg: dependency problems prevent configuration of nginx:
 nginx depends on nginx-full (<< 1.10.3-1+deb9u2.1~) | nginx-light (<< 1.10.3-1+                                          deb9u2.1~) | nginx-extras (<< 1.10.3-1+deb9u2.1~); however:
  Package nginx-full is not configured yet.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.
 nginx depends on nginx-full (>= 1.10.3-1+deb9u2) | nginx-light (>= 1.10.3-1+deb                                          9u2) | nginx-extras (>= 1.10.3-1+deb9u2); however:
  Package nginx-full is not configured yet.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.

dpkg: error processing package nginx (--configure):
 dependency problems - leaving unconfigured
Processing triggers for systemd (232-25+deb9u11) ...
Errors were encountered while processing:
 nginx-full
 nginx

 

Share this post


Link to post
Share on other sites
  • 0

If i try to acces the site with https it gives me an error

This site can’t provide a secure connection dopepx.com sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

i enabled all the ssl settings from the panel

Share this post


Link to post
Share on other sites
  • 0

This happens when you try to use https but http is served. Have you enabled ssl in froxlor and added a ssl enabled up/port and assigned that to the domain.?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...