Jump to content
Froxlor Forum
Scarya

Release: 0.9.27

Recommended Posts

Hello Froxies,

 

welcome to the release of Froxlor 0.9.27. Sorry for the big delay but we needed to ensure the cronjob changes are correct and we had only a few responses. Furthermore our time is currently very limited during certain circumstances. We are sorry about that but feel free to participate on Froxlor (many changes in this release were indeed made by community members!).

 

We also would like to thank all the community members who contributed again to this release. smile.gif

 

Complete changelog for 0.9.27

 

Bug #700: APS template errors
Bug #992: Can't enable FTP Backup
Bug #1022: Remove php-fpm-specific configuration (files) correctly
Bug #1025: cron_traffic.php causes mysql error
Bug #1027: Unavailable repository 'gentoo_prefix' referenced by masters entry in layman
Bug #1028: Traffic-Cron - missing php-extension?
Bug #1032: Error while creating a new customer in 0.9.26 (posix_getpwuid())
Bug #1033: Natural sorting function for customers doesn't work
Bug #1034: Froxlor Install / Upgraded SysCP: Unknown tables
Bug #1037: [security Bug] Customers can access all tickets
Feature #1010: Provide setting for special logfiles after creating domains
Feature #1017: Fast CGI Idle Timeout
Feature #1030: Use the name "Administrator" in the mail body instead of Froxlor-Team
Feature #1031: Improve customer default index.html file
Bug #1019: Debian GPG keyserver unreachable
Bug #1061: Current froxlor ebuilds needs non-existant php use flag "pcre" to build

 

 

 

We have moved our Git repository to Github. You want to share your code? Great! Please follow the instructions in the wiki post to get more information.

 

 

 

Download Froxlor 0.9.27 via tarball and Git

Visit www.froxlor.org or join our irc-channel #froxlor on irc.freenode.org.

 

 

 

Thank you,

 

Your Froxlor Team

  • Like 2

Share this post


Link to post
Share on other sites

Hello,

 

after i manually updated froxlor from 0.9.26 to 0.9.27 I get this error, when I want to start my Webserver:

 

 

Invalid command 'FcgidIdleTimeout', perhaps misspelled or defined by a module not included in the server configuration
failed!

 

I am running Debian 5 System with Apache2 FCGI & Suexec.

Share this post


Link to post
Share on other sites

hrm. please use mod_fcgid from backports (or upgrade to squeeze) 2.3.2 added that, it should work then, sorry about that, and before anyone asks, no it was an oversight and not supposed to happen.

 

speaking of lenny, plans are still that we are going to drop hardy and lenny from .28, more then ever before since time is limited, and lenny is EOL for a while, hardy not so much, but no one complained in my previous post so i can assume that no one is using it anyway.

Share this post


Link to post
Share on other sites
no one complained in my previous post so i can assume that no one is using it anyway.

 

Don't count on that! I'm still using Sarge on some machines :-)

Share this post


Link to post
Share on other sites

Hello,

 

after i manually updated froxlor from 0.9.26 to 0.9.27 I get this error, when I want to start my Webserver:

 

 

Invalid command 'FcgidIdleTimeout', perhaps misspelled or defined by a module not included in the server configuration
failed!

 

I am running Debian 5 System with Apache2 FCGI & Suexec.

 

Hello,

 

I'm on the same big trouble on my older installations. A dirty hack for that is to edit "FcgidIdleTimeout" to "IdleTimeout" in the froxlor working directory. The files are

./scripts/jobs/cron_tasks.inc.http.15.apache_fcgid.php Line 55

./scripts/jobs/cron_tasks.inc.http.10.apache.php Line 241

 

After that, you have to renew all configuration in froxlor admin.

 

That will work in my case. No warrantry at all...

 

The problem should be fixed later on.

 

Some more Background on that gives you apache.org :

http://httpd.apache....id.html#upgrade

 

I'm not happy about that. The froxlor developer team should really consider what they are doing...

Share this post


Link to post
Share on other sites

I think, that everyone who is willing to install froxlor, also knows how to install a webserver and so on. If i want to install froxlor with nginx, I'm kind of pissed by froxlor adding automatically all those apache things. Maybe there is a possibility to handle certain froxlor-packages. Maybe like this:

 

Package: froxlor-nginx (contains all packages you usually need for a nginx environment, including mail,ftp and so on); froxlor-apache (contains all packages you usually need for a apache environment and so on); maybe also one for lighttpd

 

AND there should be one like froxlor-only. So maybe froxlor-only or whatever, so with no dependencies.

 

(I hope my english is understandable wink.gif)

 

 

 

 

 

---------------------------------

 

 

Sac Longchamp Pliage

Share this post


Link to post
Share on other sites

Froxlor it not only for Debian, and maintaining this amount of packages i a lot of work, also not only the webserver changes - there can also be other mailserver-services and ftp-services, etc. would you want to maintain all these packages? froxlor-nginx-courier-proftpd - froxlor-nginx-courier-pureftpd, froxlor-nginx-dovecot-proftpd...etc.etc.etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...