Jump to content
Froxlor Forum
  • 0
scinaty

SSH Zertifikat wird erstellt, aber nicht verwendet

Question

Guten Abend,

 

ich habe Froxlor (Version 0.9.39.1-1 auf Debian) vor einiger Zeit installiert und das integrierte "lets encrypt" zur Erstellung der Zertifikate verwendet - alles hat super funktioniert. Nun sind die Zertifikate inzwischen abgelaufen. Unter "SSL Zertifikate" kann ich sehen, dass die Zertifikate erneuert wurden. Rufe ich die Seite hingegen auf, ist das Zertifikat abgelaufen. Es wird also offenbar ein anderes, veraltetes Zertifikat verwendet. Woran kann das liegen? Ich liefere gerne Informationen nach, wenn das zu allgemein ist.

Danke schon mal! Bereitet mir echt kopfzerbrechen 😕

 

image.thumb.png.e99353de71ee49d3876f755440623f04.png

image.png.b7d904f3951b233455b49b4381ea2a53.png

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 1
8 hours ago, scinaty said:

Ja super, das war das Problem! Ich habe den Apache mit 


sudo /etc/init.d/apache2 restart

neu gestartet und jetzt wird auch das korrekte Zertifikat verwendet.

das ging ohne irgendwelche Anpassungen? Warum konnte dann froxlor apache nicht neustarten? Hast du da einen anderen Befehl hinterlegt?

Denn laut log is der apache service nicht aktiv,

systemctl enable apache2.service

 

Share this post


Link to post
Share on other sites
  • 1

Lief denn der Cronjob zum Neuerstellen der Webserver Configs? Eventuell mal manuell anstupsen:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

Share this post


Link to post
Share on other sites
  • 1

Jo, dein apache startet aus irgendeinem Grund nicht (neu) - daher werden die neuen vhosts auch nicht übernommen:

Quote
  1. [information] apache::reload: reloading apache
  2. Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.

schau mal nach was er da zu meckern hat, vllt ist die lösung ganz einfach :)

Share this post


Link to post
Share on other sites
  • 1

Mach doch mal bitte auch eine

apache2ctl -t

Ergibt jedenfalls wenig Sinn das systemctl sagt der Apache2 läuft nicht und kann nicht starten aber über das init.d Skript geht es. Denn das init.d Skript sollte auch nur auf systemctl verweisen bzw. stellt nur eine abwärtskompatibilität dar.

Irgendwas ist da vermurkst!

Share this post


Link to post
Share on other sites
  • 0

Ja super, das war das Problem! Ich habe den Apache mit 

sudo /etc/init.d/apache2 restart

neu gestartet und jetzt wird auch das korrekte Zertifikat verwendet. Es wäre natürlich toll, wenn es auch noch automatisch gehen würde. Ich habe mal die beiden Befehle ausgeführt, die hinter der Fehlermeldung stehen:

root@+++:~# systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: failed (Result: exit-code) since Wed 2019-03-20 13:56:18 CET; 8h ago
  Process: 424 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Mar 20 13:55:57 +++ systemd[1]: Starting LSB: Apache2 web server...
Mar 20 13:56:18 +++ apache2[424]: Starting web server: apache2 failed!
Mar 20 13:56:18 +++ apache2[424]: The apache2 instance did not start within 20 seconds. Please read the log files to discover problems ... (warning).
Mar 20 13:56:18 +++ systemd[1]: apache2.service: control process exited, code=exited status=1
Mar 20 13:56:18 +++ systemd[1]: Failed to start LSB: Apache2 web server.
Mar 20 13:56:18 +++ systemd[1]: Unit apache2.service entered failed state.
Mar 20 22:27:54 +++ systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
Mar 20 22:29:07 +++ systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.


root@+++:~# journalctl -xn
-- Logs begin at Wed 2019-03-20 13:55:57 CET, end at Wed 2019-03-20 22:29:07 CET. --
Mar 20 22:29:07 +++ named[417]: reloading configuration succeeded
Mar 20 22:29:07 +++ named[417]: reloading zones succeeded
Mar 20 22:29:07 +++ systemd[1]: Reloaded BIND Domain Name Server.
-- Subject: Unit bind9.service has finished reloading its configuration
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit bind9.service has finished reloading its configuration
--
-- The result is done.
Mar 20 22:29:07 +++ rndc[4191]: server reload successful
Mar 20 22:29:07 +++ named[417]: zone ***.com/IN: has no NS records
Mar 20 22:29:07 +++ named[417]: zone ***.com/IN: not loaded due to errors.
Mar 20 22:29:07 +++ named[417]: zone ***.com/IN: has no NS records
Mar 20 22:29:07 +++ named[417]: zone ***.com/IN: not loaded due to errors.
Mar 20 22:29:07 +++ named[417]: all zones loaded
Mar 20 22:29:07 +++ named[417]: running

Ist das in irgend einer Weise zielführend?

Share this post


Link to post
Share on other sites
  • 0

Alles Volltreffer von euch und gelöst! Habe das alles nochmal komplett nachvollzogen, es ist widersprüchlich aber tatsächlich so wie von mir beschrieben. Für die Interessierten:

 

Mit 

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

konnte der Apache 2 NICHT neu starten.

systemctl status apache2.service

liefert "Active: failed (Result: exit-code) since Wed 2019-03-20 13:56:18 CET; 2 days ago" (und den Rest des outputs, siehe oben)

 

Trotzdem startet

sudo /etc/init.d/apache2 restart

den Apache 2 erfolgreich neu.

 

Nach 

systemctl enable apache2.service

Klappt aber auch

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

erfolgreich, und 

systemctl status apache2.service

liefert "Active: active (running) since Fri 2019-03-22 19:27:27 CET; 54s ago"

 

Großes Dankeschön 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...