Jump to content
Froxlor Forum
  • 0
lprod

Neuling mit Installationsproblemen

Question

Hei zusammen, 

ich hab jetzt einen neuen Server und hab aber im Prinzip noch keine Ahnung -irgendwie muss man ja anfangen. 
Hab von froxlor viel positives gehört und wollte das ausprobieren. 

Bei der Installation habe ich -- siehe Anhang -- zwei Problempunkte. Trotz vieler Befehle, die ich mir aus dem Internet zusammen gesucht habe, bin ich dafür zu blöd.

Was muss ich hier wie machen? 

Danke! 😄

Bildschirmfoto 2019-03-17 um 18.42.07.png

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

Erst einmal ein "HALLO" an alle..

Sicherlich fängt jeder mal an, trotzdem bevor Du eine Bombe ins Netz stellst die Dir vielleicht eines Tages mal um die Ohren fliegt, solltest Du Dich erst einmal mit dem Thema auseinandersetzen und Dir einen Linux Server local installieren. Und dafür brauchst man am Anfang eigentlich kein Server Management System was automatisiert ein paar Vhosts oder Datenbanken anlegt.

Auch wenn in der heutigen Zeit vieles einfacher geworden ist, wenn ich mich noch dran erinnere was es früher für eine Aktion war, Confixx auf einem Server zu installieren, da ist diese Klick und Bunty Geschichte von Frolox ein Kinderspiel.

Trotzdem gehört etwas mehr dazu einen Server sicher ins Netz zu stellen, als ein paar Klicks im Panel Menu zu machen.

Share this post


Link to post
Share on other sites
  • 0

sudo apt-get install curl 

sudo service apache2 restart 

sudo apt-get install php5-curl 

sudo service apache2 restart 

 

...und geht. Egal, thanks god es funktioniert ;-)!

Share this post


Link to post
Share on other sites
  • 0

So, jetzt geht es aber schon lustig weiter. 

Ich probiere jetzt, Mail- und FTPServer ans laufen zu bringen. 

root@net1:~# /usr/bin/nano /etc/proftpd/create-cert.sh

-bash: /usr/bin/nano: No such file or directory 

Weiß jemand, woran das liegt und wie ich das beheben kann? 
Beim Mail-Server kommen so ähnlichere (und viel verwirrendere) Sachen. 

Share this post


Link to post
Share on other sites
  • 0

einfach nur nano /etc/proftpd/create-cert.sh

alternativ: php /var/www/html/Froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/html/Froxlor/ --create

das install script erstellt dir alle confs selbst. daher brauchst dann keine copy&paste mehr machen.

 

Share this post


Link to post
Share on other sites
  • 0
vor 2 Minuten schrieb irisdina:

einfach nur nano /etc/proftpd/create-cert.sh

alternativ: php /var/www/html/Froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/html/Froxlor/ --create

das install script erstellt dir alle confs selbst. daher brauchst dann keine copy&paste mehr machen.

 

Danke, aber irgendwie will der Server nicht mit ... 😅

Bildschirmfoto 2019-03-17 um 21.06.05.png

Share this post


Link to post
Share on other sites
  • 0

apt install nano
das mit  php /var/www/html/Froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/html/Froxlor/ --create
ist der Standard Pfad für Froxlor, wenn du natürlich Froxlor unter einen anderen Pfad installiert hast, die zeile anpassen.

Ich empfehle dir, erst mal die Basic's von Linux zu lernen bevor du einen Server Produktiv einsetzt, erspart dir menge Ärger.
Desweiteren setze auf PHP7.x und nicht auf PHP5.x da letzteres EOL ist.

Share this post


Link to post
Share on other sites
  • 0

Froxlor ist bei mir unter'm Standardpfad ... 
Mir persönlich geht es nur darum, dass es läuft ;-). Einmal am Anfang den Server zum Laufen bringen und dann kann ich mit MySQL und PHP programmieren. 

Der Mailserver streikt- "von Anfang an". 

 

 

Bildschirmfoto 2019-03-17 um 21.56.00.png

Share this post


Link to post
Share on other sites
  • 0

Die Fehlermeldung sagt ja eig. schon alles, das eine dovecot.conf nicht vorhanden ist. entweder hast du diese vorher schon in eine .bak umbenannt.
Schau doch mal im Dovecot Verz. selbst nach.
cd /etc/dovecot 
ls -la

 

drwxr-xr-x   4 root root  4096 Feb 21 09:01 .
drwxr-xr-x 154 root root 12288 Mar 16 22:43 ..
drwxr-xr-x   2 root root  4096 Feb 21 14:54 conf.d
-rw-r--r--   1 root root  4398 Feb 21 09:01 dovecot.conf
-rw-r--r--   1 root root  4597 Feb 20 09:30 dovecot.conf.frx.bak
-rw-------   1 root root  6360 Feb 21 09:01 dovecot-sql.conf.ext
-rw-------   1 root root  6360 Feb 19 17:43 dovecot-sql.conf.ext.frx.bak
drwx------   2 root root  4096 Jan 28 14:49 private

 

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, lprod said:

Der Ordner existiert nicht ... 

Dann hast du wohl Dovecot nicht richtig installiert.
apt remove --purge dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve
apt install dovecot dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve

Welches OS ist eig. auf dem Server installiert?

Share this post


Link to post
Share on other sites
  • 0

1) richtiges OS ausgewählt für für Konfiguration

2) ich verstehe diese ganzen Fehler hier nicht, es ist doch stumpfes copy'n'paste - ziemlich straight forward, viel falsch machen kann man da nicht

Share this post


Link to post
Share on other sites
  • 0
vor 18 Stunden schrieb irisdina:

Dann hast du wohl Dovecot nicht richtig installiert.
apt remove --purge dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve
 apt install dovecot dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve

 Welches OS ist eig. auf dem Server installiert?

Debian Jessie. 

Package dovecot is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'dovecot' has no installation candidate

Was mir bei dem Server jetzt schon mehrfach "aufgestoßen" ist, dass hier so manche "Standards" einfach fehlen... 

Share this post


Link to post
Share on other sites
  • 0
vor 8 Stunden schrieb d00p:

1) richtiges OS ausgewählt für für Konfiguration

2) ich verstehe diese ganzen Fehler hier nicht, es ist doch stumpfes copy'n'paste - ziemlich straight forward, viel falsch machen kann man da nicht

1) Jo. 

2) Dachte ich auch ... 

Share this post


Link to post
Share on other sites
  • 0

Also k.A. was da bei dir los ist, aber wenn "nano" schon nicht installiert ist, hast du kein standard debian - dann stimmt da ja irgendwas nich. Vllt beschreibst du uns jetzt auch noch mal was genau genau jetzt aktuell das Problem ist, bzw. was du da genau gemacht/versucht hast

Share this post


Link to post
Share on other sites
  • 0

Ich tippe auf eine Debian Minimal Installation.

@Iprod
Du hast jetzt mehere möglichkeiten, entweder installiert du Manuel, alle Standard Sachen nach, wie Nano und co.
Dafür gibt es viele, How To's im Web, oder du installiert Debian neu, bsp direkt Stretch und Webserver (manche Anbieter), haben dafür vorgefertigte Templates.
Aber auf jedenfall solltest du die Basic's noch lernen für Linux.

Share this post


Link to post
Share on other sites
  • 0

Also, ich hab das jetzt nochmal probiert: Devecot will nicht. 

Provider ist dogado. Bei der Installation des Servers gibt es die Möglichkeit, Plesk direkt bei der Installation anzulegen - automatisch.

Also ich sehe erstens nicht ein, für die Plesk web host Edition (die vorinstalliert wird) im Monat 40€ (!!) zu bezahlen. Zweitens finde ich das ganze Handling von Plesk manchmal nervig. Monopolstellungen kann ich auch nicht ab... 

Macht es Sinn, eine Neuinstallation mit Plesk laufen zu lassen und dann froxlor drüber zu setzen?
Dann dürften die Standardprogramme ja wohl laufen. 

Bildschirmfoto 2019-03-19 um 21.23.02.png

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, lprod said:

Macht es Sinn, eine Neuinstallation mit Plesk laufen zu lassen und dann froxlor drüber zu setzen?
Dann dürften die Standardprogramme ja wohl laufen. 

 

Nein, das macht mehr kaputt dann, als es was bringt. 
Welche Service hast du in Anspruch genommen bei dogado, bzw. ist das überhaupt ein Dedicated Server oder eher ein V-Server etc?

Share this post


Link to post
Share on other sites
  • 0

Naja, aber offensichtlich ist es kein Standard Debian 8.... ;) Das haben wir ja schon festgestellt

Share this post


Link to post
Share on other sites
  • 0

Rufe pls mal die Source.list mit nano oder einen anderen ssh Editor auf und Poste diese hier mal.

also mit nano /etc/apt/source.list

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, lprod said:

Wie zu erwarten:

Absolut blanco.

Ok, von so einem Debian hab ich noch nie was gehört im Leben. Ich frag mal morgen deinen Anbieter mal per Tele, was die da genau benutzen, das interessiert mich selbst sehr.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Randall Newman
      I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.😓

    • By n8v8r
      CentOS 7.4 _x64 / PHP7.2.1 / Apache 2.4 / Froxlor 0.9.38.8
      Installation success, wanting to login the installation page keeps on returning, dejavu all over
      the browser console shows
       
       
    • By Boergi
      Hallo zusammen,
      ich bin leider ein wenig am verzweifel. 
      Ich habe froxlor über apt auf Debian Jessie installiert. 
      (Verwendete Anleitung: https://www.secretisland.de/froxlor-installation-debian/ )
      Froxlor lässt sich über
      http://[Server]/froxlor/
      einwandfrei erreichen.
      Dann nach
      http://www.servermom.org/how-to-install-froxlor-on-debian-or-ubuntu-vps/
      http://www.servermom.org/basic-setup-for-froxlor-control-panel/2757/
      konfiguriert. 
      Es hat alles ohne Fehler geklappt.
      Leider wird nach dem Erstellen von Kunden, domains etc keine Verzeichnisse erstellt.
      Es gibt nicht einmal  das customers Verzeichnis ( var/customers/ ) !!!
      Was mich allerdings Wundert ... 
      Im Admin Panel => System => Konfiguration  
      (ich weis nicht wozu das überhaupt ist - GLAUBE aber, das ist nur für das ÄNDERN des Servers. )
      Kann ich
      Distribution =>     Debian Jessie
      Service =>            Webserver
      Daemon =>            Apache 2.4
      auswählen. 
      Wenn ich aber das angegebene Komando
      chmod u+x example-script.sh
      ./example-script.sh
      ausführen möchte.. 
      root@testserver-deb8:/home/boergi# chmod u+x example-script.sh
      chmod: Zugriff auf „example-script.sh“ nicht möglich: Datei oder Verzeichnis nicht gefunden
      root@testserver-deb8:/home/boergi# ./example-script.sh
      bash: ./example-script.sh: Datei oder Verzeichnis nicht gefunden
      root@testserver-deb8:/home/boergi#
      wird das example-script.sh nicht gefunden.
      Obwohl ich ja nicht verstehe, wofür diese Konfiguration notwendig ist.... habe ich nach "example-script.sh" im Formum
      gesucht... Leider ohne relevanten erfolg.

      Weis jemand Rat - oder Info-Seiten, die mir bei meinem Problem (Verzeichnisse werden nicht erstellt)  helfen können.
      Vielen Dank für eure Hilfe
      Boergi
    • By Karthik
      I Installed froxlor in my New Droplet.  when I access ipaddress/froxlor/ Page.. Display Following codings...
       
      How can resolve my Issue.
       
       
       
       
    • By Onlinemarketing-Agentur
      Hello,
       
      I have been using Froxlor for a while now but one of the things I have always been missing is a modern system which helps me to save time. I am frequently setting up web sites for customers and to be honest, Froxlor's approach to installing applications is way too nerdy to give someone else this task, who is not really into it. Every large ISP has already got this somehow and I have always been wondering, why Froxlor is not going down this route:
       
      a one Click installation of any application I want would be terrific! - Forget the times, where you have been:
      1. starting a customer,
      2. giving him an email adress
      3. giving him an ftp
      4. giving him a mysql database
      5. download the application you want
      6. upload the application to the according path
      7. connect the application with the database
      8. connect customer with domain
       
       
       
      Hours of work could be saved for each and every person involved. 
      So PLEASE, PLEEEEEASE - I beg you guys, please get froxlor on the right track again or I have to move to proprietary solutions just to save time.. but this is not really the solution i want as most of my sites are managed fine by froxlor and i actually like the fact that I can handle every possible aspect with it..




×
×
  • Create New...