Jump to content
Froxlor Forum
  • 0
SeiboldSoft

fcgid Problem

Question

Hallo!

 

Ich betreibe einen Vserver mit Debian 6.0. Nach der Installation von Froxlor habe ich versucht fcgid zu installiern, weil ich Probleme mit den Schreibrechten von PHP hatte. Ich habe versucht alles genau nach der ANleitung zu machen, leider ging danach Apache nicht mehr neuzustarten. Es trat ein Problem mit den Vhosts auf: /etc/apache2/sites-enabled/20_froxlor_normal_vhost_...

 

Nachdem ich die Zeile auskommentiert habe, geht Apache wieder. Aber PHP funktioniert nicht mehr.

 

Ich hoffe hier kann mir jemand helfen ;)

 

Danke!

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Ich habe versucht alles genau nach der ANleitung zu machen

 

Welche Anleitung?

 

 

leider ging danach Apache nicht mehr neuzustarten.

 

Fehlermeldung?

 

 

Es trat ein Problem mit den Vhosts auf: /etc/apache2/sites-enabled/20_froxlor_normal_vhost_...

Welches Problem?

 

 

Nachdem ich die Zeile auskommentiert habe, geht Apache wieder. Aber PHP funktioniert nicht mehr.

Welche Zeile?

 

 

Logs, etc.?

 

http://forum.froxlor.org/index.php?/topic/1328-notice-before-you-post-your-issues/

 

Aussagekr?ftige Infos und Threadtitel bitte..

Share this post


Link to post
Share on other sites
  • 0

Entschuldigung f?r die etwas verschobene Fragestellung ;)

 

1) Ich habe mich an dieses Handbuch gehalten: http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch

 

2) Es erscheind die folgende Fehlermeldung:

 

 

Syntax error on line 11 of /etc/apache2/sites-enabled/20_froxlor_normal_vhost_nutzer.erzhost.de.conf:

Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

Action 'configtest' failed.

 

3) Die Zeilen:

php_admin_value open_basedir "/var/customers/webs/kelle/:/tmp/"

php_admin_flag safe_mode On

 

Wenn ich die Zeilen auskommentiere, geht der restart. Aber PHP geht danach nicht mehr...

Share this post


Link to post
Share on other sites
  • 0

Hast du die Schritte

 

FastCGI in Froxlor aktivieren

 

Abschlie?ende Schritte

 

vollst?ndig befolgt? Sieht so aus als ob Froxlor noch nicht wei?, dass es vHosts mit FCGID erstellen soll.

Share this post


Link to post
Share on other sites
  • 0

Als ich die Einstellung vorgenommen hatte, und den Server neustarten wollte kam die Fehlermeldung. Vielleich h?ngt es auch an Debian 6.0...

 

Wie kann ich vorgehen, um den Fehler wieder zu beheben?

 

EDIT:

 

Habe den Server heute nochmal installiert, alles klappt wieder. Wie kann ich jetzt auf Debian 6.0 das fcgid_Modul installieren? Gibt es da eine Anleitung?

 

Danke!

Share this post


Link to post
Share on other sites
  • 0

Ich habe es mit der selben Anleitung auf Debian 6 hinbekommen.

Du hast wahrscheinlich nur irgendwo einen kleinen Fehler gemacht.

Der Syntax-Error sagt, dass Froxlor seine Apache-Vhosts noch nicht neu geschrieben hatte.

Evtl. stimmten die Einstellungen im Froxlor nicht, oder der Cronjob ist noch nicht durchgelaufen.

 

huschi.

Share this post


Link to post
Share on other sites
  • 0

Ich habe es nochmal installiert, und es geht jetzt endlich! Vielen Dank!

 

Leider funktioniert aber phpmyadmin nicht, nach der Installation. Ich habe phpmyadmin mit apt-get install phpmyadmin installiert und dann mit ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d einen Link angelegt. Es sieht so aus, als ob in dem Ordner kein PHP verf?gbar ist. Was habe ich da falsch gemacht?

 

Danke ;) Thomas

Share this post


Link to post
Share on other sites
  • 0

Apache bring beim neustart folgende Warnmeldung:

 

[Thu Jan 19 13:41:13 2012] [warn] The Alias directive in /etc/apache2/conf.d/phpmyadmin.conf at line 3 will probably never match because it overlaps an earlier Alias.

 

Ich vermute, ich muss f?r phpmyadmin noch php freigeben. Ich weis nur leider nicht, wie ich das mache. Bin hier noch ziemlicher Dau, weil ich mich damit erst seit 2 Wochen besch?ftige.

Share this post


Link to post
Share on other sites
  • 0

Ich weis nicht genau, ob du diese Datei meinst: /etc/apache/sites-available/default

 

Inhalt:

 

<VirtualHost *:80>

ServerAdmin webmaster@localhost

 

DocumentRoot /var/www

<Directory />

Options FollowSymLinks

AllowOverride None

</Directory>

<Directory /var/www/>

Options Indexes FollowSymLinks MultiViews

AllowOverride None

Order allow,deny

allow from all

</Directory>

 

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

<Directory "/usr/lib/cgi-bin">

AllowOverride None

Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

Order allow,deny

Allow from all

</Directory>

 

ErrorLog ${APACHE_LOG_DIR}/error.log

 

# Possible values include: debug, info, notice, warn, error, crit,

# alert, emerg.

LogLevel warn

 

CustomLog ${APACHE_LOG_DIR}/access.log combined

 

Alias /doc/ "/usr/share/doc/"

<Directory "/usr/share/doc/">

Options Indexes MultiViews FollowSymLinks

AllowOverride None

Order deny,allow

Deny from all

Allow from 127.0.0.0/255.0.0.0 ::1/128

</Directory>

 

</VirtualHost>

 

Hilft dir das?

Danke!

  • Like 1
  • Downvote 1

Share this post


Link to post
Share on other sites
  • 0
The Alias directive in /etc/apache2/conf.d/phpmyadmin.conf at line 3 will probably never match because it overlaps an earlier Alias.

Ist es von einem Linux-Admin zuviel erwartet wenigstens ein bisschen Englisch zu k?nnen?

Sollte eigentlich nicht sein, oder?

 

Also langsam:

In /etc/apache2/conf.d/phpmyadmin.conf steht in Zeile 3 ein ServerAlias. Dieser ist aber bereits vorher definiert worden.

Aufgabe: Finde die Stelle, wo dieser ServerAlias zum ersten Mal vorkommt.

 

PS:

ErrorLog ${APACHE_LOG_DIR}/error.log

CustomLog ${APACHE_LOG_DIR}/access.log combined

Das steht da nicht wirklich, oder???

 

huschi.

Share this post


Link to post
Share on other sites
  • 0

Ich kann die Meldung durchaus lesen und verstehen. Der Alias wird schon in der apache2.conf vergeben. Wenn Ich die phpmyadmin.conf l?sche, verschwindet auch die Fehlermeldung.

 

Trotzdem geht phpmyadmin nicht zu starten. Beim Verzeichnisaufruf kommt nur ein Download Dialog von application/x-httpd-php

 

Der Dokumententyp ist allerdings vergeben.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×