Skip to content
View in the app

A better way to browse. Learn more.

Froxlor Forum

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

Froxlor auf debian 9 mit maria DB läuft nicht so richtig. Warum?

Featured Replies

mein Froxlor wurde auf debian 9 Vserver per Apt-get + web-Installation installiert.

Aber es läuft nicht so richtig. die Domain, die woanders gekauft wurde und per Weiterleitung auf die IP des Servers zeigt, kommt nur auf die Standardseite des Apachen.  Froxlor sitzt in var/www/froxlor   Die Vhosts-Einträge kommen nicht zustande .. woran kann das liegen.

auf dem Vserver ist auch Webmin installiert nur zur Info.

  • Replies 64
  • Views 14.6k
  • Created
  • Last Reply

Ich würde Mal tippen, du bist die Konfiguration nicht alle durchgegangen, der cronjob ist nicht eingerichtet und deswegen passiert nix

  • Author

d00p meinst während der Installation ? die sehr holperig ablief   oder beim Einrichten der Domain ?

Was wäre jetzt zu tun ?

froxlor.jpg

Edited by Typ01
Bild hinzugefügt

Installation ist ja nur das eine (was war denn holprig?). Danach passt du bitte alle einstellungen entsprechend deiner bedürfnisse und deines systems an und abschließend gehst du als admin auf "Configuration" und gehst die für deine distribution angezeigten dienste die konfigurations-schritte durch um die dienste einzurichten (auf keinen fall CRONJOB vergessen, Kategorie Others (system))

  • Author

Die cronjobs stehen auf aktiv, aber noch nie gestartet 01.01.1970 01:00

 

dann tu das was ich gerade geschrieben hatte :)

  • Author
vor 2 Minuten schrieb d00p:

Installation ist ja nur das eine (was war denn holprig?). Danach passt du bitte alle einstellungen entsprechend deiner bedürfnisse und deines systems an und abschließend gehst du als admin auf "Configuration" und gehst die für deine distribution angezeigten dienste die konfigurations-schritte durch um die dienste einzurichten (auf keinen fall CRONJOB vergessen, Kategorie Others (system))

ok , das werde ich erst noch tun..

  • Author

fehlermeldung:

apache2 -k restart
[Thu Dec 13 20:51:39.921072 2018] [core:warn] [pid 2991] AH00111: Config variable ${APACHE_RUN_DIR} is not defined
apache2: Syntax error on line 80 of /etc/apache2/apache2.conf: DefaultRuntimeDir must be a valid directory, absolute or relative to ServerRoot

 

wieso machst du denn "apache2 -k restart"? Wie wärs mit "service apache2 restart/reload"? Du brauchst ja nen init-script/service-script für apache (oder mindestens apache2ctl) welche entsprechende Umgebungsvariablen für dich setzt

  • Author
vor 19 Minuten schrieb d00p:

wieso machst du denn "apache2 -k restart"? Wie wärs mit "service apache2 restart/reload"? Du brauchst ja nen init-script/service-script für apache (oder mindestens apache2ctl) welche entsprechende Umgebungsvariablen für dich setzt

weil er erst gemeckert hatte es soll systemctl davor stehen, damit ging der neustart auch nicht  kann es sein das die Konfiguration des Apachen vom Webmin aus gemacht werden muss ? der war schon drauf.

spielt es eine Rolle, wenn froxlor im html steht statt im www das war eine der holprigkeiten bei der installation im www war froxlor nach der installation nicht zu erreichen.

könnte den vserver auch noch mal von vorn aufsetzen.

 

 

 

webmin? Was willstn jetzt damit? "systemctl reload apache2" geht natürlich genauso...

  • Author
vor 2 Minuten schrieb d00p:

webmin? Was willstn jetzt damit? "systemctl reload apache2" geht natürlich genauso...

ging eben nicht ...  ich frage nur, weil der drauf ist. und z.B. bestimmte verzeichnisse schon gesetzt waren z.B. sites-available usw.

 

hä? das verzeichnis /etc/apache2/sites-available/ etc. - das hat doch nix mit webmin zu tun?

Und "ging nicht" ist keine Fehlermeldung...WAS ging nicht? Was wurde ausgeben? Was stand in den Logs?

  • Author
vor 1 Minute schrieb d00p:

hä? das verzeichnis /etc/apache2/sites-available/ etc. - das hat doch nix mit webmin zu tun?

Und "ging nicht" ist keine Fehlermeldung...WAS ging nicht? Was wurde ausgebene? Was stand in den Logs?

:/etc/init.d# etc/init.d/apache2 restart
-bash: etc/init.d/apache2: No such file or directory
root@v......1:/etc/init.d# apache2 restart
Usage: apache2 [-D name] [-d directory] [-f file]
               [-C "directive"] [-c "directive"]
               [-k start|restart|graceful|graceful-stop|stop]
               [-v] [-V] [-h] [-l] [-L] [-t] [-T] [-S] [-X]
Options:
  -D name            : define a name for use in <IfDefine name> directives
  -d directory       : specify an alternate initial ServerRoot
  -f file            : specify an alternate ServerConfigFile
  -C "directive"     : process directive before reading config files
  -c "directive"     : process directive after reading config files
  -e level           : show startup errors of level (see LogLevel)
  -E file            : log startup errors to file
  -v                 : show version number
  -V                 : show compile settings
  -h                 : list available command line options (this page)
  -l                 : list compiled in modules
  -L                 : list available configuration directives
  -t -D DUMP_VHOSTS  : show parsed vhost settings
  -t -D DUMP_RUN_CFG : show parsed run settings
  -S                 : a synonym for -t -D DUMP_VHOSTS -D DUMP_RUN_CFG
  -t -D DUMP_MODULES : show all loaded modules
  -M                 : a synonym for -t -D DUMP_MODULES
  -t -D DUMP_INCLUDES: show all included configuration files
  -t                 : run syntax check for config files
  -T                 : start without DocumentRoot(s) check
  -X                 : debug mode (only one worker, do not detach)
root@v......1:/etc/init.d#

 

1 minute ago, Typ01 said:

/etc/init.d# etc/init.d/apache2 restart
-bash: etc/init.d/apache2: No such file or directory

entweder:

/etc/init.d/apache2 restart

oder wenn du im ordner /etc/init.d/ bist reicht ein:

./apache2 restart

aber im Verzeichnis /etc/init.d/ noch mal etc/init.d/apache2 ist klar das er das nicht findet. 

  • Author
vor 2 Minuten schrieb d00p:

entweder:

/etc/init.d/apache2 restart

oder wenn du im ordner /etc/init.d/ bist reicht ein:

./apache2 restart

aber im Verzeichnis /etc/init.d/ noch mal etc/init.d/apache2 ist klar das er das nicht findet. 

ok den ./ übersehen oder vergessen

 

  • Author

welchen DNS empfiehlst Du ?

 

Was hat das denn jetzt damit zu tun? Bitte mehr kontext...

  • Author
Gerade eben schrieb d00p:

Was hat das denn jetzt damit zu tun? Bitte mehr kontext...

ist der nächste Schritt in der Konfig... das apache hat mit ./ davor funktioniert

bind9 war schon drauf..  PowerDNS dazu machen oder nicht ?

 

verwaltest du denn den DNS deiner domains überhaupt selbst? Die wenigsten tun das...

  • Author
vor 9 Minuten schrieb d00p:

verwaltest du denn den DNS deiner domains überhaupt selbst? Die wenigsten tun das...

Ja und nein...  die Domains werden bei einem anderen hoster verwaltet, wo ich die Einträge auch selbst setzen kann, derzeit ist die domain aber direkt an die IP des VSErvers gebunden(umgeleitet)

die ip der domain sollte sowieso auf den server zeigen, meinst du den Nameserver eintrag?

  • Author
vor 1 Minute schrieb d00p:

die ip der domain sollte sowieso auf den server zeigen, meinst du den Nameserver eintrag?

ja die Nameservereinträge sind so eingetragen, dass der vserver den ich geradee konfiguriere darin steht.


jetzt kommt das erste mal ein Fehler.. den ich nicht deuten kann.

invoke-rc.d: initscript dovecot, action "restart" failed.
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2018-12-13 21:52:20 CET; 30ms ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 3876 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
 Main PID: 846 (code=exited, status=0/SUCCESS)

Dec 13 21:52:20 v.....1.c.....server.net systemd[1]: Starting Dovecot IMAP/POP3 email ser…r...
Dec 13 21:52:20 v......1.c......server.net dovecot[3876]: Fatal: Dovecot is already running …id)
Dec 13 21:52:20 v......1.c......server.net systemd[1]: dovecot.service: Control process exi…s=89
Dec 13 21:52:20 v......1.c.......server.net systemd[1]: Failed to start Dovecot IMAP/POP3 em…ver.
Dec 13 21:52:20 v......1.c.......server.net systemd[1]: dovecot.service: Unit entered failed…ate.
Dec 13 21:52:20 v......1.c.......server.net systemd[1]: dovecot.service: Failed with result …de'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package dovecot-core (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of dovecot-managesieved:
 dovecot-managesieved depends on dovecot-core (= 1:2.2.27-3+deb9u2); however:
  Package dovecot-core is not configured yet.

dpkg: error processing package dovecot-managesieved (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dovecot-sieve:
 dovecot-sieve depends on dovecot-core (= 1:2.2.27-3+deb9u2); however:
  Package dovecot-core is not configured yet.

dpkg: error processing package dovecot-sieve (--configure):

kann das daran liegen, dass ich im Postfix noch die root@vserver.....net  Emailadresse stehen habe ?

 

k.A. was du da tust...offenbar hast du mit jedem dienst probleme....normal ist so ein setup auf einem standard debian in 10-15min erledigt und funktioniert

Vllt solltest du einfach mal alles korrekt konfigurieren...lass dch mal folgendes laufen:

php /var/www/froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/froxlor --create

folge dem was da steht, da werden dir die dienste konfiguriert

Archived

This topic is now archived and is closed to further replies.

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.