Jump to content
Froxlor Forum
  • 0
ind

Apache2 runs, but fell inactive

Question

Hi, I upgraded from debian 7 to 8 (yeah - quite late) and so from apache2.4 to 2.4, before i go for debian 9 I need some help for this issue:

when I start apache I get this:

Nov 14 15:20:32 srv087 apache2[27920]: Starting web server: apache2 failed!
Nov 14 15:20:32 srv087 apache2[27920]: The apache2 instance did not start within 20 seconds. Please read the log files to discover problems ... (warning).
Nov 14 15:20:32 srv087 systemd[1]: apache2.service: control process exited, code=exited status=1
Nov 14 15:20:32 srv087 systemd[1]: Failed to start LSB: Apache2 web server.
Nov 14 15:20:32 srv087 systemd[1]: Unit apache2.service entered failed state.

but the server with the ID is running:

   27934	root	15:20	/usr/sbin/apache2 -k start
      27937	www-data	15:20	/usr/sbin/apache2 -k start
      27938	www-data	15:20	/usr/sbin/apache2 -k start
      27939	www-data	15:20	/usr/sbin/apache2 -k start

in the error log I get this:

[Wed Nov 14 15:20:12.229256 2018] [core:warn] [pid 27934] AH00098: pid file /var/run/apache2.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Nov 14 15:20:12.235164 2018] [mpm_prefork:notice] [pid 27934] AH00163: Apache/2.4.10 (Debian) OpenSSL/1.0.1t configured -- resuming normal operations
[Wed Nov 14 15:20:12.235224 2018] [core:notice] [pid 27934] AH00094: Command line: '/usr/sbin/apache2'

I would like to have apache in normal state ... , any suggestions?

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

solved 

changed in envars

export APACHE_PID_FILE=/var/run/apache2$SUFFIX.pid

into:

export APACHE_PID_FILE=/var/run/apache2/apache2$SUFFIX.pid

Share this post


Link to post
Share on other sites
  • 0

Yep

root@srvxx /var/www
$ /etc/init.d/apache2 stop
[ ok ] Stopping apache2 (via systemctl): apache2.service.

root@srvxx /var/www
$ /etc/init.d/apache2 start
[....] Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
 failed!

root@srvxx/var/www

 

Share this post


Link to post
Share on other sites
  • 0
-- Logs begin at Thu 2018-11-08 15:31:09 CET, end at Wed 2018-11-14 16:14:11 CET. --
Nov 14 16:13:38 srvxx dovecot[30185]: lda(root): msgid=<20181114145503.7359F21E0270@ssrvxx>: save failed to INBOX: Read-only mbox
Nov 14 16:13:38 srvxx postfix/local[30184]: 7359F21E0270: to=<root@srvxx>, orig_to=<root>, relay=local, delay=1116, delays=1115/0.01/0/0.16, dsn=4.3.0, status=deferred (temporary failure)
Nov 14 16:13:45 srvxxsrvxxsrvxx systemd[1]: Stopped LSB: Apache2 web server.
-- Subject: Unit apache2.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit apache2.service has finished shutting down.
Nov 14 16:13:51 srvxx systemd[1]: Starting LSB: Apache2 web server...
-- Subject: Unit apache2.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit apache2.service has begun starting up.
Nov 14 16:13:51 srvxx apache2[30226]: Starting web server: apache2httpd (pid 29324) already running
Nov 14 16:14:11 srvxx apache2[30226]: failed!
Nov 14 16:14:11 srvxx apache2[30226]: The apache2 instance did not start within 20 seconds. Please read the log files to discover problems ... (warning).
Nov 14 16:14:11 srvxxsrvxx systemd[1]: apache2.service: control process exited, code=exited status=1
Nov 14 16:14:11 srvxx systemd[1]: Failed to start LSB: Apache2 web server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Nov 14 16:14:11 srv087 systemd[1]: Unit apache2.service entered failed state.

 

Share this post


Link to post
Share on other sites
  • 0

I had to change the lockfile settings from default  

/var/lock/apache2/accept.lock

to
Mutex file:${APACHE_LOCK_DIR} default.

With the original setting apache wouldn't start

Might be there is an error in the mutex configuration which is


# Since there is no sane way to get the parsed apache2 config in scripts, some
# settings are defined via environment variables and then used in apache2ctl,
# /etc/init.d/apache2, /etc/logrotate.d/apache2, etc.
export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data
# temporary state file location. This might be changed to /run in Wheezy+1
export APACHE_PID_FILE=/var/run/apache2/apache2$SUFFIX.pid
export APACHE_RUN_DIR=/var/run/apache2$SUFFIX
export APACHE_LOCK_DIR=/var/lock/apache2$SUFFIX
# Only /var/log/apache2 is handled by /etc/logrotate.d/apache2.
export APACHE_LOG_DIR=/var/log/apache2$SUFFIX

any helpful hints are appreciated....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By j4mb4l4j4
      Hi, ich hätte mal eine simple Frage zum Thema Redirects.
      Wir möchten gerne folgende Redirects für eine Domain einrichten (siehe Screenshot für korrektest Beispiel aus dem Internet):
      http://www.domain.de   (301)   ->   https://domain.de https://www.domain.de (301)   ->   https://domain.de http://domain.de             (301)   ->   https://domain.de https://domain.de           (301)   ->   kein redirect Könnten wir dies im Froxlor Panel einstellen oder ist es hierzu erforderlich das wir die vHosts Configs der einzelnen Domains/Subdomains mit einer manuellen Config erweitern die die gewünschten Redirects aufweist ?
      Manuell würde ja bedeuten, dass Froxlor die Config nach 15min überschreibt.
      Können wir dies permanent hinzufügen oder gar im Panel ?
      Ich denke im worse Case dann über .htaccess oder ?
      Gerne würde ich natürlich im vHost anfangen statt in der unteren Ebene (.htaccess).
       
      Vielen Dank schon mal im Voraus.

    • By Fox
      Hallo,
       
      ich hab ein gr??eres Problem mit dem Froxlor GUI.
       
      Wenn ein Kunde bzw ich als Admin in einen Kunden einlogge und auf Datenbanken klicke kommt folgendes:

      We are sorry, but a MySQL - error occurred. The administrator may find more information in syslog with the ID 4df2ad9bbf7f66b980b30c924cad7650
       
      im Syslog befindet sich dann folgendes:

      May 22 06:01:33 mail Froxlor: [Administrator Action (ADMIN)] switched user and is now 'USER' May 22 06:01:35 mail Froxlor: MySQL - Error: Establishing connection failed, exiting; ErrNo: 0; Desc: ; Script: /customer_mysql.php?page=mysqls&; Ref: https://www.MYDOMAIN.com/customer_index.php?; 4df2ad9bbf7f66b980b30c924cad7650
       
      Dieser Fehler tritt NUR beim klicken auf Datenbanken auf. Alle anderen bereiche von Froxlor funktionieren einwandfrei.
      Es lief 2 Wochen problemlos, rund 10 Domains mit Datenbanken sind angelegt worden.
       
      Letzte erfolgreiche Aktion mit dem Men?:

      21.05.2012 19:35:07 [information] [administrator-action (ADMIN)] switched user and is now 'USER' 21.05.2012 19:35:58 [information] [customer-action (USER)] created database 'USERsql2'
      Unmittelbar danach trat der Fehler auf. Die Datenbank sowie der Datenbankeintrag ist noch erfolgreich gemacht worden.
       
      Ein Datenbankbackup vom Vortag brachte keine Besserung.
       
      Das einzig ?hnliche Problem wie hier beschrieben ist es nicht. Es ist ein neuer Gentoo Server mit MySQL 5.1
       
      Trotzdem w?re es hilfreich zu wissen wie ich das "error-supressing" aus machen kann um villeicht erweiterte Fehler zu bekommen.
       
      Vielen Dank schon mal im Vorraus
       
      Fox




×
×
  • Create New...