Jump to content
Froxlor Forum
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By MasterOfDeath
      Hello all,
      I deleted my old debian 7 and updated everything to new versions. However some problems exists and i cannot access my webpages.
      I did everything according to wiki pages and froxlor configurations but still some errors exists in below and not showing pages properly - only froxlor default page shown
      ● apache2.service - The Apache HTTP Server Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled) Active: active (running) (Result: exit-code) since Tue 2019-04-16 23:48:14 +03; 53min ago Process: 4850 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS) Process: 5958 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=1/FAILURE) Process: 4858 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS) Main PID: 4862 (apache2) Tasks: 13 (limit: 4915) CGroup: /system.slice/apache2.service ├─4862 /usr/sbin/apache2 -k start ├─4863 /usr/sbin/apache2 -k start ├─4864 /usr/sbin/apache2 -k start ├─4867 /usr/sbin/apache2 -k start ├─4868 /usr/sbin/apache2 -k start ├─4869 /usr/bin/php-cgi -c /var/www/php-fcgi-scripts/froxlor.panel/v22000.local/ ├─4874 /usr/sbin/apache2 -k start ├─4877 /usr/sbin/apache2 -k start ├─4878 /usr/sbin/apache2 -k start ├─4879 /usr/sbin/apache2 -k start ├─4880 /usr/sbin/apache2 -k start ├─4940 /usr/sbin/apache2 -k start └─5740 /usr/sbin/apache2 -k start Apr 16 23:48:14 v2201412723521843 systemd[1]: Started The Apache HTTP Server. Apr 17 00:33:51 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] rebuild configfiles due to changed setting Apr 17 00:34:45 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added user 'kaptan' Apr 17 00:35:16 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added domain 'kaptan.xyz' Apr 17 00:36:28 v2201412723521843 systemd[1]: Reloading The Apache HTTP Server. Apr 17 00:36:29 v2201412723521843 apachectl[5958]: AH00543: apache2: bad user name kaptan Apr 17 00:36:29 v2201412723521843 apachectl[5958]: Action 'graceful' failed. Apr 17 00:36:29 v2201412723521843 apachectl[5958]: The Apache error log may have more information. Apr 17 00:36:29 v2201412723521843 systemd[1]: apache2.service: Control process exited, code=exited status=1 Apr 17 00:36:29 v2201412723521843 systemd[1]: Reload failed for The Apache HTTP Server. ls -al /var/customers/webs/ total 1494612 drwxr-xr-x 9 root root 4096 Apr 17 00:36 . drwxr-xr-x 6 root root 4096 Apr 13 11:00 .. -rw-r--r-- 1 root root 1530439729 Apr 12 20:09 all_backup.zip drwxr-x--- 3 10009 10009 4096 Apr 17 00:39 kaptan drwxr-x--- 7 10002 10002 4096 Apr 13 18:41 kaptans drwxr-xr-x 8 root root 4096 Apr 13 18:55 NOTactiveWEB drwxr-x--- 3 10007 10007 4096 Apr 14 19:24 test  
    • By LostNIL
      Greetings,
      I have Froxlor installed with PHP7.2 and need to install/enable PHP7.2-fpm. I've reviewed the wiki, The Froxlor YouTube video on the subject, and reviewed/completed the instructions within the Panel > Configuration > DB Jessie > Other > FPM and am having difficulties getting the panel to work with FPM. 
      All available instructions are written for PHP5 and when I complete the instructions and substitute PHP7.2, when the panel generates configurations there are syntax errors and the websites go down. 
       
      Does anyone have any pointers or updated instructions on enabling FPM/PHP7+ with Froxlor. 
    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
    • By nisamudeen97
      Hi,
      We wish to enable HTTP/2 support in our forxlor server which is currently running apache server version "Server version: Apache/2.4.10 (Debian)".    Debian GNU/Linux 8 \n \l
      https://http2.pro/doc/Apache
      Has any one tried to enable the same in forxlor ?  We are running shared hosting.  Look forward to have detailed update.
       
    • By veto
      have now successfully a default froxlor + apache2 + mod_apache + php7  running.
      the problem is now that some php webapps are not supporting php7.
      i read the debian9 can run multiple php version 
      and i installed php 5.6 with
      apt-get install apt-transport-https curl https://packages.sury.org/php/apt.gpg | apt-key add - echo 'deb https://packages.sury.org/php/ stretch main' > /etc/apt/sources.list.d/deb.sury.org.list apt-get update https://pehapkari.cz/blog/2017/03/27/multiple-php-versions-the-easy-way/
      the manual is for nginx.
      i want now to run all virtual host with the default mod_php apache2 setting from froxlor but for some virtualhosts
      use another php handler like  php5.6-cgi or php5.6-fmp.
      there so many different setting possible and with the decaying search quality it difficult to find a staring point
       
       
       




×
×
  • Create New...