Jump to content
Froxlor Forum
  • 0
Exploit

Automatisches Anlegen von Sub-Domains

Question

Mir ist aufgefallen das viele eMail-Clients bei der Einrichtung eines Konto's automatisch Adressen wie "imap.example.com", "smtp.example.com", etc.. vorschlagen.

Beim Zuweisen einer neuen Domain, würde ich derartige sub-Domains gerne samt Let's Encrypt mit-einrichten, damit Kunden die Standard-Einstellungen einfach übernehmen können. Am liebsten ohne das sie zwangsläufig im Panel unter den Domains erscheinen. Ist das machbar oder kann ich das ohne allzu großen Aufwand machbar machen?

Da ja gerade sowieso einiges auf API umgestellt wird, vielleicht ein guter zeitpunkt ;)

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
21 minutes ago, Exploit said:

Mir ist aufgefallen das viele eMail-Clients bei der Einrichtung eines Konto's automatisch Adressen wie "imap.example.com", "smtp.example.com", etc.. vorschlagen.

Nur wenn die Autokonfiguration nichts findet / übermittelt bekommt. Besser wäre es dies auf deinem Server zu implementieren.

Wenn Du für jede Domain die E-Mailservices so aufbauen willst mußt du auch entsprechend viele postfix und dovecot installieren und laufen lassen mit jeweils einer eigener IP-Adresse - also heutzutage eigentlich unmöglich wegen der IPv4-Knappheit. Es gibt bei E-Mail kein SNI wie bei einem Webserver.

Share this post


Link to post
Share on other sites
  • 0

Also Autokonfiguration ist eine schöne Sache! auch das erfordert allerdings das Subdomains angelegt werden, dazu dann noch die XML-Dateien.

In Prinzip kann Froxlor ähnliche Sachen ja schon, mit dem www-Alias und der Default index.html beim Anlegen einer Domain und der Standard-Subdomain beim Anlegen von einem neuen Kunden. Werde mich mal an den Entsprechenden Stellen im Quellcode umschauen, ob die autoconfig dort mit herein passt.

Share this post


Link to post
Share on other sites
  • 0

eh...hä? Das ist EIN globaler Alias, du erstellst diese XML einmal...die gilt für alle

Share this post


Link to post
Share on other sites
  • 0

Hmm, das stimmt, die XML's sind bei allen domains gleich. Habe ich etwas in Froxlor übersehen, oder muss ich das manuell konfigurieren?

Habe mir dazu diese Anleitung durchgelesen: Im Idealfall sind demnach ja unter jeder Domain diese beiden Pfade erreichbar:

autoconfig.example.com/mail/config-v1.1.xml
autodiscover.example.com/autodiscover/autodiscover.xml

 

Share this post


Link to post
Share on other sites
  • 0

Auf den ersten Blick, kein Problem. Einen Virtualhost anlegen mit "autoconfig.*"- und "autodiscover.*"-Aliasse, Fertig!

Nur funzt das nicht mit SSL, das muss dann wieder per Chronjob mit Froxlor's Domaintabelle gemacht werden, also kann mann es quasi gleich in Froxlor einbauen...

.. Vielleicht komme ich die Woche mal dazu...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...