Jump to content
Froxlor Forum
  • 0
Pierre

SMTP Error sit ca. 3 Wochen

Question

Ich nutze eine kleine PHP-Datei als kontakt.php - sprich als kontaktformular.

Dieses lief bis vor ca. 3 Wochen tadellos. Jedoch seit ca. 3 Wochen gibt es folgende Fehlermeldung aus, dass es die E-Mailadresse (Admin des Portals) an den die Nachrichten des Kontaktformulars gehen nicht findet, bzw. das diese nicht existieren würde, obwohl sie existiert und erreichbar ist und auf dem selben Server für die gleiche Domain liegt:

SMTP Error: The following recipients failed: meine-emailadresse@meinedomain.de

Innerhalb des Portals werden z.B. alle Newsletter, Paidmails etc. ohne Probleme über SMTP versendet.

Wurde mit dem letzten Froxlor Update irgend etwas geändert was dies auslöst (from oder reply-to)?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
6 hours ago, Pierre said:

Wurde mit dem letzten Froxlor Update irgend etwas geändert was dies auslöst (from oder reply-to)?

Nicht dass ich wüsste. Was sagt denn die mail.log dazu?

Share this post


Link to post
Share on other sites
  • 0

Guten Abend,

 

das sagt die mail.log dazu: (habe die Namen und Domain sowie IP durch freie Anzahl an XXXX ersetzt)

Mar 15 22:03:28 server postfix/smtpd[16889]: connect from server.XXXXXX.de[84.38.74.XXX]

Mar 15 22:03:28 server postfix/smtpd[16889]: NOQUEUE: reject: RCPT from server.XXXXXX.de[84.38.74.XXX]: 553 5.7.1 <XXXXXX@vodafonemail.de>: Sender address rejected: not owned by user reda@XXXXXX.de; from=<XXXXXX@vodafonemail.de> to=<besu@XXXXX.de> proto=ESMTP helo=<www.XXXXX.de>

Mar 15 22:03:28 server postfix/smtpd[16889]: lost connection after RCPT from server.XXXXXXX.de[84.38.74.XXX]

Mar 15 22:03:28 server postfix/smtpd[16889]: disconnect from server.XXX.de[84.38.74.XXX]

 

Seltsam ist dies:

not owned by user reda@XXXXXX.de;

obwohl die E-Mailaddy dem User zugeordnet ist.

Wie gesagt das passiert nur wenn über das Kotaktformular (kontakt.php) mit SMTP gesendet wird.

Innerhalb des Portals alle Newsletter, Paidmails etc. laufen mit den gleichen Emaildresse tadellos.

Share this post


Link to post
Share on other sites
  • 0

du setzt als absender xxx@vodafonemail.de und benutzt das konto reda@xxxx.de zum senden....das wird nix

Share this post


Link to post
Share on other sites
  • 0

Guten Morgen,

xxx@vodafonemail.de

ist die E-Mailadresse des User / der Userin die das Kontaktformular ausfüllt, also der Absenderin / des Absenders.

reda@xxxx.de

ist das Mailkonto / SMTP

Wie ich schon anfangs erwähnt, ging das das bisher 5 Jahre tadellos bis vor ca. 3 Wochen, dass die Empfänger E-Mailadresse nicht mehr gefunden wird, also die E-Mailaddy an die das Kontaktformular die Nachricht sendet, nämlich an den Seiten- bzw. Portaladmin.

 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Pierre said:

xxx@vodafonemail.de

ist die E-Mailadresse des User / der Userin die das Kontaktformular ausfüllt, also der Absenderin / des Absenders.

reda@xxxx.de

ist das Mailkonto / SMTP

[...] from=<XXXXXX@vodafonemail.de> to=<besu@XXXXX.de> [...]

Ich sagte doch bereits wo das problem ist, anscheinend willst du mir nicht glauben :)

Wenn xyz@vodafonemail.de die email des besuchers ist der das formular ausfüllt, wieso versuchst du dann mit seiner adresse die mail zu schicken?

Share this post


Link to post
Share on other sites
  • 0

Hallo,

ich vermute mal, das du die E-Mail-Adresse des Besuchers benutzt hängt damit zusammen, das du direkt auf die E-Mail antworten willst, ohne die Mail-Adresse erst aus dem Content der Mail rauszukopieren.
Dies erreicht du aber auch, wenn du die Adresse des Besuchers auch als "reply-to"-Adresse angeben. Die "from"-Adresse muss aber, wie D00p ja schon gesagt hat mit der übereinstimmen, mit der du dich am SMTP-Server authentifizierst.

Das du die Fehlermeldung erst seit 3 Wochen bekommst könnte in Updates deines Servers liegen. Ich gehe mal davon aus, das du regelmäßig updates deiner Softwarepakete vornimmst. Im Rahmen dieser Updates wird sicher auch mal der SMTP-Server aktualisiert worden sein und dieser verbietet es inzwischen das es einen unterschied zwischen Absender und authorisiertem Benutzer gibt.

Am besten also einfach das Script ein kleinwenig anpassen und schon steht dem weiteren Mail-Versand nichts mehr im Wege.

Gruss cardman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
    • By Randall Newman
      I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.😓

    • By Patrick Walters
      Hallo,
      ich kenne seit einige Jahren Froxlor und verwende es auch sehr gern. 
       
      Ich habe 2 Probleme und 1 Fragen und hoffe mir kann geholfen werden.
       
      Zur Hintergrund-Information, ich verwende Debian 8 (64bit) und Postfix mit Dovecot.
       
      1. Der Mailversand via Webmailer (Auf gleichen Server) funktioniert, aber in den Mail-Header steht:
      Received: from pexmedia.de (unknown [185.101.92.201]) by pexmedia.de (Postfix) with ESMTPA id 0D8C43C0ECE Der Mailserver sollte eigentlich mail.pexmedia.de sein, der SMTP-Server smtp.pexmedia.de und der IMAP-Server imap.pexmedia.de mit den jeweiliegn Standartports.
      Warum steht vor der Server-IPAdresse unknown? Und wie behebt man es?
       
      2. Die Zugangsdaten für SMTP/IMAP stimmen, jedoch kann kein externes E-Mail Programm die Verbindung erfolgreich herstellen. Kurz gesagt seine Mailkonten kann man nicht mit Mailprogrammen wie Outlook etc. verwenden.
      In /var/log/mail.warn steht:
      Jan 31 04:44:24 mail postfix/smtpd[13385]: warning: unknown[46.44.171.19]: SASL LOGIN authentication failed: UGFzc3dvcmQ6 Jan 31 04:44:25 mail postfix/smtpd[13412]: warning: hostname rt171bb44-46-19.routit.net does not resolve to address 46.44.171.19: Name or service not known Jan 31 04:44:25 mail dovecot: auth: Warning: auth client 0 disconnected with 1 pending requests: Connection reset by peer Beim Versuch mit ein E-Mail Programm die Verbindung aufzubauen. Woran lliegt es?
      Im weiteren steht:
      Jan 31 06:46:17 mail postfix/smtpd[16068]: warning: hostname 201.92.101.185.in-addr.arpa does not resolve to address 185.101.92.201: Name or service not known Mein rDNS Eintrag ist: 201.92.101.185.in-addr.arpa 
      Wie sollte mein rDNS Eintrag denn lauten?
       
      In einer Version von Froxlor die ich mal hatte lief alles reibungslos.
       
      3. Mails von meinem Mailserver kommen bei Google in den Spam-Ordner. Liegt vilt. daran das Google die Mail als nicht verifiziert eingestuft hat. Wie mache ich das am dümmsten? 
       
      Die Configs sind die Standartkonfrigurationen von Froxlor.
       
      Hoffe mir wird geholfen. 
       
    • By LukasH
      Ich hab mal wieder ein Problem bzw. einen Fehler mit unguten Auswirkungen begangen und bekomme es nicht mehr gerade gebügelt.
      Und zwar habe ich nach anfänglichem Testen mittlerweile auch mein privates Mailkonto auf einen neuen Server mit Froxlor gezogen.
      Ich hatte wie erwähnt bereits vorher einen Umzug mit Website, daher auch Datenbanken so wie Mailadressen erfolgreich durchgeführt. Der Umzug lief auch relativ glatt und auch meine privaten Mails liegen auf dem neuen Server, senden funktioniert, alle Websites sind via https erreichbar (Letsencrypt Zertifikate erfolgreich gezogen) und alles könnte eigentlich besser nicht sein. 
      Nun kann ich mich allerdings von Extern nicht mehr am smtp Server anmelden mit meiner privaten Mail-Adresse. Und zwar wollte ich in meiner noch Unwissenheit (das ist mein erstes "eigenes" Serverprojekt, meine ersten Server wurden durch andere eingerichtet und ich habe nur zugekuckt/mitgeschrieben) SSL Zertifikate für den Mailserver bekommen, Outlook hat nämlich die überaus nervige Angewohnheit bei jedem Start Zertifikatsfehlermeldungen auszugeben (bei Selbstsignierten) und auch das Speichern in den vertrauenswürdigen Zertifikatsspeicher von Windows bringt hier scheinbar keine Lösung.
      Nun dachte ich, ist ja einfach, einfach in Froxlor für jede Domain welche auch Mailadressen hat noch die Subdomain "mail.*" und "smtp.*" anlegen, LetsEncrypt anschmeißen und fertig, den Verweis stelle ich einfach auf den Ordner in welchem der Webmailer liegt. Soweit so gut, nun hat er hier allerdings keine Zertifikate gezogen sondern nur am laufenden meter PHP Errors ausgegeben. Diese hatte ich vorher immer wenn der PHP Flag für eine Domain nicht richtig gesetzt war, also mit dem admin in Froxlor eingelogt, Domain aufgerufen und gespeichert und... nichts. Gleicher Fehler. PHP Funktioniert (Webmailer wird korrekt aufgerufen) nur werden keine Zertifikate gezogen. 
      Also wollte ich erst einmal alles rückgängig machen und habe alle Subdomains (mail.* & smtp.*) wieder gelöscht. So und nun habe ich den Salat, seltsamerweise kann noch sämtliche Mailkonten von extern ansteuern, auch den jeweiligen smtp nur bei meiner privaten Mailadresse mit eigener Domain geht es nicht, auch nicht mehr bei der meiner Frau mit gleicher Domain. Outlook fragt nach den SMTP Zugangsdaten und nimmt Mailadresse + Passwort nicht, Thunderbird sagt er findet das Passwort nicht, iPhone & Android bringen ebenfalls diese Fehler. 
      ALLE anderen Domains bzw. verbundenen Mailkonten funktionieren (bis auf den Punkt mit dem Zertifikatsfehler) problemlos. Nur die meiner Hauptdomain nicht. 
      Das ganz komische ist aber, dass mein Webmailer noch ganz normal Empfangen und vor allem auch Senden kann, dieser erreicht den SMTP Server ohne Probleme und hat auch keine Login Probleme. 
      Ports sind Frei in der Windows eigenen Firewall, Ping an smtp.* geht problemlos durch, ich habe auch keinen Speedport mit vertrauenswürdiger E-Mail Liste sondern eine Fritz!Box. Bis vor 2 Stunden lief auch noch alles. Und ganz kurios ist auch, dass Outlook den smtp Server bei einer anderen Domain auf "smtpauth.*" geändert hat, Thunderbird geht allerdings via "smtp.*" ran. 
      Nun noch Screenshots von meinem Webmailer (Rainloop) und der dort voll funktionalen Konfiguration welche aber von Extern (egal ob mein Heimnetz (Unitymedia) oder Handynetz (Telekom & O2)) nicht laufen will:




    • By martinvh
      Hello everybody,
      in the monthly Froxlor usage report I'm getting the message PHP Warning:  stream_socket_enable_crypto(): Peer certificate CN=`<my Froxlor domain>' did not match expected CN=`localhost' in /var/www/froxlor/lib/classes/phpmailer/class.SMTP.php on line 369
      The mail is being sent to the systems root account, which is mapped in /etc/aliases to an existing Froxlor mail account (webmaster@<my Froxlor domain>). Is this related to the Froxlor admin user, whos mail address is the same? Either way, why is the function expecting the local CN instead of the FQDN one? What is the correct setting in this case, or how can I mitigate the warning? The only cause effect I discovered is, that mails cannot be sent to new mail accounts via the alternate mail address, which results in the same error.
      Thanks in advance,
      Martin


×