Jump to content
Froxlor Forum
  • 0
shaaz

How to Install froxlor with single database user and password?

Question

Is that possible to install froxlor in c-panel using one database user password?
Or how can we skip the values of mysql_unpriv_user and mysql_unpriv_pass while installing?

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

makes no sense, froxlor requires a privileged database user to be able to create databases and users, for security-reasons, the user that does "all the other stuff" should be unprivileged where possible

Share this post


Link to post
Share on other sites
  • 0

I am back end developer. My client needs to install this in his c-panel, but I don't have access to create  mysql_unpriv_user and mysql_unpriv_pass in his database. So is that possible to install?

Share this post


Link to post
Share on other sites
  • 0

I don't get it...if you are using cPanel, why would you want to install froxlor? This makes no sense. froxlor is a server management interface...

Share this post


Link to post
Share on other sites
  • 0

lol...if you think so. Then i'll just say "no"...happy?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Joso
      Hi,
      after a hard work I arrived at the configuration of froxlor and also here we find the difficulties for the configuration.
      I have to admit, there are no tutorials that guide the user in every part of the configuration. So I hope in this forum to complete everything.
      Apart from the premise, I found the error indicated by the flooded image. How do you solve it?
       
      Thanks

    • By wwl
      Hallo, ich stelle fest das Froxlor ständig um die 10 Datenbankverbindungen aufrecht erhält. Normalerweise sollte doch nur eine Verbindung in Verwendung sein, der vom Cron gebraucht wird. Ok, wenn gerade viel konfiguriert wird, kann es auch mal mehr sein. Aber ständig 10 Connections ist sehr viel weil auch InnoDB Datenbanken viel Speicher brauchen.
      Gibts da eine Lösung?
      Christian
    • By irisdina
      Debian (9) Stretch
      1. 
      sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install
      wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list )
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2.  MariaDB Install
      use sudo command for install MariaDB!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional)
      when you MariaDB install with not sudo command, have you Problems with your Froxlor install. 
      you can use this workround: (Thanks J-BBB for this Note  )
      mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      3c. 
      service nginx restart 4. PHP install
      sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a.
      service nginx restart service php7.1-fpm restart  
      Ubuntu 17.10 (Artful)
      1. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list )
      1c. Key Install
      sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987)
      sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3.  MariaDB Install
      sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional)
      when you MariaDB install with not sudo command, have you Problems with your Froxlor install. 
      you can use this workround: (Thanks J-BBB for this Note  )
      mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install
      sudo apt install nginx 4a. nano /etc/nginx/nginx.conf
      4b. 
      service nginx restart 5. PHP install
      sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a.
      service nginx restart service php7.1-fpm restart  
      Froxlor Install Git version
      1. vhost
      nano /etc/nginx/sites-enabled/frox 1a. 
      service nginx restart 2. Change dir
      cd /usr/share/nginx/ 2a. Froxlor git Load
      sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename
      mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder
      sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open
      http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor

      Install Froxlor finish
      3d. Move userdata (Optional)
      mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete
      rm /etc/nginx/site-enable/frox don't restart nginx!
      Froxlor Settings
      1. cronjob
      nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * *    root    /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel
      1. Change your PHP-Backend Settings
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock
      2. Make Folder and Change chmod
      mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob
      Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install
      sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd:         compat extrausers group:          compat extrausers shadow:         compat extrausers hosts:       files dns networks:    files dns services:    db files protocols:   db files rpc:         db files ethers:      db files netmasks:    files netgroup:    files bootparams:  files automount:   files aliases:     files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. Settings > PHP-FPM > Settings
      Change > Configuration directory of php-fpm to 
      /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to
      /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note)
      sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate
      1. Create Folder on nginx
      mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf
      nano /etc/nginx/acme.conf location /.well-known/acme-challenge {     alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge;     location ~ /.well-known/acme-challenge/(.*) {         default_type text/plain;     } } 2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain

       
    • By NitroxydeX
      Hallo Community und Staff,
      bezüglich eines Serverwechsel stande nun auch eine Änderung des Control Panels an, da unser bisher genutztes einfach zu wenig geupdatet wurde und Fehler selbst gefixt werden mussten.
      Es blieb eigentlich nur Froxlor übrig. Allerdings haben wir nun feststellen müssen, dass man bei Froxlor nicht die Möglichkeit hat den Datenbanknamen und Nutzer frei zu wählen, was viele als hohes Sicherheitsrisiko werten. Warum ist dies so gewählt? Und gibt es bereits jetzt schon eine Möglichkeit das zu aktivieren?
      Zum anderen Problem: Froxlor scheint magisch alles abzufangen. Bislang hatte ich Apache so konfiguriert, dass alle nicht vorhanden Vhosts ins 403-Forbidden Nirvana gesendet werden. Gleiche Konfiguration habe ich nun auch mit Froxlor versucht und mein Abfangen als 01-beginnende Apache config hinterlegt. Dies fängt auch direkte Aufrufe der IP ab, allerdings funktioniert dies weder mit der IP noch mit nicht angelegten (Sub)-Domains. Es wird immer automatisch auf den FQDN des Panels umgeleitet, was eigentlich gar nicht möglich sein sollte. 
       
      Vielen Dank schon mal für die Antworten
    • By Hadet
      Hi so i'm pretty new to this, I have a LAMP stack running on Ubuntu 16.04 Amazon's Lightsail EC2 style platform similar to DigitalOcean's droplet setups
      So far i got everything setup, php-7 is installed, mysql is installed and it's all working i installed Froxlor with no errors, i've even setup the Mail Server and FTP though i haven't been able to test those yet
      I'm currently taking classes for sysadminstration and web development but my experience is still at a beginer level. If anyone can tell me what i set up wrong or need to change, i'd really appreciate it. It took me a long time to get this running because all the documentation was very out of date, i ended up doloading the latest version and extracting it in my var/www/html/ directory, i can access the pannel and even login to the admin account i set up during the setup phase.
      When trying to add a new user to test thing i get the following message once i've filling everything out
      A database error occurred SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1
       
      EDIT: Also redtext sorry not familiar with this forum setup. SO it DID add the User, but i'm still getting Mysql errors on things like email.I followed the instructions to the letter through ssh everything should be good. I've gone through them twice step by step to make sure.
      Rebuilt the whole LAMP stack from the ground up, configured everything exactly how it said to in the config guides
      Here's the Rerror it gives.
      Dear froxlor-team,

      the following error has been reported by a user:

      -------------------------------------------------------------
      01000 SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1

      File: /lib/classes/database/class.Database.php:72

      Trace:
      #0 /lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
      #1 /admin_customers.php(935): Database::pexecute(Object(PDOStatement), Array)
      #2 {main}

      -------------------------------------------------------------

      Froxlor-version: 0.9.38.7
      DB-version: 201612110

      End of report
       


×