Jump to content
Froxlor Forum
  • 0
luovis

Website for the host; unknown error, system_ipaddress

Question

Hello,

I would like to have my hostname domain to have a website and I found in the forum that in order to do that I would need to get panel to the subdomain.

1) How do I change the hostname given in the format mydomain.com in the installation process to host.mydomain.com?

I tried to change it straight in the Settings => System Settings but anything I try to edit there (or even without editing anything but trying to save) I get this:

Error
Unknown Error (not in option): system_ipaddress

Back

I have nothing in the menu IP's and Ports, but didn't want to start putting there anything by trial and error.

2) If I get the hostname changed, can I make the webspace for the own site using the menu "Domains"? I have already made a "customer" for it.

I've used this guidance for installing Froxlor:
https://gridscale.io/en/community/tutorials/install-froxlor-ubuntu/

I'm using Linode as a cloud server.

Thank you for your advices.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

German thread about this: 

 

On 2.11.2017 at 9:07 AM, luovis said:

I have nothing in the menu IP's and Ports,

There should be at least ONE ip after the installation, are you sure this went without any errors/warnings? Can you check whether mysql STRICTMODE is enabled? it needs to be OFF

On 2.11.2017 at 9:07 AM, luovis said:

If I get the hostname changed, can I make the webspace for the own site using the menu "Domains"? I have already made a "customer" for it.

Yes. Doing the exact thing myself. 'froxlor.domain.tld' for froxlor and 'domain.tld' as customer.

Share this post


Link to post
Share on other sites
  • 0

I have added this to the file /etc/my.cnf in mysql configuration, to get rid off strict mode.

[mysqld]
sql_mode="TRADITIONAL,NO_AUTO_CREATE_USER"

What should I put in to the Froxlor IP and Ports now (it's empty and needs something)? Yes, the IP I know since it should be the server IP, but which port and what about the other settings in it? Is there any sample screenshot of a working installation?

Share this post


Link to post
Share on other sites
  • 0

as said, the initial setup should've filled that already. Port is of course 80 or 443 (ssl). The other settings are self-explaining

Share this post


Link to post
Share on other sites
  • 0

Ok, I've put the IP, Port etc.

Now if I try to change the hostname in System Settings it gives me this:

Error
Unknown Error (not in option): system_defaultip

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, luovis said:

Ok, I've put the IP, Port etc.

Now if I try to change the hostname in System Settings it gives me this:

Error
Unknown Error (not in option): system_defaultip

When you, change the hostname, mark your IP in the Default IP/Port Block, and you has no error.

5a230a5991488_ipport.thumb.JPG.44f55472c026cce96a66737d1e20a0a6.JPG

Share this post


Link to post
Share on other sites
  • 0

Thanks irisdina, 

the IP is already correct because I'm trying to correct like mydomain.com to be host.mydomain.com in the hostname (system settings). Above it is written the default IP with the port 80 but if I edit and try to change the 

mydomain.com
=> 

host.mydomain.com 

it indeed says this "unknown error (not in option): system_defaultip".

Share this post


Link to post
Share on other sites
  • 0

If I would install all from the scratch, what is the point that I would say for the system that the hostname is host.mydomain.com instead of only mydomain.com? Because this is really not going further like this. Maybe it is a tiny thing to adjust but since the advices are not working, maybe something is just crucially wrong.

Share this post


Link to post
Share on other sites
  • 0

Your Hostname is Name from your Server.
Login to ssh and use this command: hostname and look your hostname
or change your hostname to example.server.tld

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By Marco Dieckhoff
      Hallo,

      Ich habe denselben Fehler wie in https://forum.froxlor.org/index.php?/topic/13329-solved-unknown-error-not-in-option-system_ipaddress/&_fromLogin=1#replyForm bei einer frischen Installation.


      Strato V-Server
      Ubuntu 16.04 LTS (frisch installiert und voll geupdatet)
      Webserver: Apache/2.4.18 (Ubuntu)
      PHP-Version: 7.0.22-0ubuntu0.16.04.1
      MySQL-Server-Version: 5.7.20-0ubuntu0.16.04.1

      Installierte Version: 0.9.38.7 (DB: 201612110)

      Installiert nach https://gridscale.io/community/tutorials/froxlor-installieren-ubuntu-16-04-lts/


      Beim Anlegen einer Domäne gab es keine Auswahl für das Feld "IP-Adresse(n) *:" und "SSL-IP-Adresse(n):".

      Auf der Suche nach den IPs habe ich in Einstellungen - Systemeinstellungen geschaut.

      Wenn man dort auf Speichern klickt, erhält man die Fehlermeldung:

      Fehlermeldung
      Unknown Error (not in option): system_ipaddress

      Wenn ich mir den Quellcode der Seite ansehe, gibt es dort mehrere system_ Variablen, von system_documentroot_prefix bis system_mail_smtp_passwd, aber KEIN Feld für system_ipaddress.

      Log-Einträge dazu konnte ich nirgendwo finden - kann man ggf. das Logging noch höher drehen irgendwo?

      Grüße
      Marco

    • By Buckshot
      Hallo,
       
      ich habe Froxlor 0.9.34.2 auf Debian 8 mit nginx 1.9.12, PHP 7.0.4 (FPM) und MySQL 5.6.29 eingerichtet.
       
      Läuft auch alles einwandrei, bis auf, wenn ich in Froxlor unter Server > Einstellungen auf die Systemeinstellungen gehe und versuche diese zu speichern (mit oder ohne Anpassungen) kommt die Fehlermeldung Unknown Error (not in option): system_ipaddress.
       
      In den Logs konnte ich dazu leider keine weiteren Informationen finden.


×