Jump to content
Froxlor Forum
  • Similar Content

    • By FearTheDude
      Folgende Situation:
      Ich betreibe einen vServer mit Froxlor als Hostingpanel
      Der docroot von meinedomain.tld liegt unter /var/customers/webs/meinAccount
      Eine SSL Weiterleitung wurde auf meinedomain.tld eingerichtet
      Kunden verwenden ein paar vorinstallierte tools (Webmailer, DB Frontend, Froxlor Panel) über toolname.meinedomain.tld
      Die Tools liegen nicht im docroot von meinedomain.tld sondern unter /var/www/toolname
      Folgendes Problem:
      Die SSL Weiterleitung von http auf https bei der Hauptdomain meinedomain.tld funktioniert nicht, es sei denn, man verwendet eine der Subdomains für die Tools
      Für meinedomain.tld wird anstatt /var/customers/webs/meinAccount der docroot /var/www verwendet
      Vorübergehende Lösung:
      Die Prüfung, ob mod_rewrite in der NN_froxlor_normal_vhost_meinedomain.tld.conf aktiv ist, entfernen
      <IfModule !mod_rewrite.c> Redirect 301 / https://meinedomain.tld/ </IfModule> Dann findet IMMER ein Redirect auf HTTPS statt, wobei hier auch der richtige docroot geladen wird.
      Nachteil:
      Sobald die Configs neu geschrieben werden, ist die Änderung weg.
      Fragen:
      Kann man die mod_rewrite prüfung für die SSL Weiterleitung irgendwo dauerhaft deaktivieren?
      Warum verwendet der vHost Container für http keinen bzw. den falschen docroot?
      Wie kann ich persistente Änderungen an den .conf Dateien für einen vHost vornehmen?
    • By Rmieres
      Hallo Zusammen,
      einen Webservices für die Erstellung von Kunden wäre eine Super Feature 
      Kundendaten, Domain  werden über Post übergegeben, Ws gibt Json als Rückgabe.
      Ich würde gerne für so eine Feature Maximal 1 Man Tag sponsoren . 
      Hat jemand Bock und Zeit dafür ? 
       
      Vg 
    • By nurtext
      Because otherwise he's not able to change the open_basedir-settings for the default subdomain.
      As an admin you can only turn it on/off, but not choose between document root and customers home dir.
    • By stolly82
      Hallo Zusammen,
       
      leider habe ich ein Problem mit dem Kundenbereich von Froxlor.
       
      Ich habe unseren Server komplett von null neu aufgesetzt mit Jessie und Froxlor. Alles scheint zu laufen, jedoch viel mir auf, dass ich keine Subdomain bei unter dem Kundenkonto anlegen konnte.
       
      Jetzt ist mir auch aufgefallen, dass diverse Menüpunkte fehlen, wie z.B. Email,...
       
      Hat einer eine Idee, warum ich als customer nichts konfigurieren kann?
       
      http://pasteboard.co/2G3j39wn.png
       
      So sah es sonst immer aus:
      http://pasteboard.co/2G3liTB3.png
       
      In den Einstellungen konnte ich keine Differenzen zu unseren alten Settings finden, aber auch keine Settings, dass man einen Account so verkrüppelt ;-) 
       
      Wäre nett, wenn jemand eine Idee hat, wie ich das in den Griff bekomme.
       
      Vielen Dank
       
      Jan
    • By behrang
      Hi
      when a customer has many domains he will see awstats for all domains.
      we would like to seperate stats for each domains. The question is: is this maybe possible by preferences already.
      or do we have to change confs manually and is it on the vhost side or within awstats itself.
      thx
×
×
  • Create New...