Jump to content
Froxlor Forum
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoticons maximum are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By stolly82
      Hallo zusammen, 
      ich bin immer sehr aktiv in Fehler selber lösen, aber aktuell bin ich an einem Punkt angekommen wo ich mittlerweile wirklich alle Beiträge im gesamten WorldWideWeb durchsucht habe und einfach nicht weiter komme :-( 
       
      Ich habe einen Debaian Jessie Server mit ein paar Kunde & Froxlor seit Jahren aktiv am laufen.
      Durch php7 und der Inkompatibilität einiger älterer Anwendungen benötige ich leider FCGID um auf einigen domänen noch die 5.x Version laufen zu lassen.
      Bei der Installation (mittlerweile nach knappen 15 Stunden mit google und Versuchen) scheitert es bereits an dem Punkt in der Anleitung:

       
      Das hatte ich vorher total übersehen, dass der Server dort anstatt 10001 etc. den Usernamen finde sollte. Demnach hatte ich bei der Installation weiter gemacht und bin immer bei dem Punkt hängen geblieben wo ich diese wunderschöne Fehlermeldung AH00543: apache2: bad user name **** bekommen habe.
      Ich habe bei Froxlor mittlerweile wirklich alle configs neu / plane aufgespielt und nscd will einfach die User nicht den ID´s zuordnen. 
      Was habe ich gemacht:

      Bei der Installation gibt es für mich auch keine erkennbaren Fehler. 
      Ich habe die MySQL Passwörter die ich bei Froxlor in die Config eingegeben habe selbstverständlich auch geprüft und testweise auch den root user / pw genommen. 
      Ebenfalls habe ich die Anleitung von hier genommen:
      https://github.com/Froxlor/Froxlor/wiki/apache2-with-fcgid
      Dort stimmte allerdings der Punkt mit dem 
      apt-get install libnss-mysql nicht mehr, da es mittlerweile libnss-mysql-bg ist. Demnach passten da auch die obersten beiden Config files nicht mehr.
       
      /etc/nss-mysql-root.conf /etc/nss-mysql.conf /etc/nsswitch.conf
       
      Hier mal das LOG File vom nscd.
       
      Vielleicht hat ja einer von euch eine Idee was das Problem sein könnte. 
       
      Danke und LG
       
      Jan 
       
      DAS WAR BEIM ERSTEM PLANE START: Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/passwd for database passwd Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/hosts for database hosts Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/resolv.conf for database hosts Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/services for database services Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/netgroup for database netgroup Fri 19 Jan 2018 06:51:51 PM CET - 17748: cannot stat() file `/etc/netgroup': No such file or directory Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17749 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (passwd) Fri 19 Jan 2018 06:51:51 PM CET - 17748: pruning passwd cache; time 9223372036854775807 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "0", timeout 1516384654 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "nobody", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "root", timeout 1516384654 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "vmail", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "65534", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "postfix", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "115", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "2000", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "116", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "debian-spamd", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "0" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "nobody" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "root" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "vmail" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "65534" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "postfix" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "115" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "2000" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "116" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "debian-spamd" Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17758 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (group) Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17759 Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17759 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (hosts) Fri 19 Jan 2018 06:51:51 PM CET - 17748: pruning hosts cache; time 9223372036854775807 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETHOSTBYADDR entry "127.0.0.1", timeout 1516387746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETHOSTBYADDR entry "127.0.0.1" Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17778 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17778 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17779 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17779 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17780 Fri 19 Jan 2018 06:51:53 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17780 Fri 19 Jan 2018 06:51:53 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17781 Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (1) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "1" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "1" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "daemon" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (102) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "102" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "102" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "messagebus" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (115) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "115" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "115" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "postfix" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (2000) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "2000" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "2000" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "vmail" of type GETPWBYNAME for passwd to cache MITTLERWEILE BEKOMME ICH NUR NOCH DAS HIER: Fri 19 Jan 2018 07:47:02 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:02 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:02 PM CET - 31374: handle_request: request received (Version = 2) from PID 31496 Fri 19 Jan 2018 07:47:02 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:02 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:03 PM CET - 31374: handle_request: request received (Version = 2) from PID 31497 Fri 19 Jan 2018 07:47:03 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:03 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:03 PM CET - 31374: handle_request: request received (Version = 2) from PID 31498 Fri 19 Jan 2018 07:47:03 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:03 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:04 PM CET - 31374: handle_request: request received (Version = 2) from PID 31499 Fri 19 Jan 2018 07:47:04 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:04 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:04 PM CET - 31374: handle_request: request received (Version = 2) from PID 31500 Fri 19 Jan 2018 07:47:04 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:04 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:05 PM CET - 31374: handle_request: request received (Version = 2) from PID 31501 Fri 19 Jan 2018 07:47:05 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:05 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:05 PM CET - 31374: handle_request: request received (Version = 2) from PID 31502 Fri 19 Jan 2018 07:47:05 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:05 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:06 PM CET - 31374: handle_request: request received (Version = 2) from PID 31503 Fri 19 Jan 2018 07:47:06 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:06 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:06 PM CET - 31374: handle_request: request received (Version = 2) from PID 31504 Fri 19 Jan 2018 07:47:06 PM CET - 31374: GETFDGR  
    • By gunnyst
      Hello again, hope you don't mind me coming up with another issue (including proposal for solution obviously).
      I had another issue using PHP-FPM, where I cannot get my .XML files parsed by the PHP interpreter even though I have this in my .htaccess:
      <FilesMatch "\.(xml)$">   SetHandler php5-fastcgi   Action php5-fastcgi /fastcgiphp   Options +ExecCGI </FilesMatch> It turns out that there is a limit imposed by the security.limit_extensions setting which defaults to .php only. My .XML files are used in order to automatically return the correct autodiscover/autoconfig settings to Outlook/Thunderbird and the like and therefor need to be "dynamic XML files", but I could imagine someone else needing .phps or the like...
      Currently I have gone so far as to add some stuff to /var/www/froxlor/lib/classes/phpinterface/class.phpinterface_fpm.php @ 248:
      if ($this->_domain['domain'] == 'autodiscover.mydomain.tld') {         $fpm_config.= 'security.limit_extensions = .php .xml'."\n"; } But again, this could be a new string-based setting in the new PHP-FPM versions section.
      (Slowly I'll get in touch with the code structure I promise...)
    • By LuckySparkle
      Ich hab mal wieder ein Problem bzw. einen Fehler mit unguten Auswirkungen begangen und bekomme es nicht mehr gerade gebügelt.
      Und zwar habe ich nach anfänglichem Testen mittlerweile auch mein privates Mailkonto auf einen neuen Server mit Froxlor gezogen.
      Ich hatte wie erwähnt bereits vorher einen Umzug mit Website, daher auch Datenbanken so wie Mailadressen erfolgreich durchgeführt. Der Umzug lief auch relativ glatt und auch meine privaten Mails liegen auf dem neuen Server, senden funktioniert, alle Websites sind via https erreichbar (Letsencrypt Zertifikate erfolgreich gezogen) und alles könnte eigentlich besser nicht sein. 
      Nun kann ich mich allerdings von Extern nicht mehr am smtp Server anmelden mit meiner privaten Mail-Adresse. Und zwar wollte ich in meiner noch Unwissenheit (das ist mein erstes "eigenes" Serverprojekt, meine ersten Server wurden durch andere eingerichtet und ich habe nur zugekuckt/mitgeschrieben) SSL Zertifikate für den Mailserver bekommen, Outlook hat nämlich die überaus nervige Angewohnheit bei jedem Start Zertifikatsfehlermeldungen auszugeben (bei Selbstsignierten) und auch das Speichern in den vertrauenswürdigen Zertifikatsspeicher von Windows bringt hier scheinbar keine Lösung.
      Nun dachte ich, ist ja einfach, einfach in Froxlor für jede Domain welche auch Mailadressen hat noch die Subdomain "mail.*" und "smtp.*" anlegen, LetsEncrypt anschmeißen und fertig, den Verweis stelle ich einfach auf den Ordner in welchem der Webmailer liegt. Soweit so gut, nun hat er hier allerdings keine Zertifikate gezogen sondern nur am laufenden meter PHP Errors ausgegeben. Diese hatte ich vorher immer wenn der PHP Flag für eine Domain nicht richtig gesetzt war, also mit dem admin in Froxlor eingelogt, Domain aufgerufen und gespeichert und... nichts. Gleicher Fehler. PHP Funktioniert (Webmailer wird korrekt aufgerufen) nur werden keine Zertifikate gezogen. 
      Also wollte ich erst einmal alles rückgängig machen und habe alle Subdomains (mail.* & smtp.*) wieder gelöscht. So und nun habe ich den Salat, seltsamerweise kann noch sämtliche Mailkonten von extern ansteuern, auch den jeweiligen smtp nur bei meiner privaten Mailadresse mit eigener Domain geht es nicht, auch nicht mehr bei der meiner Frau mit gleicher Domain. Outlook fragt nach den SMTP Zugangsdaten und nimmt Mailadresse + Passwort nicht, Thunderbird sagt er findet das Passwort nicht, iPhone & Android bringen ebenfalls diese Fehler. 
      ALLE anderen Domains bzw. verbundenen Mailkonten funktionieren (bis auf den Punkt mit dem Zertifikatsfehler) problemlos. Nur die meiner Hauptdomain nicht. 
      Das ganz komische ist aber, dass mein Webmailer noch ganz normal Empfangen und vor allem auch Senden kann, dieser erreicht den SMTP Server ohne Probleme und hat auch keine Login Probleme. 
      Ports sind Frei in der Windows eigenen Firewall, Ping an smtp.* geht problemlos durch, ich habe auch keinen Speedport mit vertrauenswürdiger E-Mail Liste sondern eine Fritz!Box. Bis vor 2 Stunden lief auch noch alles. Und ganz kurios ist auch, dass Outlook den smtp Server bei einer anderen Domain auf "smtpauth.*" geändert hat, Thunderbird geht allerdings via "smtp.*" ran. 
      Nun noch Screenshots von meinem Webmailer (Rainloop) und der dort voll funktionalen Konfiguration welche aber von Extern (egal ob mein Heimnetz (Unitymedia) oder Handynetz (Telekom & O2)) nicht laufen will:




    • By gunnyst
      I have some sites that make use of HTTP authorization headers inside of PHP (so not using htaccess/htpasswd, but an internal user database). For the moment I have simply added the required "-pass-header Authorization" to scripts/jobs/cron_tasks.inc.http.15.apache_fcgid.php @ 63 right after the "-socket" setting. But it would be nice if this was either always on by default or selectable as a switch in the GUI (could either be a global FCGI/FPM setting, but would be nicer if it was on a level with "PHP Configurations", since it's rarely needed).
      Thanks
      Günther
    • By Rupert Dobiasch
      Maildir wird autom. bei Erstellung von Mailadresse angelegt, aber Pfad ist falsch, siehe
      /var/customers/mail/var/customers/mail/[CUSTOMER]/[DOMAIN.TLD]/[MAILBOX]
      "var/customers/mail" ist doppelt.
      Bitte um Info welcher Prozess dieses Verzeichnis anlegt, bzw. wo der Fehler liegt.


×