Jump to content
Froxlor Forum
  • 0
Aragorn

Let's Encrypt Problem?

Question

Gibt es ein Problem mit Let's Encrypt?

Ich kann keine neuen Zertifikate mehr bekommen und anscheinend werden auch keine verlängert. Ist wohl seit dem Update auf Jessie so...

Im user.log finde ich diese Meldungen:

May  8 18:40:04 server Froxlor: [ Action MeineDomain] [error] letsencrypt Please check http://webmail.MeineDomain.de/.well-known/acme-challenge/2c3SVcZN3rCKkA_MQIE09yvsYM2KzQ4p36
0FAnewfoo - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/webmail.MeineDomain.de\/.well-known\/acme-challenge\/2c3SVcZN3rCKkA_MQIE09yvsYM2KzQ
4p360FAnewfoo): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232}

May  8 18:40:06 server Froxlor: [ Action MeineDomain] [error] Could not get Let's Encrypt certificate for webmail.MeineDomain.de: Verification ended with error: {"identifier":{"t
ype":"dns","value":"webmail.MeineDomain.de"},"status":"invalid","expires":"2017-05-15T16:40:04Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:e
rror:unauthorized","detail":"Invalid response from http:\/\/webmail.MeineDomain.de\/.well-known\/acme-challenge\/2c3SVcZN3rCKkA_MQIE09yvsYM2KzQ4p360FAnewfoo: \"<!DOCTYPE HTML
PUBLIC \"-\/\/IETF\/\/DTD HTML 2.0\/\/EN\">\n<html><head>\n<title>404 Not Found<\/title>\n<\/head><body>\n<h1>Not Found<\/h1>\n<p\"","status":403},"uri":"https:\/\/acme-v01
.api.letsencrypt.org\/acme\/challenge\/bmRdVyO7ijFkbEDqUomtP9LEDEhOxua5t9eUXqAcLuY\/1143768904","token":"2c3SVcZN3rCKkA_MQIE09yvsYM2KzQ4p360FAnewfoo","keyAuthorization":"2c
3SVcZN3rCKkA_MQIE09yvsYM2KzQ4p360FAnewfoo.ccY_1bA4eufhisVHL8Ukj2YCAr1AniVguPFkHDoqgV0","validationRecord":[{"url":"http:\/\/webmail.MeineDomain.de\/.well-known\/acme-challenge
\/2c3SVcZN3rCKkA_MQIE09yvsYM2KzQ4p360FAnewfoo","hostname":"webmail.MeineDomain.de","port":"80","addressesResolved":["144.76.184.3"],"addressUsed":"144.76.184.3"}]},{"type":"tl
s-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/bmRdVyO7ijFkbEDqUomtP9LEDEhOxua5t9eUXqAcLuY\/1143768905","token":"x5dwYbFJFLMsK
mFJ-BuUez21EcV71CHlRw6zRTmJiTY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/bmRdVyO7ijFkbEDqUomtP9LEDEhOxua5t9eUXqA
cLuY\/1143768906","token":"J35C8C0K_mq6X7-Ml0iq72xZmrAVSeXCvls-UA6J0Ms"}],"combinations":[[1],[2],[0]]}

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Ist dein acme alias auch konfiguriert? Er sagt ja 404...

Share this post


Link to post
Share on other sites
  • 0

In /etc/apache2/conf.d liegt diese acme.conf:

Alias "/.well-known/acme-challenge" "/var/www/letsencrypt-tokens/.well-known/acme-challenge"
<Directory "/var/www/letsencrypt-tokens/.well-known/acme-challenge">
    Order allow,deny
    Allow from all
</Directory>
 

In /etc/apache2/conf.enabled liegt diese acme.conf:

Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge"
<Directory "/var/www/froxlor/.well-known/acme-challenge">
    Order allow,deny
    Allow from all
</Directory>
 

 

Inzwischen lautet der Fehler

"detail":"Error creating new authz :: Too many invalid authorizations recently.","status":429}

 

Share this post


Link to post
Share on other sites
  • 0

Froxlor -> als admin einloggen -> konfiguration -> [distro] -> webserver -> apache

Und dann schauste mal da bzgl. der acme.conf welche das ist und wie der inhalt lautet. Alle anderen bitte entfernen

Share this post


Link to post
Share on other sites
  • 0

Jo, die sieht beim Apache 2.4 leicht anders aus.

Naja, wie lange muss ich warten um zu sehen, ob's nun klappt? Wegen dem Fehler

  Too many invalid authorizations recently

 

Share this post


Link to post
Share on other sites
  • 0

Naja, lösch im Zweifel den Key von dem Customer :P  Für den Kunden "web123" wie folgt:

UPDATE panel_customers SET lepublickey = '', leprivatekey = '', leregistered = 0 WHERE loginname = 'web123'

Ansonsten wartest du entweder 5 Minuten bis der Cronjob wieder läuft, oder (und auch besser zum debuggen) du startest ihn manuell:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug

 

Share this post


Link to post
Share on other sites
  • 0

Ja ne das meine ich nicht. So wie es aussieht, sperrt sich Let's Encrypt inzwischen mit

Too many invalid authorizations recently.","status":429

Da kann man wohl nur warten....

 

Share this post


Link to post
Share on other sites
  • 0

jop. am besten den letsencrypt cronjob dann mal deaktivieren, sonst versucht er es ja immer und immer wieder :) (alternativ nur bei der domain die probleme macht, wenn es nur um 1-2 domains geht)

Share this post


Link to post
Share on other sites
  • 0

Hallo zusammen!

Ich will keinen neuen Thread aufmachen, aber auch ich habe Probleme LE ans Laufen zu kriegen.

Ich hatte zuvor bereits eine andere SSL Konfiguration (gekauftes Zertifikat) und 2 IPs für SSL, wobei eine meine Verwaltungsadresse ist. Es geht also (erstmal) nur um eine IP Adresse.

Habe mir bereits alles was ich hier im Forum dazu finden konnte durchgelesen, war aber trotzdem nicht in der Lage mein Problem zu lösen.

Verwende die aktuelle Froxlor Version ( 0.9.38.7-1) mit Wheezy und Apache/2.2.22

 

Den Ordner unter /var/www/froxlor/.well-known/acme-challenge hat er auch angelegt und Einträge in der DB (panel_customers) werden auch erzeugt.

Aber immer wenn ich den Cron-Job (manuell) ausführe, erhalte ich einen 404er ala:

http://example.com/.well-known/acme-challenge/hSg7MXFsjq-Ff8A8j4M12uO-OAzA25J5-rPdzVJ8h24 - token not available

 

Daraus rsultierend dann auch:

PHP error: {"type":2,"message":"file_get_contents(http:\/\/example.com\/.well-known\/acme-challenge\/hSg7MXFsjq-Ff8A8j4M12uO-OAzA25J5-rPdzVJ8h24): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232

 

Könnte mir bitte jemand freundlicherweise helfen?

Stehe echt auf'm Schlauch im Moment - danke!

 

Gruß

Gunther

Share this post


Link to post
Share on other sites
  • 0

Konfiguration für LE denn auch im Webserver gemacht? Stichwort acme-alias (acme.conf)

Share this post


Link to post
Share on other sites
  • 0

So - Problem gelöst!

Da mein Problem ja darin bestand, dass der Token (der in "/.well-known/acme-challenge/" abgelegt sein sollte) nie gefunden wurde bei der Überprüfung durch LE, ich aber den entsprechenden Alias gemäß des Konfig-Templates gesetzt hatte, habe ich dann mal kurz überlegt und bin der Ursache dann schnell auf den Grund gekommen.

 

Bei mir (Wheezy + Apache 2.2.22) wird das Verzeichnis "conf-enabled", welches im Konfig-Template angegeben wird, in der apache2.conf gar nicht eingebunden!

Beim 2er Apache ist es auch standardmäßig eher das Verzeichnis "conf.d".

Also entweder die Datei "acme.conf" ins "conf.d" Verzeichnis stecken, ODER in der Datei "apache2.conf" das Verzeichnis "conf-enabled" mit einbinden (inkludieren). Dann klappt's auch mit Let's Encrypt.

 

Gruß

Gunther

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...