d00p

Problems with NSCD using Debian? Try this...

1 post in this topic

Dear debian-users,

we know, that many of you struggle with nscd and libnss-mysql(-bg). I've quickly developed a patch which allows you to use an alternative: libnss-extrausers

Basically, this nss-module allows us to create "custom" passwd, group and shadow files which makes the use of libnss-mysql(-bg) and therefore many database-connections obsolete.

If you have massive problems with users not being recognized or similar, just follow these commands:

#> apt-get install libnss-extrausers
#> sed -i -e 's/mysql/extrausers/g' /etc/nsswitch.conf
#> cd /var/www/froxlor
#> wget http://files.froxlor.org/patches/0001-libnss-extrausers.patch
#> patch -p1 < 0001-libnss-extrausers.patch
#> rm 0001-libnss-extrausers.patch
#> php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Hope this helps a few of you guys - we'll add this feature with an enable/disable option and install instructions in the next release.

To switch back to libnss-mysql just reverse the changes to the nsswitch.conf file:

#> sed -i -e 's/extrausers/mysql/g' /etc/nsswitch.conf

Thanks for using froxlor and have fun :)

Regards

Michael (d00p)

Share this post


Link to post
Share on other sites

  • Similar Content

    • By adamjedgar
      Hi guys,
       
      I have a google cloud compute debian instance
      I have been experimenting with a couple of alternatives to cpanel. Just installed virtualmin and now am looking at froxlor.
       
      I have followed the install outline as documented.
      1. I setup a google cloud launcher LAMP
      2. navigated in browser to <myserveripadress> to ensure apache is working (which it is)
      3. downloaded froxlor to /var/www/ directory
      4. chown froxlor to www-data:www-data (i also checked to ensure my webserver is running as www-data)
       
      Now when i attempt to navigate to http://<mywerveripadress>/froxlor i get the following error in browser 
      "NOTFOUND" the requested URLwas not found on this server.
       
      now when i ssh into server, froxlor is definatelly in /var/www/ directory.
      permissions are  0755 www-data:www-data
       
      i am not sure what i have done wrong?
       
      has anyone with experience in installing this on google cloud got any advice?
    • By dg3fbl
      Hallo,
       
      ich bin jetzt ein frischer" Anwender" und habe gestern auch schon mal eine Weile durch das Forum gestöbert. Aber eine Grundfrage ist mir noch nicht so richtig klar geworden.
       
      Ich möchte einen neuen VServer aufsetzen und überlege ob ich Debian 8.5 oder Ubuntu 16.04 nehmen soll.
       
      Gibt es für froxlor eine Präferenz?
       
      Ich selber kenne mich seit Jahren mit Ubuntu aus, aber mit Debian würde ich bestimmt genau so gut klar kommen. Bisher habe ich als Admin Panel Plex und Vesta-CP genutzt, aber bei letzterem komme ich mit dem Support nicht klar.
       
      Grüße aus Südhessen
      Jochen
       
    • By FM-Design
      Ich versuche verzweifelt o.g. Konfiguration zum Laufen zu bringen, scheitere aber bereits
      bei der Installation an den ersten Schritten. Ich hoffe, Ihr k?nnte mir helfen.

      Bei der Installation halte ich mich an dieser Anleitung FPM - handbook - Froxlor.

      Bei der Ausf?hrung des Befehls ?apt-get install libnss-mysql-bg nscd libapache2-mod-fastcgi apache2-suexec php5-fpm? kommt die Meldung

      ?Package libapache2-mod-fastcgi is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or
      is only available from another source
      E: Package 'libapache2-mod-fastcgi' has no installation candidate?

      Ich habe die Source-Listen wie folgt angepasst:
      ftp.es.debian.org/debian stable main contrib non-freedeb-src ftp.es.debian.org/debian stable main contrib non-freedeb ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb-src ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb security.debian.org/ wheezy/updates main contrib non-freedeb-src security.debian.org/ wheezy/updates main contrib non-free Nach 'apt-get update' funktioniert auch die Installation.

      W?hrend der Installation folgt dann die Frage, wie mit dem Konfiguration File ?/etc/apache2/apche2.conf? umgegangen werden soll. Hier bin mir unschl?ssig. Ich habe die ?Install the package maintrainer?s version? versucht. Dann funktioniert Froxlor nicht mehr.

      Ich habe es auch mit der Beibehaltung der aktuellen Version versucht. Dann l?sst sich aber Apache nicht mehr starten. (?apache2: Syntax error on line 265 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/conf.d/: No such file or directory?).

      Leider finde ich dazu keine Hinweise oder Anleitungen. Hat von Euch jemand eine Idee?
    • By garfield
      I've installed Debian 8.2 amd64 with apache, mysql and php to run as a webserver.
      What I want is retrieving the $_SERVER['REMOTE_USER'] when my clients, using Windows XP and Windows 7, visit the intranet installed on the Debian server.
      Modules that are enabled in apache:
      alias
      auth_basic
      auth_kerb
      authn_core
      authn_file
      authz_core
      authz_host
      authz_user
      autoindex
      cgi
      deflate
      dir
      env
      filter
      mime
      mpm_prefork
      negotiation
      perl
      php5
      setenvif
      status
       
      httpd.conf
      DirectoryIndex index.php index.html index.htm KeepAlive on HostnameLookups on <Location /test> PerlAuthenHandler "Apache2::AuthenNTLM" AuthType ntlm,basic AuthName "NTLM Authentication" require valid-user PerlAddVar ntdomain "MYDOMAIN 10.52.43.220" PerlSetVar defaultdomain "MYDOMAIN" PerlSetVar splitdomainprefix 1 PerlSetVar ntlmdebug 0 PerlSetVar ntlmauthorative off PerlSetVar ntlmsemkey 0 PerlSetVar ntlmsemtimeout 1 </Location> apache2.conf is a default file without any changes.
       
      Because it doesn't work I tried putting an .htaccess in /var/www/test
      <Location /test> AuthType NTLM NTLMAuth on NTLMAuthoritative on NTLMDomain MYDOMAIN NTLMServer 10.52.43.220 require valid-user </Location> But it doesn't work either.
       
      /var/log/apache2/error.log displays this:
      [Thu Oct 08 11:34:23.786879 2015] [mpm_prefork:notice] [pid 2287] AH00163: Apache/2.4.10 (Debian) mod_auth_kerb/5.4 mod_perl/2.0.9dev Perl/v5.20.2 configured -- resuming normal operations [Thu Oct 08 11:34:23.786922 2015] [core:notice] [pid 2287] AH00094: Command line: '/usr/sbin/apache2' [Thu Oct 08 11:35:39.656529 2015] [:error] [pid 2293] [client 10.52.43.14:49784] PHP Notice: Undefined index: REMOTE_USER in /var/www/html/test/ntlm.php on line 2, referer: http://10.52.43.71/test/ What am I doing wrong and how can I fix it?
    • By nbussman
      Hey guys,
       
      i got a huge problem with a single user. After cron tasks I often got a 500 Internal Server Error
      to all domain poining to a user directory. I use php5-fpm.
       
      The logs say:
      [Mon Jun 22 16:03:34 2015] [error] [client 137.224.252.19] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external" [Mon Jun 22 16:03:57 2015] [error] [client 77.3.79.65] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed [Mon Jun 22 16:04:00 2015] [error] [client 77.3.79.65] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external" [Mon Jun 22 16:04:03 2015] [error] [client 146.60.197.9] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed [Mon Jun 22 16:04:03 2015] [error] [client 146.60.197.9] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external" [Mon Jun 22 16:04:06 2015] [error] [client 137.224.252.19] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed But the user fullname should have access to /var/www/php-fpm/fullname/*
      la /var/www/php-fpm/fullname/ insgesamt 16K drwxr-xr-x  4 root     root     4,0K Jun 22 15:35 . drwxr-xr-x 10 root     root     4,0K Jun 22 15:35 .. drwxr-xr-x  2 fullname fullname 4,0K Jun 22 15:35 fullname.h**3528.stratoserver.net drwxr-xr-x  2 fullname fullname 4,0K Jun 22 15:35 nilsbussmann.de I can fix the problem by give choown the complete folder to the user. 
      chown fullname:fullname -R /var/www/php-fpm/fullname/ service nscd restart service apache2 restart But this is a dirty workaround. Though i have to fix i manually evertime ...
       
      Can anyone help me width this problem? That would be awesome! 
      Cheers Nils