Jump to content
Froxlor Forum
  • 0
irisdina

Domain => SQL = keine verbindung

Question

Und zwar ... benutze frox schon sehr lange und ist immer aktuell, aber mom stehe ich vor einem prob, was es eig. gar nicht geben dürfte ^^"

 

Auf einen meiner Server läuft frox (wie schon oben erwähnt) mit mehreren Domains bisher keine probleme gehabt, jetzt wollte ich für einen bekannten nen eigenen Acc machen.

Habe ihm einen User + Domain angelegt und er wollte sich WP installieren, (DB + SQL nutzer wurde angelegt), nur laut WP install bekommt er keine Verbindung zu der SQL (würde angeblich nicht laufen).

 

Nach gesehen ob die Login Daten für die SQL richtig gehen => ssh mysql login oh. probleme (also daten stimmen), ihm mal einen zweiten SQL User angelegt => gleiches prob. Ihm mal daten für einen einen anderen SQL Acc (andere Kunde) gegeben => prob.

In den Logs mal nach gesehen, keine fehler drin, die darauf deuten das es probleme mit der SQL gibt.

 

WP mal auf ne andere Domain gelegt und installiert (mit den oberen SQL Daten) => kein problem, geht einwandfrei ...

 

Why kann ich keine SQL verbindung mit Domain A aufbauen aber mit Domain B etc. schon?

Kunde kann aber SQL anlegen.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Liegt sicher nicht an der Domain, die hat nix mit den SQL Zugängen zu tun. Mal versucht statt localhost einfach 127.0.0.1 zu benutzen? oder andersrum? Username und Passwort auch WIRKLICH korrekt? etc.etc.etc.

Share this post


Link to post
Share on other sites
  • 0

Liegt sicher nicht an der Domain, die hat nix mit den SQL Zugängen zu tun. Mal versucht statt localhost einfach 127.0.0.1 zu benutzen? oder andersrum? Username und Passwort auch WIRKLICH korrekt? etc.etc.etc.

 

127.0.0.1 habe ich bereits versucht und wie gesagt, die SQL Daten stimmen zu 100% sonst könnte ich mich nicht per ssh o. phpmyadmin auf die SQL DB mit dem benutzer einloggen.

Habe dem Kunden auch mal noch eine andere Domain hinzugefügt, da geht es oh. probleme, nur halt mit Domain A nicht.

Share this post


Link to post
Share on other sites
  • 0

Hat dann nix mit froxlor zu tun, wüsste nicht wieso das nicht gehen soll

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By Rmieres
      Hallo Zusammen,
      einen Webservices für die Erstellung von Kunden wäre eine Super Feature 
      Kundendaten, Domain  werden über Post übergegeben, Ws gibt Json als Rückgabe.
      Ich würde gerne für so eine Feature Maximal 1 Man Tag sponsoren . 
      Hat jemand Bock und Zeit dafür ? 
       
      Vg 
    • By tt33tt
      Hallo alle zusammen,
      ich möchte die Weiterleitung bei der Domäne ändern: http://lehrerfortbildung.schule/
      Ursprünglich war sie verlinkt auf http://rainerwiederstein.de/ Dafür habe ich als Pfad das Heimverzeichnis eingegeben dieser Domäne
      In der Beschreibung steht ja, dass eine Weiterleitung per http:// an eine andere Seite möglich ist. Nun möchte ich sie auf eine andere Domäne verlinken, möglichst mit einem eim Link domain.xy/page/page.php
      Letzteres klappt nicht. Redirect-Code scheint auch keinen Einfluss zu haben. Geht es denn statt auf nur eine Domäne auch auf die Seite einer Domäne zu verlinken d.h. per http?
      Oder braucht es etwas Zeit bis die DNS-Einstellungen wirken: 1-2 Tage?
    • By H4nSolo
      Hallöchen zusammen,
      ich hätte mal eine Frage bezüglich Froxlor und Cloudflare.
       
      Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden.

      Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann.
      Cloudflare API: https://api.cloudflare.com/
       
      Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können.
       
       
      Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor?
       
      lg H4nSolo
    • By tt33tt
      Hallo alle zusammen,
       
      bei SMTP Auth holt sich bei mir der Postfix die Zugangsdaten aus der Datenbank. Standardmäßig greift er über sql_select: SELECT password FROM mail_users WHERE username='%u@%r' OR email='%u@%r' zu.
      Allerdings ist die Spalte password leer und somit kann man sich ohne Passwort-Eingabe am SMTP authentifzieren (sicherheitshalber habe ich die Authentifzierung aber auf den localhost beschränkt). Das eigentliche Passwort des Mail-Users ist in der Spalte password_enc. Wenn ich in der smtdp.conf aber password_enc als Spalte nehmen würde, dann könnte er das nicht entschlüsseln.
      Ist password_enc FROM mail_users ein Hash-Wert? Kann ich in Postfix einen Hash-Wert verarbeiten? Wie habt ihr das eingerichtet?
×
×
  • Create New...