Jump to content
Froxlor Forum
  • 0
Infected

acme.conf not found

Question

Schönen guten Tag,

Froxlor wird bei jedem Update besser und besser.

 

Jedoch bin ich auf ein kleines Problem gestoßen.

Ich habe etwas ausprobiert, weshalb ich (entgegen dem Hinweis) direkt an den VHosts der Nginx Config rumgespielt habe.

 

Nachdem ich Änderungen gemacht hatte, wollte ich Nginx von Hand neu starten.

Doch aufgrund eines Fehlers war dies nicht möglich.

Also habe ich mir den Fehler angesehen und habe folgende Zeile in sämtlichen VHosts ausfindig machen können:

 

include /etc/nginx/acme.conf;

 

 

Diese Datei ist nicht vorhanden.

Als ich diese Zeile überall auskommentierte, konnte ich Nginx endlich neustarten.

 

 

 

Meine Frage ist nun, ist das so richtig?

Wenn ich über das Froxlor Panel die Webconfigs neu erstelle, kann Nginx ohne Probleme neu gestartet werden, obwohl der Eintrag dann wieder vorhanden ist.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Diese Datei ist nötig bei der Nutzung von Let's Encrypt - das diese nur inkludiert wird, wurde bereits gefixed (siehe https://github.com/Froxlor/Froxlor/commit/28f0c3eac401b5793c8ca9e9750d99421683cb96). 

 

Wenn du es übernehmen willst, ersetze einfach die Datei scripts/jobs/cron_tasks.inc.http.30.nginx.php mit der aus Github (https://github.com/Froxlor/Froxlor/blob/master/scripts/jobs/cron_tasks.inc.http.30.nginx.php). Oder erstelle die acme.conf laut Konfigurations-Template :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...