Jump to content
Froxlor Forum
  • 0
ZIP

Dovecot, Postfix und Sieve

Question

Hallo zusammen,

 

ich betreibe schon seit längerem einen Mailserver via Dovecot und Postfix.

 

Als Plattform setze ich Debian GNU/Linux 8 ein. Dovecot und Postfix habe ich via apt-get install installiert.

 

Jetzt möchte ich zusätzlich Sieve ins Spiel bringen um die Mails automatisiert filtern zu lassen. So wie ich die Dokus verstanden habe benötige ich dafür aber das Plugin 'sieve'.

 

"Geschrieben" habe ich die sieve-scripts mit roundcube und getestet mit sieve-test. Demnach funktioniert sieve bereits super, nur leider scheint postfix/dovecot sieve gar nicht erst zu involvieren bevor die Mail abgelegt wird.

 

Meine dovecot.conf ist recht schlank:

!include_try /usr/share/dovecot/protocols.d/*.protocol
dict {
}
!include conf.d/*.conf
!include_try local.conf
mail_location = maildir:~/.maildir
mail_debug = yes

10-mail.conf

mail_location = mbox:~/mail:INBOX=/var/mail/%u
namespace inbox {
  inbox = yes
}
mail_access_groups = mail-users

20-lmtp.conf

protocol lmtp {
    mail_plugins = $mail_plugins sieve
}

90-sieve.conf

plugin {
	sieve = ~/.maildir/sieve sieve_dir = ~/.maildir/sieve
	sieve_before = /etc/dovecot/sieve/spam-global.sieve
}
protocol sieve {
	managesieve_max_line_length = 65536
	managesieve_implementation_string = dovecot
	log_path = /var/log/dovecot-sieve-errors.log
	info_log_path = /var/log/dovecot-sieve.log
}

Da die Konfig-Files in vielen Ordnern/Scripten aufgeteilt ist weiß ich nicht so recht welche Configs ich hier noch reinschreiben könnte.

 

/etc/postfix/main.cf

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
append_dot_mydomain = no
readme_directory = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_enforce_tls = no
mydomain = hkgame.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, /etc/postfix/virtual/domains
virtual_maps  = hash:/etc/postfix/virtual/addresses
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = .maildir/
local_destination_concurrency_limit = 2
default_destination_concurrency_limit = 10
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_received_header = yes
smtp_use_tls = no

Was mache ich wohl falsch? Muss ich noch irgend ein Plugin aktivieren?

 

Danke und Gruß

ZIP

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Wie wärs du nutzt einfach unsere config-templates?

 

Als admin links in Configuration -> Debian Jessie (8.x) »  Mailserver (IMAP/POP3) »  Dovecot with postfix

 

Inklusive aller sieve/managesieve pakete und entsprechende config damit das mit froxlor tut.

Share this post


Link to post
Share on other sites
  • 0

Für postfix rate ich dir das gleiche, denn die config ist auch nicht von uns, das kann ja so dann gar nicht funktionieren ohne die mysql-anbindung

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By thunfischbaum
      Hi everyone,
      just a little problem here. I have severa domains registered on my froxlor installation and a different hostname of course. So let's say domain1.de is my hostname. The second domain, which is used by a customer is called domain2.de . When I view the mail.log I am not able to find my connection request. I do only see the bruteforce bots with example@domain1.de connecting. But any example@domain2.de request is not getting forwareded. I did configure the installation accordingdly with the provided templates.
      Best regards,
      thunfischbaum
    • By thunfischbaum
      Hi everyone,
      I'm running a Debian 10 Buster Server with PHP7.3 installed. The PHP7.3 update is the new component in the system. since then, I can't find any Mailboxes. There are no folders in the var/customers/mail/[customer] directory.
      If you take look at the Screenshot, you see, that the E-Mail adress is existent in Froxlor. 

      Mail Bounce
      Mail Log
       
      If I missed a log, please let me know, so I can attach it
      Best regards,
      thunfischbaum

    • By alex84
      Hallo,
      ich würde gerne Quotas für die Mailboxen nutzen. Dazu habe ich u.g. Funktion aktiviert und kann jetzt pro Mailbox Kontingente festlegen. 
      Allerdings werden die weder in Thunderbird noch Roundcube angezeigt. Die Option oben besagt ja auch, das eine "spezielle Konfiguration" vorausgesetzt wird. Also nun meine Frage(n) Was muss ich noch anpassen oder installieren? Haben sich mit der Aktivierung dieser Option auch die Konfigurationstemplates geändert? (Auf dem ersten Blick würde ich sagen: Nein)
      Ich nutze das aktuelle Froxlor 0.9.40.1 (allerdings auf Debian 10 - Ich habe mich dabei an diese Anleitung gehalten, so weit es rein um Froxlor geht. Also ohne die "Partitionieren"-etc Abschnitte: https://lichtmetzger.de/2019/05/31/debian-10-buster-und-froxlor-0-9-auf-einem-hetzner-ex52-server-installieren/) Die Config-Templates (Postfix/Dovecot) habe ich soweit 1:1 übernommen, lediglich die SSL-Zertifikate und das message_size_limit angepasst.
      Danke schonmal,
      Alex
×
×
  • Create New...