February 29, 201610 yr Hi, My server shows 500 internal server error for all domains. Visiting the IP of the server shows "It's Working". Froxlor admin page works and I can login. But, all other websites return error 500. php5-fpm is running, I also tried restarting it with no luck. This is the error I am getting in the error file: [Mon Feb 29 04:02:40.320681 2016] [fastcgi:error] [pid 3459] (13)Permission denied: [client 14.192.215.133:1103] FastCGI: failed to connect to server "/var/www/php-fpm/superuser/xxxxxxxxx/fpm.external": connect() failed [Mon Feb 29 04:02:40.320767 2016] [fastcgi:error] [pid 3459] [client 14.192.215.133:1103] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/superuser/xxxxxxxxx/fpm.external" I hope you could help me with this. Regards.
February 29, 201610 yr Author I have installed libnss-mysql following the configuration from froxlor admin. I think I narrowed down the problem to the permissions on /var/libapache2/fastcgi/superuser-* All these files are generated with another username (superuser). Not by the froxlorlocal. If I chown to froxlorlocal, the 500 internal server error is gone and things work fine. Also, under /etc/php5/fpm/pool.d/*.conf, the script listens to superuser, not to the froxlorlocal. So, every time the server is rebooted, or php5-fpm is restarted, the permissions are reset to superuser again and the error comes back. How to solve this permanently? I was thinking to make a cronjob to run every minute or so to correct these, but then, I think that's an over-kill. Any suggestions? Thanks!
February 29, 201610 yr Author the webserver username is www-data and it's the same for the group name. The php-fpm user and group is froxlorlocal (same as the one used in the tutorial video).
March 6, 201610 yr the webserver username is www-data and it's the same for the group name. The php-fpm user and group is froxlorlocal (same as the one used in the tutorial video). Genau, ja sehr gut. Ich stimme mit dieser Ansicht. hulle6 samsung a7 hülle
Archived
This topic is now archived and is closed to further replies.