Jump to content
Froxlor Forum
  • 0
glampe

[solved] Froxlor web interface now giving 500 error.

Question

When I try to access Froxlor on my server I am now receiving a 500 error.

 

A few days before this, I upgraded php and a few other items through apt-get but did not see an issue immediately.  All the hosted sites are running fine.  The only problem I have is with the Froxlor interface.

 

This is the message in the browser.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

 

The error.log shows

 

No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/froxlor.panel/hostname.com/8dfd.fpm.external": connect() failed

 

FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/froxlor.panel/hosting.com/8dfd.fpm.external

 

Anyone have any ideas on how to fix this or what might have changed?  It seems like it is trying to use php-fpm.  I know the other sites use it, but does the Froxlor admin?

 

Thanks for any help anyone can give.

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Then you might forgot to adjust the settings to tell froxlor to use fpm also for the panel - alternativley, re-activate mod_php :)

Share this post


Link to post
Share on other sites
  • 0

I reactivated mod_php and I started seeing the raw php code.  Not sure why that is happening.

 

I was able to tell froxlor to use fpm and things seem to be working now.

 

So things are working now.  Just not sure of the exact cause or why mod_php doesn't work now.

 

Thanks for your help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...