• Announcements

    • d00p

      Major server crash   03/27/17

      Due to a major server crash, most of our services are currently not available. Sorry for any inconvenience. Sadly, the forums database could not be restored, so we are back to a database from mid-2016  Sorry
  • 0
w6g

Support for FreeBSD

Question

Hi.

 

Is there anyone else missing the FreeBSD support that has been removed from froxlor with version 0.9.34?

 

Just recently I discovered that ever since I last looked, now there are hosters that offer virtual servers running on FreeBSD for little money. For reasons that might be off-topic, I was so happy to get one of those. And just with the first version update of froxlor, the support for FreeBSD is removed. Bummer!

 

So for what it's worth, I'd like to see FreeBSD support re-appear, and I am willing to share some of my time to make it happen. Having said that, I have to admit that I'm still pretty new to both FreeBSD and Froxlor, and even if I were an expert I would not be able to do this alone. I can imagine the Froxlor team wouldn't want a one-man-show either.

 

So, are there any Froxlor-on-FreeBSD users out there who, like me, would want to contribute in order to make Froxlor support FreeBSD again?

 

Cheers

w6g

Share this post


Link to post
Share on other sites

15 answers to this question

  • 0

I'm here to volunteer as well

 

 

Hi.

 

Is there anyone else missing the FreeBSD support that has been removed from froxlor with version 0.9.34?

 

Just recently I discovered that ever since I last looked, now there are hosters that offer virtual servers running on FreeBSD for little money. For reasons that might be off-topic, I was so happy to get one of those. And just with the first version update od froxlor, the support for FreeBSD is removed. Bummer!

 

So for what it's worth, I'd like to see FreeBSD support re-appear, and I am willing to share some of my time to make it happen. Having said that, I have to admit that I'm still pretty new to both FreeBSD and Froxlor, and even if I were an expert I would not be able to do this alone. I can imagine the Froxlor team wouldn't want a one-man-show either.

 

So, are there any Froxlor-on-FreeBSD users out there who, like me, would want to contribute in order to make Froxlor support FreeBSD again?

 

Cheers

w6g

 

Share this post


Link to post
Share on other sites
  • 0

Github -> Fork -> create freebsd.xml configfile -> pull-request :)

Share this post


Link to post
Share on other sites
  • 0

Hi.

 

Is there anyone else missing the FreeBSD support that has been removed from froxlor with version 0.9.34?

 

Just recently I discovered that ever since I last looked, now there are hosters that offer virtual servers running on FreeBSD for little money. For reasons that might be off-topic, I was so happy to get one of those. And just with the first version update od froxlor, the support for FreeBSD is removed. Bummer!

 

So for what it's worth, I'd like to see FreeBSD support re-appear, and I am willing to share some of my time to make it happen. Having said that, I have to admit that I'm still pretty new to both FreeBSD and Froxlor, and even if I were an expert I would not be able to do this alone. I can imagine the Froxlor team wouldn't want a one-man-show either.

 

So, are there any Froxlor-on-FreeBSD users out there who, like me, would want to contribute in order to make Froxlor support FreeBSD again?

 

Cheers

w6g

 

Count me on this one. I would love to contribute and help fellow users of Froxlor-on-FreeBSD. :)

Share this post


Link to post
Share on other sites
  • 0

Very welcome, See me previous andere on howto contribute. Also you might want to join us on IRC

Share this post


Link to post
Share on other sites
  • 0

My pc was broken, i couldnt reply on time, sorry about that.

 

For server setup,

I saw many errors related to other ports which required for froxlor setup. freebsd has some changes related to openssl, and i selected libressl because of this, and all errors comes up. and then i gave up about port installation. because i dont want to deal with port problems.

 

Now i am looking for setup without froxlor port, i installed froxlor and i configure the php fpm and other things.

I couldnt find any documentation about php fpm that is different than froxlor old wiki,

why it needs libnss-mysql, dont we have another way to work with php fpm?

because libnss-mysql seems suck, because of cache system needs ;) If there is any other thing to do this, let me know please ;) Thans in advance!

 

Another point is for froxlor development, reading all codes take time, do we have some diagrams or something like that to explain the froxlor and its parts ? or i will do it when i am done my research about codes ;)

 

next week , i hope ,i will update this issue with better news.

 

have a nice day everyone!

Share this post


Link to post
Share on other sites
  • 0

1) we currently cannot avoid libnss-mysql

2) froxlors structure has nothing really to do with the config-templates...just adjust the file jessie.xml or gentoo.xml or whatever is closest to FreeBSD and create a new freebsd.conf...

Share this post


Link to post
Share on other sites
  • 0

I understand it very well, thank you for help, i like the concept of froxlor but i need more freedom for freebsd, i wanna modify some of features that may help majority of people, and i will create config file and maybe more than that for freebsd users.

 

thank you for good job ,froxlor commiters and founders.

I like this panel.

Share this post


Link to post
Share on other sites
  • 0

OP here.

 

So, it has been quite some ten months since my first post, but I am counting xentie, Geniusties and UlasSAYGIN. Let's stay in touch!

 

Cheers

w6g

Share this post


Link to post
Share on other sites
  • 0

I am working on it, i will contribute when i am done.

 

Let me know if I can provide any help. I have a 0.9.37 installation running with FreeBSD 10.3, Nginx, MySQL, PHP-FPM, the latter ones all from ports.

 

 

I tested freebsd port but i couldnt achieve successful the setup.

 

I can't find the URL again, but I think I remember having read that the port would be broken. I used the installation from upstream. (Maybe we could contact the port maintainer?)

Share this post


Link to post
Share on other sites
  • 0

Could be my friend, but now i am looking getting things done ,step by step. In my country it was holiday, i was in holiday mood but now finally it is ending and i am happy to go back to work and look something good. I just looked 3 times for froxlor setup again and i just saw i didnt setup other ports like powerdns and ftp , and i setup them now, it seems working , i will test them, by the way i am looking code of froxlor to get how things get done.

 

I am also want to try froxlor on Dragonflybsd. it seems very cool bsd OS. I will let all you know when i tested and approved my works.

 

see you later. have a nice day and week.

Share this post


Link to post
Share on other sites
  • 0

Sorry i forgot to say, thank you people who says good things and wishing to help, i will ask help but first i need to know and research the system and understand it. without this it will be weak start, but i may say, froxlor needs more documentation to be a better open source system.

Share this post


Link to post
Share on other sites
  • 0

I tried again to setup from freebsd ports. I selected libressl and powerdns, pureftpd, etc.

 

at the end froxlor port gives this error , even if powerdns is installed.

 

===>   Registering installation for powerdns-4.0.1 as automatic
Installing powerdns-4.0.1...
*******************************************************************
 Enable powerdns in /etc/rc.conf with the following line:

    pdns_enable="YES"

 A configuration template is available in /usr/local/etc/pdns
 as pdns.conf-dist.

 A pdns.conf with all possible options is available in
 /usr/local/share/examples/powerdns

 ---------------------------------------------
 IMPORTANT: PowerDNS Authoritive Server 3.4.0+:
 ---------------------------------------------
 This version needs a mandatory schema change for the gmsyql,
 gpgsql and gsqlite3 backends. SQL statements are available in
 /usr/local/share/doc/powerdns or http://doc.powerdns.com
*******************************************************************

===> SECURITY REPORT:
      This port has installed the following files which may act as network
      servers and may therefore pose a remote security risk to the system.
/usr/local/bin/nproxy
/usr/local/bin/dnstcpbench
/usr/local/sbin/pdns_server
/usr/local/bin/dnsreplay
/usr/local/bin/stubquery
/usr/local/bin/sdig
/usr/local/bin/ixplore
/usr/local/bin/dumresp
/usr/local/bin/pdnsutil

      This port has installed the following startup scripts which may cause
      these network services to be started at boot time.
/usr/local/etc/rc.d/pdns

      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.

      For more information, and contact details about the security
      status of this software, see the following webpage:
http://www.powerdns.com/
===>   froxlor-0.9.33.2 depends on executable: powerdns - not found
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/sysutils/froxlor
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/froxlor
 

Share this post


Link to post
Share on other sites
  • 0

after adding powerdns to rc.conf , the froxlor port gives this error and i am stuck but i am able to run powerdns executable.

from here /usr/local/etc/rc.d/pdns
 

 

root@:/usr/ports/sysutils/froxlor # make install
===>  Staging for froxlor-0.9.33.2
===>   froxlor-0.9.33.2 depends on executable: opendkim - found
===>   froxlor-0.9.33.2 depends on file: /usr/local/lib/nss_mysql.so - found
===>   froxlor-0.9.33.2 depends on executable: logrotate - found
===>   froxlor-0.9.33.2 depends on executable: nginx - found
===>   froxlor-0.9.33.2 depends on executable: postfix - found
===>   froxlor-0.9.33.2 depends on package: dovecot2>=2 - found
===>   froxlor-0.9.33.2 depends on executable: pure-ftpd - found
===>   froxlor-0.9.33.2 depends on executable: powerdns - not found
===>   froxlor-0.9.33.2 depends on executable: powerdns - not found
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/sysutils/froxlor
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/froxlor
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now