Jump to content
Froxlor Forum
  • 0
newan

Support f?r Let's Encrypt

Question

Hallo,

 

Let's Encrypt startet am 3. Dezember die open Beta und es w?re super die Zertifikate mit Froxlor zu verwenden.

Ich habe es bisher mit einem Beta account nicht geschafft die Konfig dauerhaft am laufen zu haben.

 

Ist es geplant dies offziell zu unterst?tzen? K?nnte man ja super in den Cronjob mit einbinden etc?

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Ich habe auch default Froxlor (neuste Git version) und obwohl SSL aktiviert ist und die ssl ip zugewiesen ist, bekomme ich "ERR_CONNECTION_REFUSED" wenn ich die seite mit https besuche. Er leitet auch http nicht auf https um obwohl es eingeschaltet ist (und mod_rewrite aktiviert ist, die vhost stimmt auch).

Habe es bisher nur mit Let'sencrypt versucht, weiß nicht ob der fehler auch bei einem normalen cert auftauchen würden.

Share this post


Link to post
Share on other sites
  • 0

Hört denn der Apache auch auf Port 443? Also hast du ein globales oder explizites "Listen"-Statement für den Port? Der Thread wird hier langsam etwas vergewaltigt für alle möglichen Anfragen, eventuell macht es Sinn hier ein eigenes Thema zu beginnen?!

Share this post


Link to post
Share on other sites
  • 0

Hi, Eine Frage: Wo kann man das Letsencrypt - Log sehen?

 

Hintergrund ist, dass es ja verschiedene Limits gibt, die LE hat, so zB x Fehlversuche, x Zertifikate pro Domain und Woche. Kann man das durch die Logs in Erfahrung bringen?

Share this post


Link to post
Share on other sites
  • 0

Wird zukünftig in der Log des entsprechenden Kunden zu sehen sein, ist jetzt schon in der "komplett"-Log des admins zu sehen (menü links -> System-logging)

Share this post


Link to post
Share on other sites
  • 0

Ich probiere das auch gerade aus und es klappt nicht.

Ich hatte LetsEncrypt vorher schon benutzt und wollte es jetzt für eine andere Domain mit Froxlor testen, in der zugehörigen vhost-ssl-conf steht:

 

  SSLCertificateFile /etc/apache2/apache2.pem
  SSLCertificateKeyFile /etc/apache2/apache2.key
 

Was ja schon mal nicht richtig ist.

 

Im System-Logging finde ich dann folgendes:

 

Could not get Let's Encrypt certificate for xxxxx.de: Please check http://xxxxx.de/.well-known/acme-challenge/HvmuX9PBGs-1co2a7n7qVQIQ3Fn82jlsUTW-GceBdOc - token not available

 

Jo, das Verzeichnis .well-known gibt's da auch nicht.

 

Bei den Domains, für die ich das Zertifikat manuell erstellt und in Froxlor eingetragen habe, funktioniert es auch einwandfrei.

 

Anfangs lief der Cron-Job übrigend gar nicht los, da stand im Dashboard:

aktualisiert Let's Encrypt Zertifikate: 19.01.2038

 

So lange wollte ich aber nicht warten :-). Hab den master dann mit --force gestartet, nun läuft der jedenfalls, aber halt obige Fehlermeldung.

 

Any idea?

 

Lobo

Share this post


Link to post
Share on other sites
  • 0

Alias "/.well-known/acme-challenge" "/var/www/html/.well-known/acme-challenge"
<Directory "/var/www/html/.well-known/acme-challenge">
    Require all granted
</Directory>

 

in  /etc/apache2/conf-enabled/acme.conf ?

 

Wobei /var/www/html/das froxlor-verzeichnis ist.

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

das Verzeichnis "/var/www/froxlor/.well-known/acme-challenge"

 

gibt es, aber ein /etc/apache2/conf-enabled/

gibt es nicht, auch keine acme.conf.

Share this post


Link to post
Share on other sites
  • 0

Du solltest im Froxlor-Backend die Server-Konfiguration für Apache noch mal machen.

"/etc/apache2/conf-enabled/" Ist Ubuntu/Debian-spezifisch...

Share this post


Link to post
Share on other sites
  • 0

Ich habe Debian Wheezy 7.9 laufen.

conf-enabled/ gab's dann wohl bei der Installation noch nicht.

Wird übrigens bei der aktuellen Froxlor-Version auch nicht angelegt, das fehlt noch im "Script".

 

Ich werde mir das mal vorsichtig anschauen, da laufen immerhin etliche Domains dauf ;-)

Share this post


Link to post
Share on other sites
  • 0

So, hab das mal gemacht, war ja nicht viel. Verzeichnis angelegt, acme.conf erstellt, Apache neu gestartet, aber keine Veränderung, gleiche Fehlermeldung...

Share this post


Link to post
Share on other sites
  • 0

conf-enabled/ gab's dann wohl bei der Installation noch nicht.

Wird übrigens bei der aktuellen Froxlor-Version auch nicht angelegt, das fehlt noch im "Script".

 

hat froxlor noch nie gemacht und macht froxlor auch nicht, ein ordner für zusatzconfigs stellt normal apache selbst, bei den meisten ist das neben dem pendent "sites-enabled" nunmal "conf-enabled"

Share this post


Link to post
Share on other sites
  • 0

Bei Debian ist aber der Standard /etc/apache2/conf-enabled/....wenn das bei dir nicht so ist, musst du bitte den entsprechenden Ordner nutzen, so dass die configs inkludiert wird.

Share this post


Link to post
Share on other sites
  • 0

Es gibt ein sehr gutes, Youtube Video für das Einrichten von SSL mit FROXLOR:

 

 

Es wäre toll dieses upzudaten für SSL, FROXLOR und LET´S ENCRYPT.

Share this post


Link to post
Share on other sites
  • 0

Topic locked - if you have any problems or questions please feel free to create a new one

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.





×
×
  • Create New...