Jump to content
Froxlor Forum
  • 0
Rogue1639

404 Not Found Froxlor install

Question

Guten Abend Community,

ich hoffe ihr k?nnt mir etwas weiter helfen.
Ich m?chte auf meinen Dedicated-Server Froxlor installieren.
Bis jetzt hat es auf meinen alten Server (alter Anbieter) auch geklappt.
Jetzt wo ich einen neuen Anbieter und einen Neuen Dedicated-Server
habe, klappt die normale Installation nicht mehr richtig.

Also ich habe mich diesmal an dieser Anleitung gerichtet..
https://blog.secretisland.de/froxlor-installation-debian/

Die Installation verlief ohne Fehler...
Aber, wenn ich nun die Froxlor Einrichtung aufrufe mit: IP: <meineip>/froxlor/install/install.php
kommt diese Fehlermeldung:

Not Found

The requested URL /froxlor was not found on this server.
Apache/2.4.10 (Debian) Server at xx.xx.xx.xx Port xx
 

(hei?t soviel, dass Froxlor nicht auf meinen Server zu finden ist).
Froxlor ist aber unter /var/www/froxlor installiert.
Ordner rechte 0755

Hintergrund Info:
System: 
Debian 8 - Minimal - RAID1
php5
Apache2
mysql-server
phpmyadmin
proftpd

der Apache2 l?uft auch, da ich die Standard index.html und auch als index.php oder phpinfo.php sich ?ffnen l?sst.


Mit freundlichen Gr??en
rogue1639

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hallo,

 

Vermutlich liegt es daran, dass standardm??ig der Documentroot von Apache 2.4 unter Debian 7/8 nicht mehr "/var/www" ist, sondern "/var/www/html". 

 

Das l?sst sich allerdings leicht beheben, indem du folgende Datei ?ffnest und den Documentroot von "/var/www/html" zu "/var/www" ?nderst. 

 

nano /etc/apache2/sites-enabled/000-default

service apache2 restart

Gr??e

Share this post


Link to post
Share on other sites
  • 0

Guten Morgen,

 

danke, f?r den L?sungsweg.

Genau das war es. Jetzt geht alles wieder...

 

Gru?

Rogue

PS: Es war genau die richtige Entscheidung sich hier anzumelden :-)

Share this post


Link to post
Share on other sites
  • 0

Meinst du den Documentroot der Kunden? Der liegt unter "/var/customers/webs/[KUNDE]"

Den Documentroot der Kunden kannst du festlegen, indem du entwerder die Domains bearbeitest und dort den Pfad ?nderst, oder in den EInstellungen.

Share this post


Link to post
Share on other sites
  • 0

Mahlzeit,

 

nee das meinte ich nicht.

Aber die frage hat sich er?bricht.

Ich habe den Apche2 das verzeichnis ge?ndert, auf /var/www

 

Trotzdem euch allen Danke f?r die Hilfe.

 

Gru?

Rogue

Share this post


Link to post
Share on other sites
  • 0

Wie sollst du das verzeichnis in froxlor ?ndern k?nnen, wenn du froxlor nicht aufrufen kannst, da froxlor in /var/www/froxlor liegt und nicht /var/www/html/froxlor - unser debian paket installiert froxlor halt nach /var/www/ - du kannst gerne den gesamten froxlor ordner auch nach /var/www/html/ verschieben, nur damit ist der sinn des debian pakets dahin. Alternativ kannst du nat?rlich einfach das tar.gz benutzen und hininstallieren wo auch immer du es haben willst.

 

Aber du hast die bevorzugte Methode dieses Problem zu l?sen ja schon umgesetzt :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...