Jump to content
Froxlor Forum
  • 0

"PHP warning/error" am Login


mircsicz

Question

Am Login-Screen von Froxlor (0.9.33dev3 ausm git) bekomme ich folgende Fehlermeldung:

PHP warning/error
#2 Unknown: open(/var/customers/tmp/froxlor.panel//sess_df41388ff90485391535811bc44edb9a, O_RDWR) failed: Permission denied (13)
Unknown:0

PHP warning/error
#2 Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/customers/tmp/froxlor.panel/)
Unknown:0

Der FPM Prozess scheint mit den Rechten von www-data ausgef?hrt zu werden:

ps axuw |grep websrv
www-data  6351  0.0  1.0 197728 22328 ?        S    Dez18   0:43 php-fpm: pool websrv.xxx.de

Und der das Temp-Verz. geh?rt aber als froxlorlocal:

ll /var/customers/tmp/|grep froxlor
drwxr-x--- 2 froxlorlocal froxlorlocal  44K Dez 16 09:09 froxlor.panel

Und der Socket geh?rt www-data:

ll /var/run/nginx/|grep froxlor
srw-rw---- 1 www-data     www-data     0 Dez 18 15:32 froxlor.panel-websrv.xxx.de-php-fpm.socket

Hier die vollst?ndige /etc/php5-fpm.d/websrv.xxx.de.conf und der aus meiner Sicht relevante Ausschnitt:

listen = /var/run/nginx/froxlor.panel-websrv.xxx.de-php-fpm.socket
listen.owner = www-data
listen.group = www-data
listen.mode = 0660
user = www-data
group = www-data

Gem?? der Gruppenzuordnungen sollte eigentlich gehen:

root@websrv:/var/www/froxlor# groups froxlorlocal
froxlorlocal : froxlorlocal www-data
root@websrv /var/www/froxlor# groups www-data
www-data : www-data froxlorlocal ONE XXX NJ MKP ETC

Auch hier kann ich mit einem beherzten "chown -R www-data:www-data /var/customers/tmp/froxlor.panel" das Prob l?sen. Nachher mache ich einen reboot um zu verifizieren ob es behoben 'bleibt'...

 

Hat einer von euch ne Idee wo die "falschen" Permissions auf '/var/customers/tmp/froxlor.panel' herkommen k?nnten?

Link to post
Share on other sites

1 answer to this question

Recommended Posts

listen.owner = www-data
listen.group = www-data
user = www-data
group = www-data

Das sollte aber eigentlich alles "froxlorlocal" sein...hast du den Benutzer in den Einstellungen auch korrekt angegeben?

Link to post
Share on other sites

Damn, einen Punkt net nachgeschaut und der wars dann auch! Im Panel unter "Server > Settings > Webserver Settings" war der user auf www-data... Und ich nehme mal an dass ich den selbst ge?ndert hatte als der 502 so um sich schlug! :-(

 

THX

 

Nach dem reboot markier ich die beiden Thread's dann als "answered"...

Link to post
Share on other sites

Es ist fast alles reboot-fest, aber leider wird /var/customers/tmp/froxlor.panel mit den falschen Perms erzeugt:

root@websrv:~# ll /var/customers/tmp/
insgesamt 1,9M
drwxr-x--- 2 EDL          EDL          244K Dez 20 18:29 EDL
drwxr-x--- 2 www-data     www-data      44K Dez 19 20:37 froxlor.panel

Die frisch erzeugte Config passt aber:

PHP-FPM configuration for "websrv.xxx.de" created on 2014.12.20 18:53:18
[websrv.xxx.de]
listen = /var/run/nginx/froxlor.panel-websrv.xxx.de-php-fpm.socket
listen.owner = froxlorlocal
listen.group = froxlorlocal
listen.mode = 0660
user = froxlorlocal
group = froxlorlocal

Ich mach nachher nochmal einen reboot, mal sehen...

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...