Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Infected

Nginx 1.6.2 + PHP5-FPM = 502 Bad Gateway

Question

Hall?chen zusammen,

leider habe ich gerade einen weiteren Fehler entdeckt, den ich mir nicht erkl?ren kann.

 

Ich habe einen neuen kunden angelegt.

?ber diesen Kunden habe ich mir eine Forensoftware installiert.

Soweit alles ok.

Ich sehe das Forum auch.

Doch wenn ich mich nun versuche, im ACP anzumelden, bekomme ich einen 502 Bad Gateway Error.

Jetzt frage ich mich, wie so etwas sein kann, wenn das Forum an sich ja wunderbar l?uft.

 

Log:

2014/10/26 15:07:04 [error] 3609#0: *305 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XX.XX.XX.XX, server: meineseite.de, request: "GET /admincp/index.php?adsess=a849e802283436a013858985c929bf35 HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/kunde-php-fpm.socket:", host: "meineseite.de", referrer: "http://meineseite.de/admincp/index.php"

Forum funktioniert und auch den Login vom ACP sehe ich.

Soch sobald ich auf Login dr?cke, bekomme ich den Fehler.

 

Informationen

Betriebssystem: Debian 7 x64

Webserver: Nginx 1.6.2 PHP5-FPM

 

Benutze Source:

deb http://packages.dotdeb.org wheezy all
deb-src http://packages.dotdeb.org wheezy all

deb http://packages.dotdeb.org wheezy-php56 all
deb-src http://packages.dotdeb.org wheezy-php56 all

Ich habe die gleiche Forensoftware schoneinmal installiert, allerdings habe ich damals noch nicht die neuere Nginx und PHP Version von DotDeb benutzt.

Kann das daran liegen?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

Wieso versuchst du es nicht erstmal mit den "standard-paketen" von debian? Es muss doch nicht gleich php-5.6 sein (ich wette es gibt nicht EIN feature dieser version auf das du angewiesen bist!)

Share this post


Link to post
Share on other sites

Das ist soweit richtig.

Ich entnehme deiner Antwort, dass Probleme bei Froxlor und PHP 5.6 bekannt sind.

Daher werde ich ganz einfach wieder zum Debian standard springen :)

Share this post


Link to post
Share on other sites

Ich entnehme deiner Antwort, dass Probleme bei Froxlor und PHP 5.6 bekannt sind.

 

Lege mir doch bitte nicht etwas in den Mund was ich nicht gesagt habe...das ist schlichtweg falsch. Froxlor funktioniert wunderbar mit php-5.6 - ich habe lediglich gefragt wieso du denn gleich ein dotdeb paket nimmst und es nicht erstmal mit den Standard-Paketen versuchst (bei anderen klappts ja auch).

 

Hast du denn fpm etc. auch korrekt installiert und konfiguriert? (Siehe wiki)

Share this post


Link to post
Share on other sites

×
×
  • Create New...