Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Infected

Hauptdomain leitet auf Panel statt auf Seite

Question

Guten Morgen zusammen,

seit l?ngerem arbeite ich jetzt mit Froxlor und bin super zufrieden.

 

Leider sto?e ich gerade auf ein Problem, welches ich nicht l?sen kann.

Daher hoffe ich, dass ihr mir helfen k?nnt.

 

Folgende Situation:

Ich habe auf meinem Server Froxlor installiert.

Nun wolle ich Forxlor ?ber den Hostnamen direkt erreichbar machen (froxlor.meinedomain.de).

Soweit so gut, funktioniert auch.

Zudem wolte ich, wie ich es auch schon immer gemacht habe, ?ber meine Domain eine normale Seite anzeigen lassen.

Dazu habe ich also eine neue Domain in Froxlor angelegt und ihr den Alias (www.) zugeordnet.

Die VHosts wurden erstellt und die passende Verzeichissstruktur angelegt.

 

Doch statt meiner Seite, bzw der Froxlor Wellcome Page werde ich trotzdem auf das Froxlor Panel weitergeleitet.

Ich habe darauf die VHosts gepr?ft, aber die scheinen OK zu sein.

Nun verstehe ich nicht, wieso Froxlor die Domain nicht zum passenden Verzeichiss leitet.

 

Vielleicht noch zu erw?hnen ist, dass ich 2 IPs konfiguriert habe.

 

 

Auszug VHost Froxlor Hostname mit IP 1:

	listen    1.1.1.1:80 default;
	# Froxlor default vhost
	server_name    froxlor.meinedomain.de;
	access_log      /var/log/nginx/access.log;
	root     /var/www/froxlor/;

Auszug VHost Froxlor Hostame mit IP 2:

	listen    2.2.2.2:80 default;
	# Froxlor default vhost
	server_name    froxlor.meinedomain.de;
	access_log      /var/log/nginx/access.log;
	root     /var/www/froxlor/;

Auszug VHost MeineDomain ?ber IP 2:

	listen 2.2.2.2:80;
	server_name meinedomain.de www.meinedomain.de;
	access_log /var/customers/logs/admin-access.log combined;
	error_log /var/customers/logs/admin-error.log error;
	root /var/customers/webs/kunde/meinedomain.de/;

Wie man sieht, stimmen die Rootverzeichnisse sowie die Servernamen.

Daher verstehe ich nicht, wieso ich wenn ich meinedomain.de oder www.meinedomain.de aufrufe, das Froxlor Panel zu Gesicht bekomme.

Ich hoffe, ihr k?nnt mir helfen.

 

 

PS:

Nur um das klar zu stellen, die IPs sind nat?rlich nicht meine :)

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

Sieh mal nach ob noch irgendwelche anderen vHosts rumliegen - z.B. von vor der Installation. z.B. mittels grep -ir "meinedomain.de" /etc/apache2

Share this post


Link to post
Share on other sites

Genau, ist Nginx mit PHP-FPM.

H?tte ich vielleicht auch mal erw?hnen sollen, sry ^^

 

Es sind keine weiteren VHosts vorhanden.

Auch nicht der Default.

 

Ich bin echt rahtlos.

Share this post


Link to post
Share on other sites

Kein Ding, h?tte ich ja auch gleich dabei schreiben k?nnen :)

 

Hier meine nginx.conf:

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
	worker_connections 768;
	# multi_accept on;
}

http {

	##
	# Basic Settings
	##

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;
	keepalive_timeout 65;
	types_hash_max_size 2048;
	# server_tokens off;

	# server_names_hash_bucket_size 64;
	# server_name_in_redirect off;

	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	##
	# Logging Settings
	##

	access_log /var/log/nginx/access.log;
	error_log /var/log/nginx/error.log;

	##
	# Gzip Settings
	##

	gzip on;
	gzip_disable "msie6";

	# gzip_vary on;
	# gzip_proxied any;
	# gzip_comp_level 6;
	# gzip_buffers 16 8k;
	# gzip_http_version 1.1;
	# gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

	##
	# nginx-naxsi config
	##
	# Uncomment it if you installed nginx-naxsi
	##

	#include /etc/nginx/naxsi_core.rules;

	##
	# nginx-passenger config
	##
	# Uncomment it if you installed nginx-passenger
	##
	
	#passenger_root /usr;
	#passenger_ruby /usr/bin/ruby;

	##
	# Virtual Host Configs
	##

	include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/sites-enabled/*;
}


#mail {
#	# See sample authentication script at:
#	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#	# auth_http localhost/auth.php;
#	# pop3_capabilities "TOP" "USER";
#	# imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#	server {
#		listen     localhost:110;
#		protocol   pop3;
#		proxy      on;
#	}
# 
#	server {
#		listen     localhost:143;
#		protocol   imap;
#		proxy      on;
#	}
#}


Ich habe gerade einfach mal alle VHosts bis auf die, die nicht funktioniert hat gel?scht.

Dann habe ich Nginx neugestartet

Und pl?tzlich ging die Seite.

Daraufhin habe ich die anderen nach und nach wieder eingef?gt und auch jedesmal Nginx neugestartet.

Jetzt sind alle VHosts wieder drin, also so, wie es davor auch war, aber jetzt geht alles.

 

Normalerweise sollte nginx doch beim erstellen der neuen VHosts einen reload machen.

Kann es sein, dass da evtl. was fehlschl?gt?

 

Edit:

Ich habe auf meinem System "sudo" installiert.

Fehlt vielleicht dem Froxlor Benutzer ein Recht?

Share this post


Link to post
Share on other sites

Der cronjob von froxlor sollte als "root" laufen, daher gibts keine berechtigungs-probleme beim restart. Pr?fe doch das Restart-Kommando in den Einstellungen...

Share this post


Link to post
Share on other sites

Du hast ja nur die basis-Konfiguration gepostet - nicht aber die ganzen Ordner die included werden (include /etc/nginx/conf.d/*.conf; include /etc/nginx/sites-enabled/*;) - aber wenns jetzt mittlerweile schon geht dann ists ja gut.

 

Pr?f mal deinen Froxlor-Cronjob und ruf ihn ggf. manuell ohne -q aber mit --force auf um zu sehen obs irgendwelche Fehlermeldungen gibt

Share this post


Link to post
Share on other sites

×
×
  • Create New...