Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
iSweety

vHosts werden ignoriert

Question

Guten Tag,

ich habe ein kleines Problem mit den vHosts. Meine Konfiguration siehe Signatur.

Die vHost-Dateien in "/etc/nginx/sites-enabled" werden auch erstellt, Inhalt korrekt.

Allerdings werden die nicht geladen.

In der nginx Konfiguration steht der Pfad auch auf include /etc/nginx/sites-enabled/*;.

Was ist zu tun?

 

Mit freundlichen Gr??en,

iSweety

 

 

#edit:

Hier ist einmal die Konfiguration von bk001.vweb01.bukkcom.de. Wenn ich bk001.vweb01.bukkcom.de aufrufe, kommt der Fehler, dass der Server nicht erreichbar w?hre:

# 20_froxlor_normal_vhost_bk001.vweb01.bukkcom.de.conf
# Created 22.08.2014 23:02
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
	listen 185.28.77.73:80;
	server_name bk001.vweb01.bukkcom.de *.bk001.vweb01.bukkcom.de;
	access_log /var/customers/logs/bk001-access.log combined;
	error_log /var/customers/logs/bk001-error.log error;
	root /var/customers/webs/bk001/;
	location / {
		index index.php index.html index.htm;
		try_files $uri $uri/ @rewrites;
	}
	location @rewrites {
		rewrite ^ /index.php last;
	}
	location /webalizer {
		alias /var/customers/webs/bk001/webalizer/bk001.vweb01.bukkcom.de/;
		auth_basic "Restricted Area";
		auth_basic_user_file /etc/nginx/froxlor-htpasswd/1-fd7da6a3e35bd3aa80d08e3adb18b281.htpasswd;
	}
	location ~ \.php$ {
		try_files $uri =404;
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		fastcgi_pass unix:/var/run/nginx/bk001-bk001.vweb01.bukkcom.de-php-fpm.socket;
		fastcgi_index index.php;
		fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
		include /etc/nginx/fastcgi_params;
	}
}

Die Log-Dateien beispielsweise werden erstellt, drin steht aber nichts.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

bk001.vweb01.bukkcom.de zeigt aucht nicht auf deine Server-IP - pr?fe deine DNS Eintr?ge

Share this post


Link to post
Share on other sites

Hey,

Danke f?r deine Antwort.

Hab ich eben leider auch bemerkt. Ich hab meinem Teamler der die DNS Eintr?ge verwaltet bereits bescheid gesagt.

 

MfG

iSweety ^^

Share this post


Link to post
Share on other sites

Soo @d00p.

Er hat das nun eben gemacht und die werden auch weitergeleitet auf den Server.

Allerdings werden die Subdomains noch nicht an die entsprechenden Webspaces weitergeleitet.

Hier mal ein aktueller vHost Eintrag

# 20_froxlor_normal_vhost_web1.vweb01.bukkcom.de.conf
# Created 23.08.2014 00:35
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
	listen 185.28.77.73:80;
	server_name web1.vweb01.bukkcom.de *.web1.vweb01.bukkcom.de;
	access_log /var/customers/logs/web1-access.log combined;
	error_log /var/customers/logs/web1-error.log error;
	root /var/customers/webs/web1/;
	location / {
		index index.php index.html index.htm;
		try_files $uri $uri/ @rewrites;
	}
	location @rewrites {
		rewrite ^ /index.php last;
	}
	location /webalizer {
		alias /var/customers/webs/web1/webalizer/web1.vweb01.bukkcom.de/;
		auth_basic "Restricted Area";
		auth_basic_user_file /etc/nginx/froxlor-htpasswd/2-735d9ba174d82d7bea0ffdfb1551a030.htpasswd;
	}
	location ~ \.php$ {
		try_files $uri =404;
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		fastcgi_pass unix:/var/run/nginx/web1-web1.vweb01.bukkcom.de-php-fpm.socket;
		fastcgi_index index.php;
		fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
		include /etc/nginx/fastcgi_params;
	}
}

Share this post


Link to post
Share on other sites

So wie es aussieht hast du wohl einen vhost der zuerst greift...anders kann ich es mir nicht erkl?ren.

 

Bitte mal die Ausgabe von:

ls -la /etc/nginx/ 
ls -la /etc/nginx/sites-enabled/
und am besten die nginx.conf gleich dazu

Share this post


Link to post
Share on other sites

@d00p

hier die nginx.conf

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
	worker_connections 768;
	# multi_accept on;
}

http {

	##
	# Basic Settings
	##

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;
	keepalive_timeout 65;
	types_hash_max_size 2048;
	# server_tokens off;

	# server_names_hash_bucket_size 64;
	# server_name_in_redirect off;

	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	##
	# Logging Settings
	##

	access_log /var/log/nginx/access.log;
	error_log /var/log/nginx/error.log;

	##
	# Gzip Settings
	##

	gzip on;
	gzip_disable "msie6";

	# gzip_vary on;
	# gzip_proxied any;
	# gzip_comp_level 6;
	# gzip_buffers 16 8k;
	# gzip_http_version 1.1;
	# gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

	##
	# nginx-naxsi config
	##
	# Uncomment it if you installed nginx-naxsi
	##

	#include /etc/nginx/naxsi_core.rules;

	##
	# nginx-passenger config
	##
	# Uncomment it if you installed nginx-passenger
	##
	
	#passenger_root /usr;
	#passenger_ruby /usr/bin/ruby;

	##
	# Virtual Host Configs
	##

	include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/sites-enabled/*;
}


#mail {
#	# See sample authentication script at:
#	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#	# auth_http localhost/auth.php;
#	# pop3_capabilities "TOP" "USER";
#	# imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#	server {
#		listen     localhost:110;
#		protocol   pop3;
#		proxy      on;
#	}
# 
#	server {
#		listen     localhost:143;
#		protocol   imap;
#		proxy      on;
#	}
#}

Danke,  dass du mir hilfst (:

 

Lg

Share this post


Link to post
Share on other sites

Okey das hat sich inzwischen erledigt. Da hat mir nen guter bekannter geholfen.

Ich hab auf der falschen IP gehorcht. Das ist jetzt aber korrekt umgestellt und die werden auch korrekt umgeleitet. Nun aber ein Fehler scheinbar bei den Rechten.

 

Wenn ich beispielsweise auf web1.vweb01.bukkcom.de gehe, kommt 403. Wenn ich auf web1.vweb01.bukkcom.de/webalizer gehe, fragt der nach den Daten, werden aber nicht annerkannt. Und der Name wird auch nicht korrekt gesendet da steht dennoch Restricted Area.

 

In der web1-error.log steht:

2014/08/23 18:46:13 [crit] 30762#0: *21 stat() "/var/customers/webs/web1/index.php" failed (13: Permission denied), client: 109.47.3.162, server: web1.vweb01.bukkcom.de, request: "GET /larifari.html HTTP/1.1", host: "web1.vweb01.bukkcom.de"

Lg

Share this post


Link to post
Share on other sites

Wie sind die Rechte des Kunden-Ordners?
 

ls -la /var/customers/webs/
ls -la /var/customers/webs/web1/

Share this post


Link to post
Share on other sites


$ ls -la /var/customers/webs/web1/

total 16

drwxr-x--- 3 www-data www-data 4096 Aug 23 18:04 .

drwxr-xr-x 4 www-data www-data 4096 Aug 23 02:35 ..

-rwxr-x--- 1 www-data www-data 1681 May 23 08:29 index.php

drwxr-x--- 2 www-data www-data 4096 Aug 23 01:50 webalizer

 


$ ls -la /var/customers/webs/

total 16

drwxr-xr-x 4 www-data www-data 4096 Aug 23 02:35 .

drwxr-xr-x 6 www-data www-data 4096 Aug 22 20:14 ..

drwxr-x--- 3 www-data www-data 4096 Aug 23 18:04 web1

drwxr-x--- 3 www-data www-data 4096 Aug 23 17:51 web2

 

Share this post


Link to post
Share on other sites

Wieso geh?rt der Kunden-Ordner nicht dem Kunden? Da kann was bei dir nicht stimmen, denn der Froxlor-Cronjob legt die Ordner an und setzt die Rechte korrekt...hast du dran rumgespielt?

Share this post


Link to post
Share on other sites

Mein Teamler, ja.

Das komische ist, wir haben nur an web1 bisschen mit den rechten probiert. Bei web1 funktioniert nichts. Bei web2 hingegen kommt die Domain default page und bei web3 wie bei web1 ein 403 Error.

Bei web2 haben wir nichts gemacht. Den Benutzer web3 habe ich eben angelegt und NICHTS ver?ndert. Weder im Admin-/Userpanel noch in irgendwelchen Einstellungen. Den User web3 habe ich einfach erstellen lassen.

 

Ich habe dir hier mal eine kleine Seite mit, ich hoffe allen ben?tigten Informationen angelegt: http://vweb01.bukkcom.de/froxinfo

Share this post


Link to post
Share on other sites

  • Similar Content

    • By alex84
      Hi,
      wie der Titel schon sagt: Ich würde gerne bei einer Subdomain eigene vhost-Einstellungen vornehmen. Leider taucht (bei mir) das entsprechende Feld beim Kunden in "(Sub-)Domain bearbeiten" nicht auf. Liegt das vielleicht daran, das bei der Hauptdomain im vhost-Bereich die Checkbox "Übernehme Einstellungen für alle Subdomains" angehakt ist? Falls dem so ist, wie bekomme ich den Haken weg? Dieser weigert sich, zu verschwinden, nach jedem Speichern ist er wieder da. (Was könnte hier das Problem sein?) Hier der Screenshot, welchen ich meine:

      Oder geht das generell nicht über Froxlor und ich müsste das "außenrum" lösen? Oder bei der Hauptdomain über ein generelles 
      IncludeOptional /var/customers/additionalVhostConfigs/{CUSTOMER}/{DOMAIN}/*.conf ? Deutlich schöner fände ich es allerdings, wenn es bei der Subdomain ginge. Trac (zum Beispiel) verlangt ein paar Einstellungen, die via .htaccess nicht zulässig sind...
      Danke, Alex
    • By ZeroGodForce
      Hello there,
       
      I've set up a new domain inside froxlor and uploaded site source into the document root, yet when I attempt to access the domain, I'm routed to the froxlor login page.
       
      I don't know where froxlor keeps it's customer vhost config files. I've checked in the default apache location and it isn't there. Only the main froxlor vhost resides.
       
      I'm sure it's something really simple that I've missed, but I'm new to froxlor and have used a bunch of other (terrible) panels, so maybe I'm just looking in the wrong places. Any advice would be greatly appreciated.
       
      Thanks
    • By gab
      Hi all,
       
      I searched in the forum, but the answers weren't to clear to me(since one says Yes, and other No), and SysCP worked with different versions from php(yes, using fcgid).

      My question is quite simple: Can I use PHP 5.4 for customer A, and PHP 5.5 for customer B? I have to upload the php.ini, but how? 
       
      And if just keeps compatibility with fcgi, where can I find a Howto with that?
       
      Environment:
       
      Nginx 1.6
      PHP 5.4.14 with FPM(which runs Froxlor)
      PHP 5.4.30 with FPM
      PHP 5.5.14 with FPM
       
       
       
      Yes:
      http://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/
       
      No:
      http://forum.froxlor.org/index.php/topic/12610-erledigt-php-fpm-verschiedene-php-versionen/
       
       
      And if I should do another question in the same topic, is there a way to set ssh login to all users without mysql every time with new user added?  I mean, setting different shells(just /bin/false, or /bin/bash)? Or should I patch it?
       
      TIA
       
      Best Regards,
       
      Gabriel
×
×
  • Create New...