Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Manuel

[solved] Keine Webseiten werden angezeigt

Question

Hallo,

 

ich habe heute mein Server neuinstalliert gehabt und Froxlor neuinstalliert gehabt und habe gesehen es gab direkt eine neue Version von Froxlor.

Abgesehen von meinem Problem im IRC, wo ein Cache leeren gereicht hat.

 

Habe ich ein ganz anderes Problem,

 

ich habe ein Kunde angelegt + eine Domain, nun ist das Problem aber:

 

Die Webseiten werden gar nicht angezeigt, nichtmal der Inhalt von der index.html, die Froxlor Standartm??ig erstellt und die einzige Fehlermeldung die ich vorweisen kann ist:

 

 

[sat May 31 00:23:10 2014] [crit] [client 77.11.45.125] (13)Permission denied: /var/customers/webs/web1/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

 

das Problem hatte ich mit der vorherige Versi0on jedoch nicht.

Share this post


Link to post
Share on other sites

Recommended Posts

Problem ist gel?st, die Rechte vom Kunden hauptverzeichnis war statt 755 auf 750 gewesen.

 

Bitte in der n?chsten Froxlor Version wieder korregieren

Share this post


Link to post
Share on other sites

Es wurde nichts an der umask ge?ndert von 0.9.31 auf 0.9.32....

Share this post


Link to post
Share on other sites

Angenommen es w?re so ;)

 

Dann h?tte ich das Problem schon mit der 0.9.31 haben m?ssen, hatte ich aber nicht.

 

Das mit dem Cache ok, war mein Fehler. H?tte ich leeren sollen, aber das ist nun ein Problem, was ganz gewiss nicht an mir liegt.

 

Denn es kann nicht sein, das bei einer erst Installatioin von 0.9.31 alles klappt, aber jetzt bei der Version 0.9.32 eben nicht.

Share this post


Link to post
Share on other sites

Ich kann mich nur wiederholen, da wurde von unserer Seite aus nichts ge?ndert. Das brauchst du auch nicht nur annehmen, das kannst du sogar via diff beweisen ;)

Share this post


Link to post
Share on other sites

Ich werde meine Konfigurationen ?berpr?fen, ich kann zwar jetzt schon sagen das bei mir alles in Ordnung ist.

 

Aber den beweis liefer ich ;)

Share this post


Link to post
Share on other sites

Ich sage auch nicht das es total ausgeschlossen ist. Ich sage nur das nichts ge?ndert wurde und ich den Fehler nicht reproduzieren kann. Ich schaue gerne genauer nach wenn ich auch genauer weiss was du da gemacht hast ;)

Share this post


Link to post
Share on other sites

Ich habe ganz normal Debian minimal installieren gelassen, paar Pakete die ich brauche nachinstalliert.

 

Danach  habe ich ganze normal Froxlor via apt-get installiert, in Froxlor unter Server -> Konfiguration alle Dienste die ich haben wollte installiert und konfiguriert und zwar genau die Inhalte die dort vorgeschrieben sind.

 

Spricht, Froxlor ist ganz normal ganz sauber installiert und konfiguriert worden.

Share this post


Link to post
Share on other sites

Installiere und konfiguriere libnss-mysql und alles ist gut. Oder, wenn du unbedingt m?chtest, ?ffne scripts/jobs/cron_tasks.php und l?sche oder ?ndere folgende Zeile:

safe_exec('chmod 0750 ' . escapeshellarg($userhomedir)); 

Share this post


Link to post
Share on other sites

Wie ich gerade in diesem Thread Froxlor 0.9.32 directory permissions

 

sehe, hat also noch jemand das gleiche Problem.

 

Das finde ich gut so, denn so kann man mir jetzt nicht unterstellen.

 

Dass kein Fehler gemacht wurde und ich der einzige w?re.

 

Vorallem: Dass es nur daran liegt weil man kein libnss-mysql nutzt, denn man kann niemanden dazu zwingen, obwohl man es auch f?r alle anderen andersweitig l?sen kann

Share this post


Link to post
Share on other sites

Es ist nur ein Problem bei mod_php...und da oben steht wie du es umgehst. Es kommt bald ein Fix raus, aber es betrifft nun mal nur einen sehr kleinen Kreis von Usern

Share this post


Link to post
Share on other sites

Kann ja m?glich sein, aber man sollte trotzdem nicht jemanden irgendein Paket aufzwingen. was man vorher auch nie hatte.

Share this post


Link to post
Share on other sites

Dann bleib doch einfach bei 0.9.31 ...mein gott, man kann auch aus ner M?cke nen Elefanten machen

Share this post


Link to post
Share on other sites

Danke wunderbar. M?cke erledigt.

 

Ich hab fpm nochnicht am laufen, da beim letzten Versuch irgendwas schief gagangen war. ?ffne wahrscheinlich noch einen Thread.

So lange muss ich mal mod_php weiter verwenden und der Patch hilft klasse.

 

Einfach // davor und gut ...

Share this post


Link to post
Share on other sites

hallo.

ich habe leider das gleiche problem. libnss-mysql hatte ich schon bei der grundinstallation installiert gehabt. es sind alle angebotenen updates fuer debian wheezy (mysql-server: 5.5.37-0+wheezy1) sind installiert und bis vor kurzem hat das system ohne probleme funktioniert.

 

ich habe mir alle threads, die ich hier im forum zu diesem thema gefunden habe durchgelesen und wie beschrieben habe ich in libnss-mysql.cfg die folgenden zeilen angepasst:

memsbygid ... WHERE gid='%1$u' UNION SELECT 'www-data'

gidsbymem ... WHERE username='%1$s' UNION SELECT gid FROM ftp_users WHERE 'www-data'='%1$s'

 

nach

/etc/init.d/nscd restart

 

habe ich jede menge dieser error-messages im log:

...

Jul 17 21:14:28 ex40 apache2: libnss-mysql: mysql_query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''www-data' at line 1

Jul 17 21:21:47 ex40 postfix/proxymap[26834]: libnss-mysql: mysql_query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''postfix' at line 1, trying again (1)

...

 

....und postfix reagiert nicht mehr.

sobald ich die geaenderten parameter aus libnss_mysql.cfg wieder herausloesche, funktioniert das system wieder (abgesehen vom setzen der 0755 rechte fuer eine neuerstellten kundenordner).

 

natuerlich kann ich bis zum naechsten patch warten, allerdings mache ich mir gedanken, warum der loesungsweg bei mir neue probleme aufwirft?!

 

vielen dank falls jemand hierzu eine idee haette! :)

Share this post


Link to post
Share on other sites

hallo d00p,

 

vielen dank fuer deine antwort! ich habe die libnss-mysql.cfg wie folgt geaendert:

memsbygid   SELECT members \

            FROM ftp_groups \

            WHERE gid='%1$u'

gidsbymem   SELECT SELECT CONCAT_WS(',', gid) as gid \

            FROM ftp_groups \

            WHERE FIND_IN_SET('%1$s', members)

 

bekomme nun diese fehlermeldungen, sobald ich versuche ein mail zu verschicken:

Jul 18 09:17:40 ex40 postfix/bounce[2479]: libnss-mysql: mysql_query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT CONCAT_WS(',', gid) as gid FROM ftp_groups WHERE FIND_IN_SET('postfix', m' at line 1

Share this post


Link to post
Share on other sites

nachtrag:

sorry, habe eben gesehen, dass ich einen falschen syntax eingebaut habe!

SELECT SELECT

 

entschuldigung! ;) aber ich glaube, jetzt koennte es gehen. muss nur noch testen, ob die kundenordner nun mit den richtigen rechten angelegt werden.

vielen dank schon mal! :)

Share this post


Link to post
Share on other sites

Das ist doch auch korrekt. Jetzt sollte nur der Webserver auch in der Kundengruppe sein damit er rankommt. Darum geht es doch, das 755 zu umgehen

Share this post


Link to post
Share on other sites

ach ok! :)

ja, dann vielen dank fuer deine hilfe!! froxlor rocks! :)

 

eine frage: muss ich bei dem naechsten froxlor-update diesbezueglich etwas beruecksichtigen?

 

 

EDIT: entschuldige, aber anscheinend habe ich doch noch das problem, dass ich nicht genuegend rechte habe... der webserver ist standardmaessig www-data:www-data angelegt. weiters ist FCGID aktiviert - spielt das evtl. eine rolle?

Share this post


Link to post
Share on other sites

Hallo, ich habe den patch "ausgef?hrt"... aber ich bekomme immer noch beim Domain Aufruf 

 

Forbidden

You don't have permission to access / on this server.

 

Wie sagt man so sch?n, ich sehe momentan den Wald vor lauter B?umen nicht.

 

Das einfachste w?re wenn sich dieses einmal jemand ansehen kann (Daten per PN)

 

Danke!

Share this post


Link to post
Share on other sites

×
×
  • Create New...