Jump to content
Froxlor Forum
  • 0

SSL funktioniert nicht


YEP

Question

Hallo, 

 

ich habe SSL in Froxlor aktiviert und ebenfalls eine IP mit entsprechendem Port freigeschaltet. Nun habe ich die IP der Domain zugewiesen. Als Kunde kann man nun die SSL Zertifikate hinzuf?gen. Das habe ich ebenfalls getan. Nur wenn man die Seite aufruft ist es so als w?re keine IP hinterlegt. Chrome zeigt mir an das keine Verbindung aufgebaut werden kann. K?nnt Ihr mir vielleicht helfen?

 

 

Viele Gr??e, 

Thunderbits

Link to post
Share on other sites

23 answers to this question

Recommended Posts

Nein das ist okay. Wie lautet denn die Domain? dann pr?f ich mal ein paar DNS eintr?ge und kann mir ein bild davon machen. Gerne auch per PM wenn du sie nicht ?ffentlich machen willst.

Link to post
Share on other sites

Die Domain hat anscheinend keinen Wildcard-Eintrag, d.h. "irgendwas.deinedomain.tld" zeigt nicht auf deinen server. Nur "deinedomain.tld". Kannst du uns einen screenshot deines DNS interfaces zeigen, wo du die Domain-Einstellungen f?r den Nameserver vornimmst?

 

Ansonsten scheint ein anderes problem zu sein, dass der browser meldet "connection refused", das beudeutet meist, dass kein Service auf diesem Port lauscht. Die ausgabe von 

grep -r "Listen" /etc/apache2/

w?re hilfreich.

Link to post
Share on other sites

Hi, 

 

wenn ich den Befehl in der Konsole eingebe dann wird mir folgendes ausgeworfen (X.X.X.X=IP):

 

/etc/apache2/sites-enabled/10_froxlor_ipandport_X.X.X.X.80.conf:Listen X.X.X.X:80
/etc/apache2/sites-enabled/10_froxlor_ipandport_X.X.X.X.443.conf:Listen X.X.X.X:443
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:    Listen 443
/etc/apache2/ports.conf:    Listen 443
 
Meine DNS Eintr?ge mache ich mit CloudFlare. Hier ein Bild von allen Eintr?gen die ich habe. Ich habe vorhin noch den *.domain-Eintrag also den Wildcard Eintrag hinzugef?gt.
 
iimage.png
Link to post
Share on other sites

Hi, 

solange man die CloudFlare Funktion nicht eingeschaltet hat so wie bei dem ersten Eintrag fungiert CloudFlare als normaler DNS Service. Bei fast allen Eintr?gen ist die CloudFlare Funktion deaktiviert. Deswegen kann es nicht daran liegen.

Link to post
Share on other sites

Wollte gerade Apache2 restarten dann das:

root@server:/etc/apache2# service apache2 restart
Syntax error on line 10 of /etc/apache2/sites-enabled/10_froxlor_ipandport_XXX.XXX.XXX.XXX.443.conf:
Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
 failed! 
Link to post
Share on other sites

Habe ich gemacht und nun funktioniert Apache nicht mehr. 

root@server:~# a2enmod ssl
Module ssl already enabled
root@server:~# service apache2 start
[....] Starting web server: apache2(98)Address already in use: make_sock: could not bind to address XXX.XXX.XXX.XXX:443
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
 failed!
root@server:~#
Link to post
Share on other sites

Naja ich kann die Froxlor Seite nicht mehr ?ffnen. Und Apache2 l?sst sich nicht starten oder restarten. Beim Starte oder Restart kommt folgende Meldung: 

root@server:~# a2enmod ssl
Module ssl already enabled
root@server:~# service apache2 start
[....] Starting web server: apache2(98)Address already in use: make_sock: could not bind to address XXX.XXX.XXX.XXX:443
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
 failed!
root@server:~#
Link to post
Share on other sites
/etc/apache2/sites-enabled/10_froxlor_ipandport_X.X.X.X.80.conf:Listen X.X.X.X:80
/etc/apache2/sites-enabled/10_froxlor_ipandport_X.X.X.X.443.conf:Listen X.X.X.X:443
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:    Listen 443
/etc/apache2/ports.conf:    Listen 443

Ich bekomme folgendes angezeigt. 

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...