Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

j4mb4l4j4

[solved] Why are the configs not complete

Recommended Posts

Hi, after 4 Days i could solve my Mailserverproblem.

 

The Problem was, that my smtp server didnt work ( postfix with dovecot ), so i searched with google for the solution and find out, that the

 

/etc/init.d/master.cf

 

file was incomplete ( i followed the froxlor configuration steps ).

 

And there was no hint , that i have to edit the master.cf in postfix for getting the smtp server listening on port 25.

 

It would be really n1 if you could change this problem or could tell me why the default config is without the smtp settings.

 

Sorry for my bad englisch ;-)

Share this post


Link to post
Share on other sites

i am using Froxlor with

 

- Debian Lenny 5

- Apache 2

- Postfix

- Dovecot

- Mysql

 

I had the same problem with exim4 for a half year where the smtp server didnt start.

 

Only with this Code i could run my smtp server ( Didnt know if everything is ok in this configuration but with this my smtp port 25 is shown in

netstat -tapn

:

 


# Add this lines to be able to use dovecot as delivery agent
# Dovecot LDA
dovecot   unix  -       n       n       -       -       pipe
       flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}






smtp      inet  n       -       -       -       -       smtpd
#submission inet n       -       -       -       -       smtpd
#  -o smtpd_enforce_tls=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps     inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
       -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache

Share this post


Link to post
Share on other sites

Ok, this was the master.cf after doing the froxlor configuration steps:

 

# Add this lines to be able to use dovecot as delivery agent
# Dovecot LDA
dovecot	  unix	-	n	n	-	-	pipe
flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}

 

And i added

 

smtp      inet  n       -       -       -       -       smtpd
#submission inet n       -       -       -       -       smtpd
#  -o smtpd_enforce_tls=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps     inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
       -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache

 

I think the most important line here was:

 

smtp      inet  n       -       -       -       -       smtpd

 

After this line, my postfix listened on port 25. Before that he was only running but not listening.

Share this post


Link to post
Share on other sites

if you read the config-template correctly, you knew that it says

-> # Add this lines to be able to use dovecot as delivery agent

-> # Add this lines

-> # Add

 

add - not replace the whole content

Share this post


Link to post
Share on other sites





×
×
  • Create New...