Jump to content
Froxlor Forum
  • 0

Fehler froxlor_master_cronjob


vogti

Question

Hallo zusammen,

 

seit ein paar Tagen erhalte ich immer wenn der Froxlor Master Cronjob nach einer ?nderung ausgef?hrt wird folgende Fehlermeldung per Mail:

[Mon Aug 22 14:10:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

 

wie es aussieht kann er irgendeinen Hostnamen nicht aufl?sen. Das gr??te Problem ist, das der Apache nach einem Serverreboot nichtmehr richtig startet. Erst nach einem Neustart des Dienstes (Apache) funktioniert er wieder. Woran liegt das? Wie kann ich das Problem beheben?

 

Viele Gr??e

Vogti

Link to post
Share on other sites

13 answers to this question

Recommended Posts

Hat den niemand eine Idee wo ich nach dem Fehler suchen soll?

Dieselbe Fehlermeldung erscheint beim starten und stoppen vom Apache. Ich vermute das der Fehler in einem der Apache-Config Dateien liegt, habe aber bisher nichts gefunden.

 

Seit ein paar Tagen erhalte ich jetzt auch (immer kurz nach Mitternacht 0:10 Uhr und/oder 0:15 Uhr) eine Mail mit folgendem Inhalt:

There is already a Cronjob in progress. Exiting...
Take a look into the contents of /var/run/froxlor_froxlor_master_cronjob.lock-* for more information!

 

Viele Gr??e

Vogti

Link to post
Share on other sites

Hat den niemand eine Idee wo ich nach dem Fehler suchen soll?

Dieselbe Fehlermeldung erscheint beim starten und stoppen vom Apache. Ich vermute das der Fehler in einem der Apache-Config Dateien liegt, habe aber bisher nichts gefunden.

 

Seit ein paar Tagen erhalte ich jetzt auch (immer kurz nach Mitternacht 0:10 Uhr und/oder 0:15 Uhr) eine Mail mit folgendem Inhalt:

There is already a Cronjob in progress. Exiting...
Take a look into the contents of /var/run/froxlor_froxlor_master_cronjob.lock-* for more information!

 

Viele Gr??e

Vogti

 

Hallo Vogti,

 

Dies ist bereits bekannt!

Warum steht auch drinnen. Der Letzte Cronjob ist nicht durchgelaufen und deswegen kann kein neuer gesartet werden.

 

Siehe http://redmine.froxlor.org/issues/841#change-4394

Link to post
Share on other sites

Hallo xocii,

 

dank f?r die Antwort, wie sieht es mit dem Apache-Fehler aus?

 

[Mon Aug 22 14:10:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

 

hast du eine Idee wovon dieser Fehler verursacht wird oder wonach ich suchen soll?

 

Viele Gr??e

Vogti

Link to post
Share on other sites

Hallo xocii,

 

dank f?r die Antwort, wie sieht es mit dem Apache-Fehler aus?

 

[Mon Aug 22 14:10:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

 

hast du eine Idee wovon dieser Fehler verursacht wird oder wonach ich suchen soll?

 

Viele Gr??e

Vogti

 

Diesen Fehler hatte ich bis jetzt nie :S.

Schau dir aber mal die /etc/hosts datei an. Ich vermute mal das der Fehler da oder beim DNS Server(bind) sein Ursprung hat.

Link to post
Share on other sites

Hallo zusammen,

 

ich hatte wenig Zeit, weshalb ich das Problem erst jetzt wieder aufgreife. Ich habe mir mal die /etc/hosts Datei angeschaut. Muss hier eigentlich f?r jede IP-Adresse ein Eintrag in der Form

IP-Adresse hostname.meinedomain.org hostname

vorhanden sein?

 

In der /etc/resolve.conf habe ich folgendes eingetragen:

nameserver 127.0.0.1
nameserver 213.133.100.100
nameserver 213.133.98.98
nameserver 213.133.99.99

 

F?r die Domain unter der der Server l?uft, existiert kein Eintrag auf diesem DNS-Server (127.0.0.1). Bisher verwende ich noch die DNS-Server meines Registrars.

nslookup hostname.meinedomain.org
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
Name:   hostname.meinedomain.org
Address: XXX.XXX.XXX.XXX

Liegt hier das Problem?

 

Viele Gr??e

Vogti

Link to post
Share on other sites

Hallo zusammen,

 

seit dem Update auf Version 0.9.24 erhalt ich bei jeder Konfigurations?nderung die den Apache betrifft folgende Fehlermeldungen per Mail:

 

PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
[Fri Oct 07 15:25:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

 

Vor dem Update erhielt ich jedeglich folgenden Fehler per Mail:

[Fri Oct 07 15:25:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

Dieser Fehler erscheint auch zweimal wenn ich den apache neu starte.

 

Viele Gr??e

Vogti

Link to post
Share on other sites

nameserver 213.133.98.98

nameserver 213.133.99.99

nameserver 213.133.100.100

 

Ich habe die so in meiner /etc/resolv.conf. Trotzdem scheint was mit deinem dns nicht zu stimmen auf den ersten Blick. Klappt den das aufl?sen etc

Link to post
Share on other sites

Die Namensaufl?sung funktioniert eigentlich einwandfrei.

 

nslookup froxlor.org
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
Name:   froxlor.org
Address: 109.234.108.226

 

Wie kann ich am besten ?berpr?fen ob es am DNS liegt?

Link to post
Share on other sites

Heute Nacht erhielt ich wieder ein Mail. Dieses Mal jedoch, trat der Fehler 16x auf und nicht wie bisher nur einmal. Diese Anzahl entspricht der Zahl an Kunden in der froxlor Installation.

 

[sat Oct 08 00:30:17 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:30:33 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:31:30 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:31:46 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:32:01 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:32:50 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:33:05 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:33:21 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:33:39 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:33:55 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:34:10 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:34:26 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:40:26 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:40:41 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:40:49 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!
[sat Oct 08 00:41:05 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

 

Hat jemand eine Idee?

 

Viele Gr??e

Vogti

Link to post
Share on other sites

Verschiedene Probleme/ Themen bitte in separate Threads posten!

 

 

 

In der /etc/resolve.conf habe ich folgendes eingetragen:

nameserver 127.0.0.1
nameserver 213.133.100.100
nameserver 213.133.98.98
nameserver 213.133.99.99

 

F?r die Domain unter der der Server l?uft, existiert kein Eintrag auf diesem DNS-Server (127.0.0.1). Bisher verwende ich noch die DNS-Server meines Registrars.

nslookup hostname.meinedomain.org
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
Name:   hostname.meinedomain.org
Address: XXX.XXX.XXX.XXX

 

 

"F?r die Domain unter der der Server l?uft, existiert kein Eintrag auf diesem DNS-Server (127.0.0.1)"

Dir ist bewusst das die Loopback Adresse 127.0.0.1 auf deine lokale Maschine/ localhost zeigt? Betreibst du einen DNS-Server auf dieser Maschine?

 

"Bisher verwende ich noch die DNS-Server meines Registrars."

Warum tr?gst du die loopback Adresse dann zus?tzlich in der Datei /etc/resolve.conf ein?

Link to post
Share on other sites

Verschiedene Probleme/ Themen bitte in separate Threads posten!

Welche zwei Themen habe ich hier vermischt?

 

 

"F?r die Domain unter der der Server l?uft, existiert kein Eintrag auf diesem DNS-Server (127.0.0.1)"

Dir ist bewusst das die Loopback Adresse 127.0.0.1 auf deine lokale Maschine/ localhost zeigt? Betreibst du einen DNS-Server auf dieser Maschine?

Ja, auf dem Server l?uft ein Bind der von froxlor verwaltet wird.

 

"Bisher verwende ich noch die DNS-Server meines Registrars."

Warum tr?gst du die loopback Adresse dann zus?tzlich in der Datei /etc/resolve.conf ein?

Um zur Namensaufl?sung meinen eigenen Nameserver zu nutzen. Au?erdem m?chte ich in Zukunft meine eigenen Nameserver betreiben.

 

Kann der Eintrag in /etc/resolve.conf schuld an dem Problem sein.

 

 

Im Moment sieht es mit den Fehlermeldungen folgenderma?en aus:

[Mon Aug 22 14:10:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

Diesen Fehler erhalte ich jede Nacht (16x untereinander in einer Mail). Der Fehler erscheint auch beim starten und stopen von Apache.

 

 

PHP Notice:  Undefined index: deactivated in /var/www/froxlor/lib/functions/filedir/function.makeChownWithNewStats.php on line 32
[Fri Oct 07 15:25:02 2011] [error] (EAI 2)Name or service not known: Could not resolve host name : -- ignoring!

Diese beiden Fehler (den oberen etliche Male) erhalte ich nach den meisten Config-?nderungen (ich vermute: bei allen die den Apache betreffen).

 

 

Vielen Gr??e

Vogti

Link to post
Share on other sites

schmei? mal den eintrag f?r 127.... raus. Der st?rt da ja nur.

 

Da du den dns deines Registrators nuzt (zur zeit) werden auch alle Domains dadr?ber abgebildet und du brauchst den bind auf deiner Maschine nciht (musst aber nicht l?schen soviel ressourcen frisst der nicht, und hast ihn sp?ter noch).

 

Dann starte ggf. die Dienste einmal neu und teste nochmal bitte.

Link to post
Share on other sites

Ich habe eben das eben mal ausprobiert, leider ohne Erfolg.

 

Au?erdem habe ich bei allen IP die Option Erstelle ServerName-Eintrag im vHost-Container: aktiviert. Hat jedoch leider auch nichts gebracht. Soll ich das drinnen lassen oder besser wieder raus nehmen?

 

Hat noch jemand irgendeine Idee?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...