Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Stephen

[solved] FCGID Handbook: Making userdata.inc.php Readable

Question

I was following the proceedure in the FCGID Handbook at:

http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_handbook

 

When I got to the last step under the heading "Setting up the Froxlor vHost" where apache is restarted Froxlor did not work anymore. What appeared in the browser was the the message:

 

You have to make the file "lib/userdata.inc.php" readable for the http-process!

 

I had to make the file: /var/www/froxlor/lib/userdata.inc.php readable by "others" for Froxlor to work again.

 

Was this the right thing to do? Or should this change in permissions have been unncessary?

 

 

 

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

Yes.

But in the procedure given this disabling comes at the beginning of the "Final Steps" section, which is right after the end of the "Setting up the Froxlor vHost" section. At the end of this ?Setting up the Froxlor vHost" section there are instructions to log into Froxlor. If this error is to be expected until mod_PHP is disabled then there needs to be change in the instruction sequence given in the handbook.

 

I completed the handbook's procedure with read permission for other in effect. As I write this I removed that permission and found Froxlor continued to work.

 

Share this post


Link to post
Share on other sites

i'd say the cronjob did not run before you test and therefore the froxlor-directory was not yet owned by the local froxlor user (what the cronjob changes when switching to fcgid) hence the error message.

Share this post


Link to post
Share on other sites





×
×
  • Create New...