Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Netsurfer

Ausf?hrungszeitpunkt der Cronjobs festlegen

Question

Hallo,

 

ich w?rde gerne erreichen, dass die Cronjobs unter Froxlor wie bspw. der Backup Cronjob zu einer bestimmten Uhrzeit ausgef?hrt werden.

Kann mir netterweise jemand einen Tipp geben, wie ich das anstelle?

 

Besten Dank im Voraus!

 

Gru?

Gunther

Share this post


Link to post
Share on other sites

Recommended Posts

Manuell den Timestamp der letzten Ausf?hrung in der Datenbank anpassen :)

Share this post


Link to post
Share on other sites

Hallo,

 

ich nochmal ...!

Das Setzen der entsprechenden Timestamps in der DB ist ja soweit kein Problem, allerdings habe ich jetzt immer den Fall, dass mir der Cron Daemon mailt:"There is already a Cronjob in progress. Exiting..."

 

In welcher Reihenfolge und/ oder mit welchem min. Zeitabstand starte ich denn die einzelnen Cronjobs am besten?

Laufen m?ssen alle au?er den beiden APS Jobs und die Intervalle sind unver?ndert.

 

Besten Dank im Voraus!

 

Gru?

Gunther

 

PS: ?rger macht immer der froxlor_cron_traffic ...!

Share this post


Link to post
Share on other sites

der Fehler kommt wenn vom Master-Cronjob, der das Starten der Cronjobs managed. Der sollte laut default config alle 5 Minuten aufgerufen werden, logischerweise sollte also kein Cron einen Intervall von unter 5 Minuten haben, sonst verrennt er sich in eben diesen Fehler. 

Share this post


Link to post
Share on other sites

Guten Morgen,

 

und besten Dank f?r deine schnelle Antwort.

 

der Fehler kommt wenn vom Master-Cronjob, der das Starten der Cronjobs managed. Der sollte laut default config alle 5 Minuten aufgerufen werden, logischerweise sollte also kein Cron einen Intervall von unter 5 Minuten haben, sonst verrennt er sich in eben diesen Fehler. 

 

Der Master-Cronjob hat bei mir auch das Standard-Interval von 5 Minuten und es gibt keinen anderen Cronjob mit einem k?rzeren Intervall. Ich habe bereits ausprobiert das, den jeweils letzten Ausf?hrungszeitpunkt der einzelnen Jobs zeitlich versetzt zu setzen, genauso wie alle auf denselben Zeitpunkt.

 

Ergebnis ist in beiden F?llen gleich: Es bleibt immer die /var/run/froxlor_cron_traffic.lock, die dann beim n?chsten Start des Master-Cronjobs besagten Fehler samt Benachrihtigung produziert.

 

EIne Idee?

Share this post


Link to post
Share on other sites

hm, hast du denn sehr viele Kunden oder sehr viele Domains die da jedes mal verarbeitet werden m?ssen?

Share this post


Link to post
Share on other sites

Nein, eben nicht. Bisher ist der Server eher noch "leer".

16 Kunden, aber nur bei zweien ?berhaupt wirklicher Inhalt (Web) und 3 Mail-Accounts.

Share this post


Link to post
Share on other sites

oh ja...hm, wie gro? sind so die access.log von den 16 kunden? wenn es am traffic cron liegt, muss es was damit zu tun haben.

Schau mal nach, ob dir evtl. die PHP extension pcntl installiert hast, damit kann Froxlor den traffic cron in einem eigenen Prozess forken und diesen Fehler umgehen.

Share this post


Link to post
Share on other sites

Bis auf eine, die knapp 28 MB gro? ist, sind alle anderen "unbedenklich" klein. Verwende auch Logrotate.

 

Zu deiner Empfehlung mit der pcntl ist das erste was ich dazu gefunden habe:"Process Control should not be enabled within a web server environment and unexpected results may happen if any Process Control functions are used within a web server environment."

 

Von daher w?re es mir lieber, wenn sich das Problem auch anders l?sen lassen w?rde ...! ;)

Share this post


Link to post
Share on other sites

naja, du nutzt die funktion ja nicht im webinterface sondern nur auf der shell...f?r die apache2-php.ini kannstes ja verbieten so lange die cli das darf

Share this post


Link to post
Share on other sites

So, musste jetzt erstmal nachgucken.

Also ich habe (u.a.) das Paket

php5-cli                            5.3.23-1~dotdeb.0

installiert. Soweit ich wei?, beinhaltet das doch die pcntl.

 

Auszug von debian.org dazu:

Kommandozeilen-Interpreter f?r die Skriptsprache PHP5

Dieses Paket stellt den Kommandozeilen-Interpreter /usr/bin/php5 zur Verf?gung, der f?r das Testen von PHP-Skripten in einer Shell oder auch f?r die Erledigung von Shell-Skripting-Aufgaben verwendet werden kann. Die folgenden Erweiterungen sind integriert: bcmath, bz2, calendar, Core,

 ctype, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gettext, hash, iconv, json, libxml, mbstring, mhash, openssl, pcntl, pcre, Phar, posix, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, zip und zlib.

Muss ich denn ansonsten noch irgendetwas "machen", oder benutzt Froxlor die automatisch, wenn vorhanden?

Share this post


Link to post
Share on other sites

Brauchst nichts einstellen, froxlor verwendet das, wenn es verf?gbar ist automatisch

Share this post


Link to post
Share on other sites

Brauchst nichts einstellen, froxlor verwendet das, wenn es verf?gbar ist automatisch

 

OK, dann sind wir wieder am Ausgangspunkt ... :P

Kann ich eigentlich irgendwo sehen, ob der Traffic Cronjob irgendwo ein "Problem" hat?

 

In der Lock Datei steht au?er der Nummer sonst nie etwas anderes drin und auch in der cron.log findet sich ja nur der Eintrag, dass der Master Cronjob gestartet wurde.

Share this post


Link to post
Share on other sites

Settings -> System settings -> Cronscript debugging (da steht auch nochma genau dran, was das bedeutet)

Share this post


Link to post
Share on other sites

Ja, danke - h?tte ich auch selber drauf kommen k?nnen ...!

 

froxlor_froxlor_master_cronjob.lock-11705:

Setting Lockfile to /var/run/froxlor_froxlor_master_cronjob.lock-11705
Setting Froxlor installation path to /var/www/froxlor
Userdatas included
Table definitions included
Database Class has been loaded
Database-connection established
Froxlor settings have been loaded from the database
Checking froxlor file permissionsFroxlor version and database version are correct
Logger has been included
  cron_tasks: Searching for tasks to do
Cronfiles have been included
Closing database connection
 

und

 

froxlor_cron_traffic.lock:

11710

 

Problem scheint mir eher darin zu liegen, dass die froxlor_cron_traffic.lock im Anschluss nicht gel?scht wird, oder zumindest nicht immer, was dann sp?testens beim n?chsten Start des Traffic Cronjobs zu dem besagten Problem f?hrt.

Share this post


Link to post
Share on other sites

Naja das wurde ja jetzt durch das debug Flag nicht gel?scht... Schau mal ob es gel?scht wird wenn das nicht an ist (btw der traffic cron sollte nur 1x am Tag laufen, der Verbrauch wird sonst mehrfach berechnet)

Share this post


Link to post
Share on other sites

Naja das wurde ja jetzt durch das debug Flag nicht gel?scht... Schau mal ob es gel?scht wird wenn das nicht an ist (btw der traffic cron sollte nur 1x am Tag laufen, der Verbrauch wird sonst mehrfach berechnet)

 

Schon klar, dass sie dieses Mal aufgrund der Debugging Einstellung nicht gel?scht wurde. Aber wurde sie vorher (ohne Debugging) eben auch nicht (bisher beide Male, wo der Job regul?r ausgef?hrt werden sollte).

Und ja, der Traffic Cronjob l?uft normalerweise bei mir 1x am Tag.

Share this post


Link to post
Share on other sites

Ach, mir kommt da gerade so eine Idee ...!

 

Kann es sein, dass im Anschluss an die Traffic-Berechnung auch der Traffic-Report ausgef?hrt werden muss und dieser die Lock-Datei l?scht?

Share this post


Link to post
Share on other sites

kann ich so nicht sagen, eventuell musst du da selbst die cronscripts mal durch-debuggen, ich treffe leider nicht auf diesen Fehler und kann es nicht reproduzieren

Share this post


Link to post
Share on other sites

Hallo!

 

Ich bin, so glaube ich zumindest, ein St?ckchen schlauer ...

 

Vorweg: Kannst du, oder jemand anders, mal bitte gucken, ob die Datei 'froxlor_cron_traffic.lock' in /var/run bei dir/ ihm auch grunds?tzlich nicht gel?scht wird, also immer vorhanden ist und nur bei jeder Ausf?hrung des entsprechenden Cronjobs der Zeitstempel aktualisiert wird?

 

Diese Datei ist aber nicht, wie ich zuerst irrt?mlich angenommen habe, der Grund f?r die Benachrichtigung per E-Mail "There is already a Cronjob in progress. Exiting...".

 

Sondern es ist der Backup Cronjob, der selbst bei relativ geringer Belegung des Speicherplatzes nicht in 5 Minuten fertig ist.

 

Nun ist es nat?rlich zumindest "?u?erst l?stig", wenn man t?glich mind. einmal eine entsprechende Mail vom Daemon erh?lt. Kann man da irgendwie "Abhilfe" schaffen?

 

Gru?

Gunther

Share this post


Link to post
Share on other sites

Hi!

 

Vorweg: Kannst du, oder jemand anders, mal bitte gucken, ob die Datei 'froxlor_cron_traffic.lock' in /var/run bei dir/ ihm auch grunds?tzlich nicht gel?scht wird, also immer vorhanden ist und nur bei jeder Ausf?hrung des entsprechenden Cronjobs der Zeitstempel aktualisiert wird?

 

Die Lock Datei des Traffic Cronjobs wird nicht gel?scht, weil es schlicht keinen Befehl daf?r gibt in der Datei 'cron_traffic.php'.

Folgende Erg?nzung am Ende der Datei "l?st" das Problem:

Original:

if(function_exists('pcntl_fork')) {
	die();
}

Neu:

if(function_exists('pcntl_fork')) {
	unlink($TrafficLock);
	die();
}

Im Endeffekt ist es reine "Kosmetik", da das Vorhandensein der Datei 'froxlor_cron_traffic.lock' keinerlei Auswirkungen hat (wenn der (die) entsprechende(n) Prozess(e) beendet ist (sind)).

 

Gru?

Gunther

Share this post


Link to post
Share on other sites

Netsurfer hat Recht, da wurde wohl beim Forken nicht mehr dran gedacht, dass das Lockfile auch wieder weg muss. Danke, wird sofort eingespielt

 

EDIT: Doch nicht korrekt, sorry. Die urspr?ngliche Fehlermeldung vom OP war "There is already a Cronjob in progress. Exiting..." - diese kommt NICHT vom Traffic-Cron und hat auch nichts mit dessen Lock-File zu tun, das kommt direkt vom Master-Cronjob, und die Pr?fung wird in der lib/cron_init.php ausgef?hrt und das Lockfile in lib/cron_shutdown.php wieder gel?scht.

Share this post


Link to post
Share on other sites

Hi!

 

Netsurfer hat Recht, da wurde wohl beim Forken nicht mehr dran gedacht, dass das Lockfile auch wieder weg muss. Danke, wird sofort eingespielt

 

EDIT: Doch nicht korrekt, sorry. Die urspr?ngliche Fehlermeldung vom OP war "There is already a Cronjob in progress. Exiting..." - diese kommt NICHT vom Traffic-Cron und hat auch nichts mit dessen Lock-File zu tun, das kommt direkt vom Master-Cronjob, und die Pr?fung wird in der lib/cron_init.php ausgef?hrt und das Lockfile in lib/cron_shutdown.php wieder gel?scht.

 

BTW: Ich bin der OP ...! :P

 

Und ja, in Post #23 habe ich das ja bereits geschrieben.

Und nein, die 'froxlor_cron_traffic.lock' wird eben nicht von der 'lib/cron_shutdown.php' wieder gel?scht. ;)

 

Gru?

Gunther

Share this post


Link to post
Share on other sites

  • Similar Content

    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By where2go
      Hi there,
      I'm running Froxlor 0.9.38.7 (DB: 201612110) and when executing php /var/www/froxlor/scripts/froxlor_master_cronjob.php I'm getting "Froxlor does not seem to be installed yet - skipping cronjobroot".
      My /etc/cron.d/froxlor file looks like
      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null 7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null 15 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null  
      Cron is running as /usr/sbin/cron -f PHP Version5.6.30-0+deb8u1 Debian 8.9 Apache/2.4.10 Zend OPcache 7.0.6-dev System log is clean. Froxlor dashboard says: Outstanding cron-tasks: There are currently no outstanding tasks for Froxlor I do not have this php file: FROXLOR_INSTALL_DIR . '/lib/userdata.inc.php' as indicated here https://github.com/Froxlor/Froxlor/blob/master/lib/cron_init.php  

       
      I'd appreciate any help with this.
      Thanks a lot!
       
    • By nurtext
      Moin,
      anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log:
      root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? ?
    • By nisamudeen97
      Hi,
      I am receiving the below alert as mail,  What is this  for  ?  How  can we stop this / fix this.
       
       
      Subject: Cron <root@w03> /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
      MIME-Version: 1.0
      Content-Type: text/plain; charset=UTF-8
      Content-Transfer-Encoding: 8bit
      X-Cron-Env: <PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin>
      X-Cron-Env: <SHELL=/bin/sh>
      X-Cron-Env: <HOME=/root>
      X-Cron-Env: <LOGNAME=root>
      Message-Id: <20170409220002.09CF0800C2@w03.server.com>
      Date: Mon, 10 Apr 2017 00:00:02 +0200 (CEST)
      sh: 1: /usr/sbin/repquota: not found
       
×
×
  • Create New...