Jump to content
Froxlor Forum
  • 0

Installtion klappt nicht!


Eikichi

Question

Hallo,

 

Jedes mal wenn ich Froxlor auf unserem vServer zu installieren versuche sagt er mir:

 

Testing if MySQL-root-username and password are correct...We are sorry, but a MySQL - error occurred. The administrator may find more information in syslog with the ID

 

und im Syslog steht folgendes:

 

Dec 21 12:11:47 abcd Froxlor: MySQL - Error: Establishing connection failed, exiting; ErrNo: 1045; 
Desc: Access denied for user 'root'@'localhost' (using password: NO); 
Script: /froxlor/install/install.php; Ref: http://serv.xxxx.xx/froxlor/install/install.php?check=1; ecfc436cd22ff03f522d9a84eaefa154

 

Also das Passwort stimmt 100%, ich habe echt keine ahnung was da schief gelaufen ist :(

Bitte Helft mir... .

 

Mfg.

Link to post
Share on other sites

21 answers to this question

Recommended Posts

Hallo!

Um etwas zu sagen br?uchte man noch mehr Informationen:

1. Betriebssystem des Servers

2. Installationsmethode

3. Wurde der Server frisch aufgesetzt oder l?uft da schon was drauf

 

Ich betreibe meinen VServer mit Debian squeeze. Froxlor habe ich dann auf einem frischen Minimal-System per Aptitude installiert. Funktioniert Fehlerfrei. F?r Debian gibt es auch hier im Wiki eine Installationsanleitung.

Gru? J?rn

Link to post
Share on other sites

Hallo,

 

Es ist ein frisch installiertes Linux Debian 5 64bit system.

Der vServer ist ganz neu, und die Installationsmethode war mit apt-get gemacht worden.

Ich glaube das froxlor keine verbindung zum mysql server aufbauen kann oder verstehe ich das richtig?

Link to post
Share on other sites

@moscito: Nein

 

Ich verstehe das nicht:

 

wenn ich mit mysql -u root -p mich einloggen m?chte spuckt der mir das aus:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

 

und wenn ich es auch ohne passwort versuche spuckt der mir das selbe nur halt mit einem NO aus:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

Link to post
Share on other sites

eben nicht! ich habe nun Debian zwei mal neuinstalliert und froxlor zweimal neu drauf gehauen, am passwort liegt es nicht! ich geb Sie 100%tig richtig ein.

 

ich bekomme immer die gleiche fehlermeldung, das kann doch net sein das der nicht das Passwort setzt!

 

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Link to post
Share on other sites

Welchem User geh?ren die Ordner und Dateien von Froxlor?

 

Folgendes mal bitte in der Shell ausf?hren:

 

ls -la /var/www/froxlor/

 

Eventuell konnte die Datei gar nicht angelegt werden, weil nicht ausreichende Zugriffsrechte bei der Installation von Froxlor ?ber das Webinterface zur Verf?gung standen? EDIT: Was eigentlich gar nicht sein kann, da bei erfolglosem Abschluss ein Hinweis eingeblendet wird.

 

Je nach Konfiguration:

lib/userdata.inc.php

<?php
//automatically generated userdata.inc.php for Froxlor
$sql['host']='127.0.0.1';
$sql['user']='froxlor';
$sql['password']='<MYSQLFROXLORPWD>';
$sql['db']='froxlor';
$sql_root[0]['caption']='Default';
$sql_root[0]['host']='127.0.0.1';
$sql_root[0]['user']='root';
$sql_root[0]['password']='<MYSQLROOTPWD>';
?>

Link to post
Share on other sites

Beim aufrufen der /froxlor/index.php seite erscheint das:

We are sorry, but a MySQL - error occurred. The administrator may find more information in syslog with the ID 6f87f1ddbecffbb325c645d87c29d536

 

Und im syslog steht das:

Jan 26 14:40:12 serv Froxlor: MySQL - Error: Establishing connection failed, exiting; ErrNo: 1045; Desc: Access denied for user 'froxlor'@'localhost' (using password: YES); Script: /froxlor/index.php; Ref: http://serv.xxxx.xx/froxlor/install/install.php; 6f87f1ddbecffbb325c645d87c29d536

 

K?nnte sich das den nicht einer Kurz anschauen Bitte...?

Mfg.

Link to post
Share on other sites

Wie vermutet sind den Froxlor Verzeichnissen der Besitzer root statt bsp. des Users von apache (www-data) zugeordnet. Da die Website mit Zugriffsrechten von www-data aufgerufen wird, kann diese nat?rlich NICHT auf die Daten zugreifen, da sie ja ROOT geh?ren. Es hat nun wirklich nicht mehr 10 Sekunden gedauert, um das herauszufinden. Mir scheint es so als wenn bei der Erstinstallation falsche Daten angegeben worden sind und die Fehlermeldung einfach weg geklickt wurde, statt sie zu beachten..

 

Mir scheint es das deine Linuxkenntnisse wohl sehr bescheiden sind. Ich kann dir nur empfehlen, dich mit der Thematik Linux/ Linux Server tiefgreifender zu befassen, sonst ist dein Server in wenigen Wochen nicht mehr als eine Spamschleuder.

Link to post
Share on other sites

Sch?n und gut das du das heraus gefunden hast das ich ein Linux neuling bin, aber ich bin immer noch da wo ich vorher war -.- .

 

Froxlor l?sst sich einfach nicht installieren, es tauchen immer noch die selben fehlermeldungen auf.

Link to post
Share on other sites

Sch?n und gut das du das heraus gefunden hast das ich ein Linux neuling bin, aber ich bin immer noch da wo ich vorher war -.- .

 

Froxlor l?sst sich einfach nicht installieren, es tauchen immer noch die selben fehlermeldungen auf.

 

Dann musst du mir Linux root und MySQL root Kennw?rter nochmal schicken..

 

 

EDIT:

 

Lag am fehlerhaften Image des vServer-Hosters.

Link to post
Share on other sites

Neuer User, selbes Problem.

 

Debian Squeeze 64Bit

Passwort ist 100% richtig, Server ist erst ein Tag alt.

(Bei phpMyAdmin kann ich mich einloggen)

 

Als Besitzer der Datein war root angegeben.

(Hab ich jetzt im nachhinein mit chown umge?ndert zu www-data)

 

"Installiert" hat soweit das ganze netcup.

 

Ich verzweifel gleich...

Hab auch schon versucht die Daten manuell einzugeben in die userdata.inc.php aber ich bekomm dann die gleiche Meldung...

 

Irgend welche tipps?

Link to post
Share on other sites

Hi,

 

l?uft Euer MySQL vllt. auf Socket statt mit TCP? 'netstat -nlp | grep 3306' sollte an 0.0.0.0:3306 bzw. 127.0.0.1:3306 ein Ergebnis liefern, wenn nicht, geh?rt eine Option in der /etc/mysql.my.cnf ge?ndert : ich glaube es hei?t "skip-networking" und muss deaktiviert werden.

 

Gru?

Ronny

Link to post
Share on other sites

Hallo,.

 

Ich m?chte das Thema auch noch mal aufgreifen.

Ich betreibe einen vServer bei Serverway. Habe in den letzten Tagen mehrere Neuinstallationen mit Debian 6.0 aufgesetzt. Die nachfolgenden Froxlorinstallationen mit "aptitude install froxlor" verliefen stets einwandfrei.

 

Doch seit heute habe auch ich das gleiche Problem, wie eingangs geschildert. Die Froxlorinstallation l?uft tadellos durch. Doch bei der Konfiguration im Browser erhalte ich nach den Eingaben der Zugangsdaten f?r MySQL-Froxlor und MySQL-Root etc. nur die Meldung:

 

Teste, ob die MySQL-Root-Benutzerdaten richtig sind...We are sorry, but a MySQL - error occurred. The administrator may find more information in syslog with the ID a0cf35bce3449c3e3861a3c1c4023442

 

Der zugeh?rige Syslog-Auszug besagt folgendes:

 

Jan 23 19:30:41 sgserv01 Froxlor: MySQL - Error: Establishing connection failed, exiting; ErrNo: 1045; Desc: Access denied for user 'root'@'localhost' (using password: NO); Script: /froxlor/install/install.php; Ref: http://134.0.24.69/froxlor/install/install.php?language=german&check=1&chooselang=Go; a0cf35bce3449c3e3861a3c1c4023442

 

Ein Rechteproblem konnte ich nicht finden. Auch funktioniert das MySQL-Root-PW in der Shell ganz problemlos. Ich kann mich mit "mysql -u root -p" einwandfrei mit meinem Root-Pw anmelden.

 

Kann es mit der neuen Version 0.9.26 zu tun haben, die gerade released wurde?

 

Da es in den letzten Tagen keine Probleme bei der Froxlorinstallation gab, ist hier ein fehlerhaftes Debian 6.0 Image eher unwahrscheinlich.

W?rde mich freuen, wenn es inzwischen ein paar Hinweise oder gar L?sungen g?be.

 

Gru?, Curio

Link to post
Share on other sites

Also f?r alle die das Problem zuk?nfig haben sollten, wir von www.FloraHost.de haben uns diese Installation vorgenommen und das beschriebene Problem zu l?sen ist wenn man es wei? ganz einfach.

 

Bei der Installation von Debian Squeeze 6 wird das MySQL-Root-Passwort automatisch  vergeben und im Root in einer password.txt gespeichert.

 

Also vor der Installtion von Froxlor erst dort das Passwort raus kopieren und bei der Installation bei MySQL Passwort  das Passwort aus der password.txt eintragen, dann wird alles gr?nnnn  :D

 

Dann noch die userdata.inc.php per -> mv /tmp/userdata.inc.php /var/www/froxlor/lib verschieben und alles ist gut.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...