Jump to content
Froxlor Forum
  • 0
pout

[HowTo] Roundcube Webmail with fcgi

Question

Einleitung:

Ich habe froxlor auf Debian Squeeze mit php als mod_fcgi nach dem Froxlor fcgi-Handbuch eingerichtet.

Nun soll Roundcube-Webmail in dieser Umgebung laufen. Es wird als Subdomain (z.B.: webmail.example.com = Standardsubdomain, wenn Froxlor unter example.com l?uft) f?r alle auf diesem Server erreichbar sein.

 

vhost in Froxlor anlegen und Datenbank erstellen

 

  1. neuen Kunden (Benutzername z.B. webmail) anlegen
    Froxlor -> Kunden -> neuen Kunden anlegen
    Benutzername: webmail
    Verzeichnis Standard
    Dienstleistungsdaten:
    Webspace: 100MB
    Traffic: nach belieben
    Mysql 1
    php verf?gbar
     
    alles andere kann mit den Standardeinstellungen belassen werden.
     
  2. neue php.ini anlegen
    Froxlor -> PHP Konfigurationen -> neue Konfiguration erstellen
    in php.ini Einstellungen folgende Zeile unten anf?gen:
    suhosin.session.encrypt = 0


     

  3. (Standardsub)Domain anpassen
    Froxlor -> Domains -> webmail.example.com -> Optionen -> bearbeiten
    eigene vhost Einstellungen:
    <Directory /var/customers/webs/webmail/>
      Options -Indexes Includes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      Allow from all
    </Directory>


    PHP Konfiguration: die vorhin angelegte ausw?hlen
    SSL und SSL Redirect anzuhaken, falls SSL eingerichtet ist, macht Sinn.
    Haken bei E-Maildomain weg.
     

  4. in Froxlor zum Benutzer "webmail" wechseln und MySQL Datenbank erstellen
    Admin Froxlor -> Kunden -> in Kundenliste auf Benutzer "webmail" klicken.
    Webmail Froxlor -> Datenbanken -> neue Datenbank erstellen

 

Rouncube runterladen und entpacken

 

  1. Verzeichnisse vorbereiten
    Auf der Shell als root:
    # mkdir /usr/local/src/roundcube
    # cd /usr/local/src/roundcube


     

  2. Roundcube herunterladen
    # wget http://downloads.sourceforge.net/project/roundcubemail/roundcubemail/0.5.3/roundcubemail-0.5.3.tar.gz?r=http%3A%2F%2Froundcube.net%2Fdownload&ts=1310641364&use_mirror=dfn


     

  3. Dateinamen anpassen und entpacken:
    # mv roundcubemail-0.5.3.tar.gz?r=http%3A%2F%2Froundcube.net%2Fdownload&ts=1310641364&use_mirror=dfn roundcubemail-0.5.3.tar.gz
    # tar xvfz roundcubemail-0.5.3.tar.gz


     

  4. Dateien ins Webverzeichnis verschieben und Verzeichnisrechte setzen:
    # cp roundcubemail-0.5.3/* /var/customers/webs/webmail -R 
    # cd /var/customers/webs/webmail 
    # chmod 755 logs tmp


     

  5. Falls die index.html automatisch erstellt wird, diese bei dieser Gelegenheit gleich entfernen:
    # rm index.html


 

Roundcube-config und Datenbank erstellen

 

  1. Config-Files erstellen
    # cd config
    # cp db.inc.php.dist db.inc.php
    # cp main.inc.php.dist main.inc.php 


     

  2. Datenbank-Config bearbeiten
    # vi db.inc.php


    DB-DSN anpassen:

    $rcmail_config['db_dsnw'] = 'mysql://webmailsql1:PASSWORT@localhost/webmailsql1';


     

  3. Main-Config bearbeiten
    # vi main.inc.php


    Folgende Werte anpassen bzw. setzen:

    Zeile 68:  $rcmail_config['default_host'] = 'localhost';
    Zeile 124: $rcmail_config['smtp_server'] = 'localhost'; 


    oder, wenn man assp nutzt:

    Zeile 124: $rcmail_config['smtp_server'] = 'mx.example.com'; ("mx.example.com" durch eigene Mail-Domain ersetzten.)


    Zeile 131: $rcmail_config['smtp_user'] = '%u';
    Zeile 135: $rcmail_config['smtp_pass'] = '%p';
    Zeile 207: $rcmail_config['session_lifetime'] = 30;
    


     

  4. Webinstaller aktivieren:
    Zeile 162: $rcmail_config['enable_installer'] = true;


     

  5. Webinstaller im Browser aufrufen:
    http://webmail.example.com/installer'>http://webmail.example.com/installer
    Durchklicken bis 3. Test Config
    Button bei Check DB config anklicken um die Datenbanktabellen zu erstellen.
     
  6. Webinstaller wieder deaktivieren:
    # vi config/main.inc.php
    Zeile 162: $rcmail_config['enable_installer'] = false;


 

Aufr?umen

Source files entfernen

# # rm -R /usr/local/src/roundcube

 

Datei-Upload Problem mit fcgi beheben (auch f?r andere Anwendungen)

FcgidMaxRequestLen 2097152 in /etc/apache2/mods-enabled/fcgid.conf einf?gen. Die Datei sollte dann so aussehen:

<IfModule mod_fcgid.c>
 AddHandler    fcgid-script .fcgi
 FcgidConnectTimeout 20
 FcgidMaxRequestLen 2097152
</IfModule>

 

 

Roundcube im Browser aufrufen

 

Nun sollte Roundcube unter http://webmail.example.com zur Verf?gung stehen.

 

Links die mir geholfen haben:

http://isp-control.net/documentation/de/howto/mail/install_roundcube_for_webmail

http://www.howtoforge.com/forums/showthread.php?t=38881

http://blog.benny-baumann.de/?p=966

 

Disclaimer

Roundcube 0.5.3 funktioniert auf diese Art auf meinem Server mit Apache2 und PHP als mod_fcgi unter Debian Squeeze. Ich kann keine Verantwortung ?ber irgendwelche Probleme oder gar Zerst?rungen auf anderen Rechnern und Systemen ?bernehmen.

  • Like 1

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi,

funktioniert das auch mit phpmyadmin unter PHP-FPM (kann kein Tutorial mit PHP-FPM finden, dass unter froxlor angewendet werden k?nnte, seit wochen).---

 

Gibt es etwas zu beachten wenn man die Vorgehensweise anpasst?

Share this post


Link to post
Share on other sites
  • 0

Ich habe damit ein Problem....

Ich habe einen neuen vServer.... mache Debian 7 Wheezy drauf, aktualisiere alles und mache php5-curl , -imap etc drauf.

Dann weiter mit phpmyadmin. zum Schluss Froxlor.

Alles l?uft.... aber ich bekomme einfach kein email program installiert .

Roundcube stell ich mich zu doof an... aber wenn ich es habe dann funktioniert das mit den E-Mailadressen die ich im Froxlor anlege einfach nicht.

 

Was mache ich falsch..??

Share this post


Link to post
Share on other sites
  • 0

Ich habe damit ein Problem....

Ich habe einen neuen vServer.... mache Debian 7 Wheezy drauf, aktualisiere alles und mache php5-curl , -imap etc drauf.

Dann weiter mit phpmyadmin. zum Schluss Froxlor.

Alles l?uft.... aber ich bekomme einfach kein email program installiert .

Roundcube stell ich mich zu doof an... aber wenn ich es habe dann funktioniert das mit den E-Mailadressen die ich im Froxlor anlege einfach nicht.

 

Was mache ich falsch..??

 

3 Jahre alter Thread...muss doch nicht sein.

 

Wie hast du denn Roundcube installiert? Was genau geht nicht? Was sagen die Error-Logs? Bisschen mehr als nur "geht nicht" muss schon her, sonst kann dir keiner helfen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...