May 20, 201115 yr Guten Tag, ich bin neu hier im Forum, und bin durch Zufall auf diesen Thread gesto?en. Ich habe ein ?hnliches Problem mit dem CronJob. Zu meinem System: - Debian 6.0 Squeese 32 Bit - AMD Athlon 2 x 3 Ghz - 3 GB RAM - Kein virtueller Server - Froxlor 0.9.20.1 Ich habe bis Mittwoch noch Debian 5.0 mit Froxlor verwendet und habe durch einen Serverwechsel nun Debian 6.0 mit Froxlor 0.9.20.1 (per apt-get install froxlor) installiert. Habe bisher nie Probleme mit Froxlor gehabt bzw. konnte diese eigendlich immer relativ einfach l?sen, seit ich jetzt Debian 6 habe wirft mir PHP unn?tige notice's raus und der gibt mir auch nur Fehler. Bin gerade am verzweifeln, wei? jemand von Euch Rat? Beim Ausf?hren per Hand bekomme ich immer folgende Meldung: # /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php -bash: /usr/bin/php5: Kann die Datei nicht ausführen. Die Dateirechte sind alle 0644. Alle anderen Scripte, welche ich ?ber den gleichen PHP Aufruf im Cron starte, l?uften sauber durch. und diese Dateien geh?ren nicht dem Root-User und haben auch nur 0644 als Rechte. Danke Euch im voraus. Gru? AIR Stone EDIT: Der Cron ist nach der Einrichtung 3 - 4 mal per Hand angelaufen und das warst auch schon. Edited May 20, 201115 yr by arnoldB Thread geteilt, IMHO hat das hier eine andere Ursache
May 20, 201115 yr Wenn eine ausf?hrbare Datei nicht ausf?hrbar ist, hast du entweder manuell an den Rechten gespielt oder das PHP Paket von Debian is nicht korrekt
May 20, 201115 yr Author Danke f?r deine Antwort. Wenn eine ausf?hrbare Datei nicht ausf?hrbar ist, hast du entweder manuell an den Rechten gespielt oder das PHP Paket von Debian is nicht korrekt Guten Tag, ich habe an den Rechten der Froxlor-Dateien nichts ge?ndert. Wie kann ich eine PHP Version zur?ck Downgraden?
May 20, 201115 yr Ich sprach auch nicht von den Rechten der Froxlor-Dateien, sondern von denen der Datei /usr/bin/php5
May 20, 201115 yr Author Ich sprach auch nicht von den Rechten der Froxlor-Dateien, sondern von denen der Datei /usr/bin/php5 also bezieht sich die Fehlermeldung auf die php5 Dateien, nicht direkt auf die Cronfiles von Froxlor.
May 20, 201115 yr Author Die Rechte von den php5 Dateien wurden nicht ge?ndert, sind alle root und 777
May 20, 201115 yr die fehlermeldung kommt von der shell...die die datei /usr/bin/php5 nicht ausf?hren kann, hat mit Froxlor so gesehen nichts zu tun
May 22, 201115 yr Ich habe anf?nglich auch ein Update von lenny auf squeeze probiert. Hatte aber zu viele Fehlermeldungen. Eine Neuinstallation verlief au?er einem Cron-Problem ohne Probleme. Nun l?uft mein Server wie geschmiert. Die L?sung des Cron-Problems habe ich in diesem Forum mitgeteilt. Gru? J?rn
May 29, 201115 yr Author Ich habe die Kiste komplett platt gemacht und Debian neu installiert. Jetzt funktioniert es. Danke Euch trotzdem.
Archived
This topic is now archived and is closed to further replies.