Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'security.limit_extensions'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello again, hope you don't mind me coming up with another issue (including proposal for solution obviously). I had another issue using PHP-FPM, where I cannot get my .XML files parsed by the PHP interpreter even though I have this in my .htaccess: <FilesMatch "\.(xml)$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> It turns out that there is a limit imposed by the security.limit_extensions setting which defaults to .php only. My .XML files are used in order to automatically return the correct autodiscover/autoconfig settings to Outlook/Thunderbird and the like and therefor need to be "dynamic XML files", but I could imagine someone else needing .phps or the like... Currently I have gone so far as to add some stuff to /var/www/froxlor/lib/classes/phpinterface/class.phpinterface_fpm.php @ 248: if ($this->_domain['domain'] == 'autodiscover.mydomain.tld') { $fpm_config.= 'security.limit_extensions = .php .xml'."\n"; } But again, this could be a new string-based setting in the new PHP-FPM versions section. (Slowly I'll get in touch with the code structure I promise...)
×
×
  • Create New...