Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'install'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 11 results

  1. Hi guys, I have a google cloud compute debian instance I have been experimenting with a couple of alternatives to cpanel. Just installed virtualmin and now am looking at froxlor. I have followed the install outline as documented. 1. I setup a google cloud launcher LAMP 2. navigated in browser to <myserveripadress> to ensure apache is working (which it is) 3. downloaded froxlor to /var/www/ directory 4. chown froxlor to www-data:www-data (i also checked to ensure my webserver is running as www-data) Now when i attempt to navigate to http://<mywerveripadress>/froxlor i get the following error in browser "NOTFOUND" the requested URLwas not found on this server. now when i ssh into server, froxlor is definatelly in /var/www/ directory. permissions are 0755 www-data:www-data i am not sure what i have done wrong? has anyone with experience in installing this on google cloud got any advice?
  2. Debian (9) Stretch 1. sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list ) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB Install use sudo command for install MariaDB! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 3c. service nginx restart 4. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a. service nginx restart service php7.1-fpm restart Ubuntu 17.10 (Artful) 1. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list ) 1c. Key Install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3. MariaDB Install sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install sudo apt install nginx 4a. nano /etc/nginx/nginx.conf 4b. service nginx restart 5. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a. service nginx restart service php7.1-fpm restart Froxlor Install Git version 1. vhost nano /etc/nginx/sites-enabled/frox 1a. service nginx restart 2. Change dir cd /usr/share/nginx/ 2a. Froxlor git Load sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor Install Froxlor finish 3d. Move userdata (Optional) mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete rm /etc/nginx/site-enable/frox don't restart nginx! Froxlor Settings 1. cronjob nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel 1. Change your PHP-Backend Settings Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock 2. Make Folder and Change chmod mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated: Change from NO to YES 3a. Settings > PHP-FPM > Settings Change > Configuration directory of php-fpm to /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note) sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate 1. Create Folder on nginx mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf nano /etc/nginx/acme.conf location /.well-known/acme-challenge { alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile insert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings Activate > Enable Let's Encrypt 2c. Activate on Settings > Froxlor VirtualHost settings - Enable Let's Encrypt for the froxlor vhost - Enable SSL-redirect for the froxlor vhost - HTTP Strict Transport Security (HSTS) - Include HSTS for any subdomain
  3. Is that possible to install froxlor in c-panel using one database user password?Or how can we skip the values of mysql_unpriv_user and mysql_unpriv_pass while installing?
  4. My main site is WordPress and is installed in /var/www/mysite.com and I just installed froxlor in /var/www/froxlor. And when i went to http://{your-ip-address}/froxlor that trigger's WordPress' 404 page. Do I have to set up a special vhost to access froxlor? Or do I need to add something to the .htaccess to avoid WordPress trying to find a page that matches froxlor? OR, do I need to extract froxlor inside /var/www/mysite?
  5. teochristian

    Install Froxlor in Fedora

    Hello! Froxlor is really a great Control Panel. I would like to install this panel and use it on our servers as primary control panel. I used Froxlor on Debian. The problem is I got some viruses on Debian because of some software related vulnerabilities. These problems are not happening when using Fedora, but we would like using Froxlor because it has a simple and clean interface, it is very simple to use and it is very fast, too. Does anyone know how to install Froxlor in Fedora? (It would be great if someone can post the entire process, installing dependencies and installing Froxlor) Thank you very much! We also want to contribute to Froxlor Developement, I am the executive manager of a web development and web hosting company and we would like to help Froxlor Team. What should we do?
  6. bigshusha

    New install

    Hello everyone! I want to install Froxlor on new clear server with Debian. I have domain.com and IP. What I must setup in hostnames and itc. to get no problems with emails and setup domain.com later? What configuration you can recomend to minimize the problems during setup and configuring server? I looking something like this - http://goo.gl/hMG0ky very good manual for instalation.
  7. Gamerboy59

    [solved] Install Problem

    Hello, after inserting all dates to the installer, double checked them to be correct, I just get a blank page and the apache error logs gives me this: [Mon Sep 01 16:51:16.862013 2014] [:error] [pid 3923] [client 62.226.161.49:14911] PHP Notice: Use of undefined constant FROXLOR_INSTALL_DIR - assumed 'FROXLOR_INSTALL_DIR' in /var/www/html/froxlor/lib/classes/database/class.Database.php on line 219, referer: http://mysite.de/froxlor/install/install.php?check=1 [Mon Sep 01 16:51:16.862226 2014] [:error] [pid 3923] [client 62.226.161.49:14911] PHP Warning: require(FROXLOR_INSTALL_DIR/lib/userdata.inc.php): failed to open stream: No such file or directory in /var/www/html/froxlor/lib/classes/database/class.Database.php on line 219, referer: http://mysite.de/froxlor/install/install.php?check=1 [Mon Sep 01 16:51:16.862279 2014] [:error] [pid 3923] [client 62.226.161.49:14911] PHP Fatal error: require(): Failed opening required 'FROXLOR_INSTALL_DIR/lib/userdata.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/froxlor/lib/classes/database/class.Database.php on line 219, referer: http://mysite.de/froxlor/install/install.php?check=1How to install froxlor then?
  8. Hi All! I met two problems at installation on FreeBSD FreeBSD 9.2 32-bit intel Froxlor 0.9.32_2 1 - not so impotant - When I installing froxlor, the bind99 port even install if it already is is installed. Creating bzip'd tar ball in '/usr/ports/dns/bind99/work/pkg/bind99-9.9.5P1_5.tbz' ===> Installing for bind99-9.9.5P1_5 ===> Checking if dns/bind99 already installed ===> bind99-9.9.5P1_5 is already installed You may wish to ``make deinstall'' and install this port again by ``make reinstall'' to upgrade it properly. If you really wish to overwrite the old port of dns/bind99 without deleting it first, set the variable "FORCE_PKG_REGISTER" in your environment or the "make install" command line. *** [check-already-installed] Error code 1 2 - Impotant - the froxlor installation comes to an end with the following errors # make install ===> Building package for froxlor-0.9.32_2 Creating package /usr/ports/sysutils/froxlor/work/pkg/froxlor-0.9.32_2.tbz Registering depends: mod_php5-5.4.29,1 php5-bcmath-5.4.29 php5-curl-5.4.29 php5-filter-5.4.29 php5-ftp-5.4.29 php5-gettext-5.4.29 php5-json-5.4.29 php5-pdo_mysql-5.4.29 php5-mysql-5.4.29 php5-mysqli-5.4.29 php5-pdo-5.4.29 php5-posix-5.4.29 php5-session-5.4.29 php5-xml-5.4.29 php5-pcntl-5.4.29 php5-5.4.29 bind99-9.9.5P1_5 libxml2-2.8.0_2 apache24-2.4.9_3 apr-1.5.1.1.5.3_1 gdbm-1.11_2 logrotate-3.8.7 popt-1.16 proftpd-mod_sql_mysql-1.3.5_2 proftpd-1.3.5_2 gettext-0.18.3 postfix-2.11.1,1 dovecot-1.2.17_2 libiconv-1.14_1 db48-4.8.30.0_2 mysql56-server-5.6.19 mysql56-client-5.6.19 pcre-8.33 pkgconf-0.9.2_1 curl-7.37.0 webalizer-2.23.8 libgd-2.1.0_4,1 tiff-4.0.3_4 jbigkit-2.1_1 jpeg-8_5 png-1.5.17 perl-5.14.4 fontconfig-2.11.0_3,1 freetype2-2.5.3_2 indexinfo-0.2 ca_root_nss-3.16.1 openssl-1.0.1_13 expat-2.1.0_1. Creating bzip'd tar ball in '/usr/ports/sysutils/froxlor/work/pkg/froxlor-0.9.32_2.tbz' tar: /usr/local/www/froxlor/COPYING: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/README.md: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/000.version.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/100.panel.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/110.accounts.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/120.system.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/125.cronjob.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/130.webserver.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/131.ssl.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/135.fcgid.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/136.phpfpm.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/137.perl.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/140.statistics.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/150.mail.php: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/actions/admin/settings/155.ftpserver.php: Cannot stat: No such file or directory ------------------------------------------------ tar: /usr/local/www/froxlor/templates/misc/configfiles/ubuntu_precise/pure-ftpd/etc_pure-ftpd_db_mysql.conf: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/templates/misc/standardcustomer/index.html: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/templates_c/.keep: Cannot stat: No such file or directory tar: /usr/local/www/froxlor/webftp.php: Cannot stat: No such file or directory tar: Error exit delayed from previous errors. pkg_create: make_dist: tar command failed with code 256 *** [do-package] Error code 1 Stop in /usr/ports/sysutils/froxlor. *** [install] Error code 1 Stop in /usr/ports/sysutils/froxlor.
  9. carras

    Nginx with Froxlor

    Hello, I'm trying to make froxlor working under Ngnix. I follow all guides in the wiki but at the end I try to enter in the admin panel and I get a 404. Then I stop Nginx and start Apache and everything is back to normal. What you I do to make Nginx work? Is that I should install froxlor in another directory or move the existing folder? Thanks a lot, Happy new year! PS: I'm using Ubuntu LTS 12.04.
  10. Hi, I recently installed Froxlor from the debian package successfully but then decided to install it from git on another system which caused the following problem: After filling out the install script I see the login prompt but it already says then only an admin is allowed to log in which I think was different when I installed from the debian package. Anyway I am the not allowed to log in even though I am using the admin account and there are no other accounts yet obviously. The error I get is not a "wrong password" error but I just end up back on the login prompt again as any normal user without admin previliges in this case because the update process is not complete. This problem occurs with the default version on git Should be easy to reproduce I tried 3 times before giving up and using the debian package again. Oh, the installation attempt was on a freshly installed Debian Wheezy 64bit system... Best regards Oliver
  11. Meco

    OpenSuSe 12.1 and Froxlor

    First of all I want you to know that I am very new with the project and I don't pretend my post to be very good. If you have some notes for me feel free to comment here. I just decided to share it with you. It will be easier for you if you have clear installation of openSuSe 12.1 with Minimal Server Selection (Text Mode) Firstly you will need to open some ports on your firewall, or to stop it which is highly not recommendable. You can do it with YaST. yast2 -> Security and Users -> Firewall -> Allowed Services -> Advanced then in TCP Ports write those ports that you want to be open. 22 ? SSH 80 - HTTP 3306 ? MySQL (don?t open it if you are not going to use it from outside) Then start SSH daemon: # rcsshd start Now you can access your server from anywhere using Putty or any other SSH client, so you don?t need monitor and keyboard for your server anymore You will need some packedgnes now. To install them you can use YaST or zypper command: # zypper install yast2-runlevel apache2 apache2-mod_php5 php5-mysql php5-posix php5-bcmat mysql-community-server pure-ftpd Now you have all that software downloaded and installed. You have to make it run automatically when your system is up. yast -> System -> System Services (Runlevel) -> ( ) Expert Mode -> and you will have to set runlevel 3 to : apache2, pure-ftpd, sshd, mysql and postfix It is gonna be a god idea to install git: #zypper install git Then get the froxlor srounce # [color=#000000][font=Verdana, Verdana, Geneva, sans-serif][size=3]git clone https://github.com/Froxlor/Froxlor.git /srv/www/htdocs/froxlor/[/size][/font][/color] Then enter http://<your ip>/froxlor/ and install it step by step Crons: # vi /etc/cron.d/froxlor: and put this there: */5 * * * * /usr/bin/php -q /srv/www/htdocs/froxlor/scripts/froxlor_master_cronjob.php For PureFTP: a friend of mine, who is a server administrator told me that it is much better for me to use vsftpd (very secure ftp), but i see that it is not supported by froxlor. I am going to have a look at it and see if it is possible to make it run. # vi /etc/pure-ftpd/pure-ftpd.conf PAMAuthentication no AnonymousOnly no NoAnonymous yes uncomment: MySQLConfigFile /etc/pure-ftpd/pureftpd-mysql.conf Umask 133:022 feel free to edit any other confs if you know what you are doing. # vi /etc/pure-ftpd/pure-ftpd-mysql.conf Replace MYSQL_PASSWORD with your MySQL password. ## connect via port 3306 #MYSQLServer localhost #MYSQLPort 3306 ## or connect via sock MYSQLSocket /var/run/mysql/mysql.sock ## MYSQLUser froxlor MYSQLPassword MYSQL_PASSWORD MYSQLDatabase froxlor MYSQLCrypt any MYSQLGetPW SELECT password FROM ftp_users WHERE username="\L" AND login_enabled="y" MYSQLGetUID SELECT uid FROM ftp_users WHERE username="\L" AND login_enabled="y" MYSQLGetGID SELECT gid FROM ftp_users WHERE username="\L" AND login_enabled="y" MYSQLGetDir SELECT homedir FROM ftp_users WHERE username="\L" AND login_enabled="y" MySQLGetQTASZ SELECT CONCAT( diskspace / 1024 ) AS diskspace FROM panel_customers WHERE loginname="\L" AND deactivated="0" Then you have to open ports in firewall from "Service to Allow" select pure-ftp. If you just open port 21 it is not going to work. # /etc/init.d/pure-ftpd restart I haven't messed up with email services now because I don't have enough free time. I see that there is no option for external email service
×