Jump to content
Froxlor Forum

Tealk

Members
  • Content Count

    177
  • Joined

  • Last visited

Everything posted by Tealk

  1. Also ich hätte das gerade mal folgendermaßen gemacht: ich habe die Datei sites-enabled/01_placeholder.conf erstellt. Ich hab extra sites-enabled genutzt weil ich froxlor einen anderen ordner zugewiesen habe. Folgendes ist der Inhalt: <VirtualHost ip:80> DocumentRoot /var/www/html </VirtualHost> Das funktioniert auch soweit, nur hab ich auch Domains mit wo "HSTS für jede Subdomain" aktiviert ist. Also wollte ich das obere eben auch für die SSL variante erstellen: <VirtualHost ip:443> DocumentRoot /var/www/html </VirtualHost> nur sobald ich den SSL
  2. müsste dann nicht schon die "000-default.conf" einspringen?
  3. ok, ja das macht anscheinend für die Anbindung keinerlei Probleme. Danke nochmals
  4. Also es gibt nen Subnetz für IPv6 aber es ist keine dem Server zugewiesen oder irgendwo eingetragen. Ich kann die Seite per Browser erreichen und der DNS check sagt auch das es auf die richtige IP geht.
  5. hab ich gar nicht daran gedacht, muss ich mir mal anschauen also erwartet wird dort der docker collabora //EDIT Also das eintragen von dem Proxi klappt, danke für die Hilfe
  6. Dann habe ich aber das selbe Problem mit Let's Encrypt oder nicht?
  7. Hab den Server neu installiert, damit ist dieses Problem verschwunden, dafür gibt jetzt das SSL Problem -.- Langsam verzweifel ich an dem teil. Aber danke für diene Unterstützung
  8. Also scheint immer noch nicht zu funktionieren Could not get Let's Encrypt certificate for analytics.domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"analytics.domain.de"},"status":"invalid","expires":"2019-05-09T06:40:02Z","challenges":[{"type":"tls-alpn-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/9vRyMApyfmNWTGLurPuEacK8pNGAbiHKurznoLOBlbU\/15400662499","token":"izSpllFsHjLocK3WDn2gIsMedTN5poSKp3wxBD78dH0"},{"type":"dns-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/9vRyMApyfm
  9. Wie kann man denn in Froxlor einen reverse proxy eintragen? Ich würde nämlich gerne folgendes umsetzen. https://nextcloud.com/collaboraonline/
  10. Ja, komischerweise habe ich bei dieser Installation echt viele Problemchen. Hab jetzt froxlor schon öfters installiert, bisher immer top gelaufen. Also bis jetzt hab ich immer noch kein Zertifikat bekommen. Ich breche das mal heute ab und lass das morgen neu Probieren.
  11. Die Option habe ich bisher gar nicht bemerkt. Macht ein self-check nicht Sinn? Ich hab es mal deaktiviert und sehe was dann passiert, gerade bin ich blockiert wegen zu vielen anfragen.
  12. Could not get Let's Encrypt certificate for analytics.domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"analytics.domain.de"},"status":"invalid","expires":"2019-05-08T01:55:04Z","challenges":[{"type":"dns-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/2j9KxcgRFqYKa9ZwAF7GFXFp2cFR5qI_12JKAi_CvHE\/15355683826","token":"7IogmcMUQaib_KsKwDY1kNwJfOGcyGMyv5voGD6oHLA"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/analytics.domain.de\/.well-known\/acme-cha
  13. Ja in der Vhost steht das auch so drin. # ls -la /var/customers/webs/web/ total 36 drwxr-x--- 7 web web 4096 Apr 24 22:20 . drwxr-xr-x 4 root root 4096 Apr 24 02:29 .. drwxr-xr-x 12 web web 4096 Apr 19 12:13 analytics.domain.de drwxr-xr-x 9 web web 4096 Apr 20 16:48 forum.domain.de drwxr-xr-x 6 web web 4096 Apr 22 21:28 domain.de -rw-r--r-- 1 web web 6568 Nov 27 18:41 index.html drwxr-xr-x 13 web web 4096 Apr 24 02:34 phpmyadmin.domain.de drwxr-xr-x 2 web web 4096 Apr 24 02:00 webalizer # ls -la /var/customers/webs total 16 drwxr-xr-x 4 root root 4
  14. Hi, ich stehe gerade ein wenig auf dem Schlauch. Ich habe für phpmyadmin eine subdomain angelegt "phpmyadmin.abc.xyz" und diese liegt dann in "/var/customers/webs/web/phpmyadmin.abc.xyz" wenn ich dann auf die Domain zugreifen will, bekomme ich folgenden Fehler angezeigt: Browser: You don't have permission to access / on this server. Server unable to read htaccess file, denying access to be safe Log: [Wed Apr 24 02:40:06.981097 2019] [core:crit] [pid 24150] (13)Permission denied: [client 93.212.30.198:53224] AH00529: /var/customers/webs/web/.htaccess pcfg_openfile: unable
  15. oh man, so einfach kann es sein. Vielen Dank.
  16. Danke für deine schnelle Antwort Eigentlich habe ich das nach der Konfigurationsanleitung eingerichtet. Also bisher habe ich folgendes: Debian-98-stretch-64-minimal Webserver: Apache/2.4.25 (Debian) PHP-Version: 7.3.4
  17. Hallo, ich richte gerade einen Server mit Froxlor ein und bin auf folgendes Problem gestoßen: Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: Starting The PHP 7.3 FastCGI Process Manager... Apr 18 09:51:17 Debian-98-stretch-64-minimal php-fpm7.3[4522]: [18-Apr-2019 09:51:17] ERROR: [pool USER.DOMAIN.de] cannot get uid for user 'USER' Apr 18 09:51:17 Debian-98-stretch-64-minimal php-fpm7.3[4522]: [18-Apr-2019 09:51:17] ERROR: FPM initialization failed Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/n/a Ap
  18. Danke, hatte noch das mpm_prefork an, darauf hab ich nicht geachtet.
  19. Hallo, ich habe die http2 Unterstützung aktiviert, aber wenn ich hier teste kommt ein negatives Ergebnis heraus: https://tools.keycdn.com/http2-test
  20. Tealk

    TOTP login

    Oh, da hab ich eig. die Suche befragt, die hat mir aber dreist-erweise gesagt das gibt es nicht. Dann bin ich mal gespannt
  21. Tealk

    TOTP login

    Hallo, wäre es möglich einen 2FA mit TOTP gem. RFC6238 zu integrieren, das würde die Sicherheit erhöhen.
  22. Ok habe ich dann bleibt er bei der erste Domain hängen diese ist aber einwandfrei erreichbar und hat schon ein Zertifikat. Warte schon ca 10 Minuten. php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating analytics.anzahcraft.de [information] Adding SAN entry: analytics.anzahcraft.de [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation
  23. Ja das habe ich schon probiert. Dann bekomme ich nur folgendes gesagt: php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug There is already a Cronjob for letsencrypt in progress. Exiting... Take a look into the contents of /var/run/froxlor_froxlor_master_cronjob-letsencrypt.lock-* for more information! und dort steht nur drinn Setting Lockfile to /var/run/froxlor_froxlor_master_cronjob-letsencrypt.lock-1382 Setting Froxlor installation path to /var/www/froxlor Userdatas included Table definitions included Database-connection established Checking froxl
×
×
  • Create New...