Jump to content
Froxlor Forum

irisdina

Members
  • Content Count

    69
  • Joined

  • Days Won

    12

Everything posted by irisdina

  1. Steht doch in der Meldung, er kann nicht auf die DBs zugreifen, weil die PW's nicht stimmen oder nicht gesetzt wurden während dem install.
  2. Verstehe irgendwie dein Problem nicht genau... Machst du die Certs über Letscrypt oder einen anderen Anbieter? Habe selbst x Domains auf einer IP laufen und alle haben keine Probleme mit den Certs.
  3. Geh zu IPs und Ports >> IP/Port hinzufügen und setze im ersten Feld deine IP vom Server und im zweiten bei Port: 80 rein. Wenn du SSL benutzen willst, machst du dass gleiche wie oben, nur anstatt Port 80 trägst du 443 ein und unten bei Webserver-SSL-Konfiguration den hacken bei Ist dies ein SSL-Port?: rein
  4. In den Alten Versionen gab es ein Problem/Bug/Feature, dass man kein PW ändern konnte bzw. bei dem Install setzen konnte und später erst nervig ein PW einstellen konnte. will man doch hoffen, das Froxlor nichts dagegen hat
  5. Warning, this is not an official guide!!! 1. sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list sudo nano /etc/apt/source.list 1b. insert (for Debian Stretch) 1.2B (for Ubuntu Cosmic) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server 2. MariaDB install Warning use sudo command für this install! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional) 3. nginx install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 4. PHP install sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. sudo service nginx restart sudo service php7.3-fpm restart Froxlor install There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master) Stable Version 1. cd /var/www/html/ 1a. sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or Git Version (Beta Version) sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory composer install --no-dev 1b. sudo chown -R www-data:www-data Froxlor/ Set up Froxlor 2. Open Your Browser 2a. http://your IP or Hostname/Froxlor Install Froxlor finish  3d. Move userdata (Optional) sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. sudo rm /etc/nginx/site-enable/default don't restart nginx! Froxlor Settings 1. Cronjob sudo nano /etc/cron.d/froxlor insert # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock 3. sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated:Change from NO to YES 3a. PHP-FPM versionsChange > php-fpm restart command: service php7.3-fpm restart and Configuration directory of php-fpm: > to /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate 1. sudo apt install certbot 1a. sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. sudo nano /etc/nginx/acme.conf insert location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfileinsert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > SettingsActivate > Enable Let's Encrypt Change Path to the acme.conf snippet to > /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings- Enable Let's Encrypt for the froxlor vhost- Enable SSL-redirect for the froxlor vhost- HTTP Strict Transport Security (HSTS)- Include HSTS for any subdomain 2d. Activated HTTP2 Support on > Settings > Nginx
  6. Für die letzte Domain wurde dass Cert nun auch erstellt, kA ob es jetzt an den Nameservern lag oder nicht. Aber jetzt geht alles wieder.
  7. Bei älteren versionen gab es ein problem, dass man kein Root PW für SQL setzen konnte. Weiß jetzt auch nicht welche vers. Stretch benutzt, aber er könnte mal: Und dann: Wichtig aber, bei einem neu install, vorher die DB's per dump/phpmyadmin etc. sichern. Den benutzer für Frox kann man manuell wieder anlegen, Daten sind ja in dem /lib/ ordner drin. in die source.list eintragen und diese vers. installieren, da kommt die abfrage nach dem PW oder probieren sein jetziges PW zu ändern, https://www.digitalocean.com/community/tutorials/how-to-reset-your-mysql-or-mariadb-root-password *edit* Sehe gerade, dass stretch 10.1 benutzt, daher entweder die source.list ändern und reconfig/neu-install machen oder dass pw ändern/festlegen
  8. Ist dass zufällig MariaDB?
  9. Ja, lösen alle auf die IP auf. Hab jetzt bei der DE Domain die Nameserver erneuert, vllt hilft dies.
  10. Ja, die Test Datei kann ich aufrufen. Heute Nacht, hat er auch zwei weitere Certs erstellt, fehlt aktuell nur noch eine DE Domain, wo dass fehlt.
  11. Hab es jetzt noch mal probier, bei 3 von 6 erstellt er mir die certs, bei den anderen 3 nicht, kA why er dies nicht macht. Hab auch die neuste git vers. gezogen. Angefangen hatte es vor einigen Tagen mit der .eu Domain, mittlerweile sind eine .com und eine .de betroffen davon. Manuell kann ich die certs erstellen, nur über frox macht er dies nicht.
  12. 1. ja, sonst würden meine Domains die ich von Anfang an drin habe nicht per ssl gehen und vor einiger Zeit ging es auch noch oh. probleme, als ich ne neue Domain dazu gemacht habe. 2. Ja ist es, wurden die gleiche einstellungen gemacht wie bei den anderen domains Habe jetzt mal manuell ein cert für die domian mit certbot erstellt, ging oh. probleme und keine fehler ausgabe etc.
  13. Hi, Hab mittlweile ein prob mit frox und certs. Und zwar, wenn ich ne neue Domain in Frox eintrage, erstellt er mir keine certs mehr, bzw. macht auch in den vhots keine Weiterleitung auf den port 443 von 80. Bestehende certs (3stk) die schon drin ist, gehen oh. probleme nur wenn ich neue domains hinzufüge zickt es um, kA ob es daran liegt dass ich mal den hostnamen manuell geändert hatte ( ) gibs ne Möglichkeit, dass man manuell frox dazu bringen kann, alle certs neu zu erstellen?
  14. Du brauchst frox gar nicht per apt-get etc. zu installieren, braucht man auch nicht wirklich. Einfach dass Tar paket laden => entpacken und spass daran haben, mehr braucht man nicht. Und apache braucht man nicht für Frox, läuft alles wunderbar mit nginx, mariadb und php7.0/1 ohne probleme. Kann gerne mal ein Tut schreiben zum einrichten, falls gewünscht.
  15. Ich wollte meinen hostnamen für frox ändern. Die neue Url kurz manuell in die jeweiligen nginx confs geschrieben und nginx neu gestartet, danach im Froxlor Panel geändert, nur habe ich das Problem, das er mir kein ssl-cert für die neue Domain erstellt, sondern dass alte cert (von der alten url), nur mit dem neuen namen versehen hat. Wie bekomm ich frox dazu, dass er mir ein neues cert erstellt für den Frox domain namen?
  16. 127.0.0.1 habe ich bereits versucht und wie gesagt, die SQL Daten stimmen zu 100% sonst könnte ich mich nicht per ssh o. phpmyadmin auf die SQL DB mit dem benutzer einloggen. Habe dem Kunden auch mal noch eine andere Domain hinzugefügt, da geht es oh. probleme, nur halt mit Domain A nicht.
  17. Und zwar ... benutze frox schon sehr lange und ist immer aktuell, aber mom stehe ich vor einem prob, was es eig. gar nicht geben dürfte ^^" Auf einen meiner Server läuft frox (wie schon oben erwähnt) mit mehreren Domains bisher keine probleme gehabt, jetzt wollte ich für einen bekannten nen eigenen Acc machen. Habe ihm einen User + Domain angelegt und er wollte sich WP installieren, (DB + SQL nutzer wurde angelegt), nur laut WP install bekommt er keine Verbindung zu der SQL (würde angeblich nicht laufen). Nach gesehen ob die Login Daten für die SQL richtig gehen => ssh mysql login oh. probleme (also daten stimmen), ihm mal einen zweiten SQL User angelegt => gleiches prob. Ihm mal daten für einen einen anderen SQL Acc (andere Kunde) gegeben => prob. In den Logs mal nach gesehen, keine fehler drin, die darauf deuten das es probleme mit der SQL gibt. WP mal auf ne andere Domain gelegt und installiert (mit den oberen SQL Daten) => kein problem, geht einwandfrei ... Why kann ich keine SQL verbindung mit Domain A aufbauen aber mit Domain B etc. schon? Kunde kann aber SQL anlegen.
×
×
  • Create New...