Jump to content
Froxlor Forum

Buckshot

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Buckshot

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling
  • Location
    Deutschland
  1. Gut, dann setze ich mir mal eine VM auf und schaue nach ob das in der git-Version auch noch der Fall ist. UPDATE: Also bei der neuen Stable-Version (0.9.35.1), welche heute erschienen ist, existiert der 302-Redirekt jedenfalls noch. Ich werde aber, wie gesagt, die git-Version auch noch mal testen - VM ist schon aufgesetzt. Ansonsten war das Update auf die neue Version n Klacks und selbst Let's Encrypt läuft einwandfrei - sehr gute Arbeit, muss ich schon sagen UPDATE 2: Leider bin ich mit der git-Version noch nicht weiter gekommen, aber nach einigen Tests mit der o. g. Version wird der 301er Redirect korrekt ausgeführt, wenn man unter System > Einstellungen > Webserver-Einstellungen bei Erlaube Kunden-Redirect den Haken setzt und für den jeweiligen Kunden unter Ressourcen > Kunden explizit 301 (moved permanently) auswählt. Wenn man nur beim Standard-Redirect 301 (moved permanently) auswählt und den Erlaube Kunden-Redirect Haken nicht setzt, blieb es zumindest bei mir bei einem 302er, aber alle Konstellationen habe ich nicht ausprobiert. Dieser Workaround ist - für mich zumindest - ausreichend.
  2. Hallo, ich möchte mal an das Problem anknüpfen, da ich ein ähnliches habe. Ich nutze Froxlor 0.9.34.2 auf Debian 8 mit Apache 2.4 und PHP 5.6, sowie MySQL 5.6. Nun habe ich festgestellt, dass, wenn man in Froxlor unter Resourcen > Domains > "Domain" > Webserver-Einstellungen > SSL-Weiterleitung = JA anhakt, folgender Code in den den vHost für Port 80 geschrieben wird: <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^/(.*) https://domain.tld/$1'>https://domain.tld/$1 </IfModule> Redirect / https://domain.tld/ Die anschließende Weiterleitung erfolgt dann per 302 Found. Die Einstellung unter Server > Einstellungen > Webserver-Einstellungen > Standard-Redirect hat hierauf keine Auswirkung. Bei der RewriteRule müsste für eine Weiterleitung per 301 Permanently Moved der Code [R=301,L] am Ende und beim Redirect permanent vor dem / eingfügt werden. Gibt es noch eine Einstellung, die übersehen habe, ist das ein known Bug und wird mit dem nächsten Release behoben oder bin ich wieder ein Einzelfall? Ich meine dazu auch schon mal einen Thread gelesen zu haben, aber ich habe ihn dann leider nicht mehr gefunden und denke hier ist meine Frage auch nicht so verkehrt. Als Hotfix kann ich natürlich auch den Haken raus nehmen und dann die Einstellung im vHost manuell einstellen - es aber nicht so schön, wie einen Haken zu setzen
  3. Die git-Version zu testen hatte ich jetzt leider keine Muße, daher hab ich mich entschlossen es noch mal neu mit meinen gesammelten Erfahrungen zu installieren. Diesmal jedoch mit Apache und PHP 5.6, also ganz simpel und das hat wunderbar geklappt. Ich werde dann lieber Stück für Stück updaten, aber hauptsache es läuft erst mal und das bis jetzt richtig gut .
  4. Hallo, ich habe Froxlor 0.9.34.2 auf Debian 8 mit nginx 1.9.12, PHP 7.0.4 (FPM) und MySQL 5.6.29 eingerichtet. Läuft auch alles einwandrei, bis auf, wenn ich in Froxlor unter Server > Einstellungen auf die Systemeinstellungen gehe und versuche diese zu speichern (mit oder ohne Anpassungen) kommt die Fehlermeldung Unknown Error (not in option): system_ipaddress. In den Logs konnte ich dazu leider keine weiteren Informationen finden.
×
×
  • Create New...