Jump to content
Froxlor Forum

v3ng

Members
  • Content Count

    200
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by v3ng

  1. Das ist ein komplett frisches Debian 8 minimal System. Es wurde 2 mal Neuinstalliert und jedes Mal trat der Fehler auf, welchen ich nun aber scheinbar beheben konnte. Das mir ein Fehler unterlaufen ist glaube ich eher nicht, da ich mich 1:1 an die Templates gehalten habe und es nicht das erste System ist, welches ich installiere. Dennoch habe auch ich zu wenig Ahnung um genaues sagen zu k?nnen, wieso das jetzt genau auf dem Server auftritt.
  2. Das tritt bei mir auch nur auf einem System auf von mehreren.
  3. Nat?rlich, libnss-mysql-bg ist nach Template konfiguriert und installiert. Das Problem wurde durch den oben genannten Fix ja gel?st
  4. Die L?sung war es, den "passwd" cache von NSCD zu deaktivieren. Die nscd.conf habe ich demensprechend angepasst: # # /etc/nscd.conf # # An example Name Service Cache config file. This file is needed by nscd. # # Legal entries are: # # logfile <file> # debug-level <level> # threads <initial #threads to use> # max-threads <maximum #threads to use> # server-user <user to run server as instead of root> # server-user is ignored if nscd is started with -S parameters # stat-user <user who is allowed to request statistics> # reload-count unlimited|<number> # paranoia <yes|no> # restart-interval <time in seconds> # # enable-cache <service> <yes|no> # positive-time-to-live <service> <time in seconds> # negative-time-to-live <service> <time in seconds> # suggested-size <service> <prime number> # check-files <service> <yes|no> # persistent <service> <yes|no> # shared <service> <yes|no> # max-db-size <service> <number bytes> # auto-propagate <service> <yes|no> # # Currently supported cache names (services): passwd, group, hosts, services # logfile /var/log/nscd.log # threads 4 # max-threads 32 # server-user nobody # stat-user somebody debug-level 1 # reload-count 5 paranoia yes # restart-interval 3600 enable-cache passwd no positive-time-to-live passwd 100 negative-time-to-live passwd 20 suggested-size passwd 211 check-files passwd yes persistent passwd yes shared passwd yes max-db-size passwd 33554432 auto-propagate passwd yes enable-cache group no positive-time-to-live group 100 negative-time-to-live group 60 suggested-size group 211 check-files group yes persistent group yes shared group yes max-db-size group 33554432 auto-propagate group yes enable-cache hosts yes positive-time-to-live hosts 3600 negative-time-to-live hosts 20 suggested-size hosts 211 check-files hosts yes persistent hosts yes shared hosts yes max-db-size hosts 33554432 enable-cache services yes positive-time-to-live services 28800 negative-time-to-live services 20 suggested-size services 211 check-files services yes persistent services yes shared services yes max-db-size services 33554432 enable-cache netgroup yes positive-time-to-live netgroup 28800 negative-time-to-live netgroup 20 suggested-size netgroup 211 check-files netgroup yes persistent netgroup yes shared netgroup yes max-db-size netgroup 33554432 Hier der NSCD Log, der mich zu der L?sung brachte: http://pastebin.com/bhGy0GS6 Eventuell k?nnte man das so in die config Templates einbauen, damit der Fehler in zukunft vermieden werden kann?
  5. root@dev:~# getent passwd Kunde Kunde:x:10010:10010:Froxlor Customer:/var/customers/webs/Kunde/:/bin/false
  6. Hi, bei jedem neu erstellen Kunden tritt das Problem auf, "Testa" ist ein gerade neu erstellter. Gr??e und Frohes Fest
  7. root@dev:/etc/apache2# grep -r Testa * htpasswd/1-0c7f9614745a5e4ad1dcdc4a9879d8c1.htpasswd:Testa:c3DRU5qw1XoLY sites-enabled/40_froxlor_diroption_0c7f9614745a5e4ad1dcdc4a9879d8c1.conf:<Directory "/var/customers/webs/Testa/webalizer/"> sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf:# 28_froxlor_normal_vhost_Testa.dev.firez.de.conf sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf:# Domain ID: 1 - CustomerID: 1 - CustomerLogin: Testa sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ServerName Testa.dev.firez.de sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ServerAlias *.Testa.dev.firez.de sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: DocumentRoot "/var/customers/webs/Testa/" sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: SuexecUserGroup "Testa" "Testa" sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: <Directory "/var/customers/webs/Testa/"> sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: FcgidWrapper /var/www/php-fcgi-scripts/Testa/Testa.dev.firez.de/php-fcgi-starter .php sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ErrorLog "/var/customers/logs/Testa-error.log" sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: CustomLog "/var/customers/logs/Testa-access.log" combined
  8. Hallo, Ich wei?, dass dieses Thema hier schon 100x aufgeriffen wurde, jedoch habe ich bisher in keiner der Topics eine L?sung gefunden. Folgendes Problem, nach dem erstellen eines neuen Kunden und einem ausf?hren des Cronjobs bekomme ich folgende Meldung: AH00543: apache2: bad user name "Kunde" Auf dem Server l?uft FCGID unter Debian 8. Libnss ist selbstverst?ndlich nach Konifgurationshinweisen aus dem Panel eingerichtet. Sowohl Apache, MySQL als auch NSCD laufen und wurden auch in der richtigen Reihenfolge gestartet: MySQL> NSCD > Apache Der Log von sagt nichts. Eine Idee? Danke und Gr??e
  9. v3ng

    PHP Cache

    allow_call_time_pass_reference = Off allow_url_fopen = On asp_tags = Off disable_classes = disable_functions = display_errors = On display_startup_errors = Off enable_dl = Off error_reporting = E_ALL & ~E_NOTICE expose_php = Off file_uploads = On cgi.force_redirect = 1 gpc_order = "GPC" html_errors = Off ignore_repeated_errors = Off ignore_repeated_source = Off include_path = ".:{PEAR_DIR}" log_errors = On log_errors_max_len = 1024 magic_quotes_gpc = Off magic_quotes_runtime = Off magic_quotes_sybase = Off max_execution_time = 30 max_input_time = 60 memory_limit = 265M {OPEN_BASEDIR_C}open_basedir = "{OPEN_BASEDIR}" output_buffering = 4096 post_max_size = 20G precision = 14 register_argc_argv = Off register_globals = Off report_memleaks = On sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}" session.auto_start = 0 session.bug_compat_42 = 0 session.bug_compat_warn = 1 session.cache_expire = 180 session.cache_limiter = nocache session.cookie_domain = session.cookie_lifetime = 0 session.cookie_path = / session.entropy_file = /dev/urandom session.entropy_length = 16 session.gc_divisor = 1000 session.gc_maxlifetime = 1440 session.gc_probability = 1 session.name = PHPSESSID session.referer_check = session.save_handler = files session.save_path = "{TMP_DIR}" session.serialize_handler = php session.use_cookies = 1 session.use_trans_sid = 0 short_open_tag = On suhosin.mail.protect = 1 suhosin.simulation = Off track_errors = Off upload_max_filesize = 20G upload_tmp_dir = "{TMP_DIR}" variables_order = "GPCS" ;mail.add_x_header = On ;mail.log = "/var/log/phpmail.log" safe_mode = off opcache.enable = "1" opcache.enable_cli = "0" opcache.enable_file_override = "1" opcache.error_log = "/var/log/php_opcache.log" opcache.fast_shutdown = "1" opcache.interned_strings_buffer = "8" opcache.log_verbosity_level = "2" opcache.max_accelerated_files = "4000" opcache.memory_consumption = "128" opcache.revalidate_freq = "20" opcache.revalidate_path = "1"
  10. v3ng

    PHP Cache

    Nein, du solltest aber via phpinfo schauen, ob Opcache aktiv ist. Ich habe die PHP Konfigurarion etwas angepasst, wenn Interesse besteht, kann ich sie dir schicken. Der Performance Unterschied ist insbesondere bei Anwendungen wie WordPress sehr hoch. In meinem Fall ist WordPress nun Ca. 50% schneller laut Benchmarks.
  11. Du kannst in den Dateivorlagen selbst w?hlen, welchen Code die .html/.php o.? enth?lt
  12. Der Vorteil von FCGID ist unteranderem, dass das Rechteproblem zwischen FTP und Webuser behoben ist. Oder auch, dass jeder Domain eine eigene PHP Konfiguration zugeordnet werden kann.
  13. Hallo, Du k?nntest beispielsweise die Zeit, die sich das Script f?r die Ausf?hrung nehmen darf verringern, falls ich das auf die schnelle richtig verstanden habe, sollte das helfen. Gr??e
  14. Hallo, Ich habe Probleme mit Froxlor in Bezug auf SSL/SNI. Beim Aufruf einer Domain kommt die Meldung "ssl_error_rx_record_too_long". Hier der vHost: http://pastebin.com/H5H1FJ9C Wenn ich den vHost von "35_froxlor_ssl_vhost_Domain.com.conf" in "00_froxlor_ssl_vhost_Domain.com.conf" umbenenne funktioniert es. Das habe ich auch schon in anderen Topics zu dem Thema gelesen, allerdings wurde kein L?sungsvorschlag genannt. Jeden SSL vHost manuell umbenennen w?rde ich nur ungern. Im Log steht nichts IP Einstellungen: http://fs5.directupload.net/images/151205/s2g2n6rx.png Als Zertifikat wurde nichts eingetragen, da SNI verwendet wird. Gr??e
  15. Meinst du den Documentroot der Kunden? Der liegt unter "/var/customers/webs/[KUNDE]" Den Documentroot der Kunden kannst du festlegen, indem du entwerder die Domains bearbeitest und dort den Pfad ?nderst, oder in den EInstellungen.
  16. Hallo, Vermutlich liegt es daran, dass standardm??ig der Documentroot von Apache 2.4 unter Debian 7/8 nicht mehr "/var/www" ist, sondern "/var/www/html". Das l?sst sich allerdings leicht beheben, indem du folgende Datei ?ffnest und den Documentroot von "/var/www/html" zu "/var/www" ?nderst. nano /etc/apache2/sites-enabled/000-default service apache2 restart Gr??e
  17. Neu installiert aber leider immer noch das selbe Problem. Hat jemand noch eine Idee? Installiert wurde alles genau wie in den configs beschrieben. EDIT: Lag an IPv6.
  18. Trotzdem danke, dann werde ich den Server mal neuinstallieren und bei der Gelegenheit direkt auf Debian 8 setzten.
  19. Liegen unter /etc/apache2/sites-enabled/ Werden auch korrekt eingelesen, soweit ich sehe.
  20. Nein, die Zeilenumr?che sind beim Koppieren etwas verschoben.
  21. # 35_froxlor_normal_vhost_Domain.de.conf # Created 17.10.2015 07:25 # Do NOT manually edit this file, all changes will $ # Domain ID: 7 - CustomerID: 1 - CustomerLogin: Ian <VirtualHost xxx.xx.xxx.xx:80> ServerName Domain.de ServerAlias *.Domain.de ServerAdmin meine@Mail.de DocumentRoot "/var/customers/webs/Ian/" FcgidIdleTimeout 30 SuexecUserGroup "Ian" "Ian" <Directory "/var/customers/webs/Ian/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/Ian/Fi$Options +ExecCGI </FilesMatch> Order allow,deny allow from all </Directory> ErrorLog "/var/customers/logs/Ian-error.log" CustomLog "/var/customers/logs/Ian-access.log" co$</VirtualHost>
  22. Habe ich dir per PN zukommen lassen.
  23. Das Problem ist ja, dass es scheinbar vom Ger?t abh?ngt. Mit ist das Problem das erste Mal aufgefallen, als ich ein Performance Test der Website mit diversen Online Tools durchgef?hrt habe. Hierbei wird oft ein Screenshot der Website sichtbar. Auff?llig war, dass hierbei bei einem Test der Content aus "/var/www/" ausgeliefert wurde, bei einem anderen der Regul?re. Heute Abend h?nge ich davor ein paar Screenshots an. Der Apache2 Configtest best?tigt, dass die Configs in Ordnung sind. Gr??e
×
×
  • Create New...