Jump to content
Froxlor Forum

Gamerboy59

Members
  • Posts

    113
  • Joined

  • Last visited

Everything posted by Gamerboy59

  1. openssl s_client -connect my-domain.de:443 CONNECTED(00000003) 139989321152160:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:795: --- no peer certificate available --- No client certificate CA names sent --- SSL handshake has read 7 bytes and written 305 bytes --- New, (NONE), Cipher is (NONE) Secure Renegotiation IS NOT supported Compression: NONE Expansion: NONE ---For localhost it works fine. This is one debug message: openssl s_client -connect my-domain:443 -state -nbio 2>&1 | grep "^SSL" SSL_connect:before/connect initialization SSL_connect:unknown state SSL_connect:error in unknown state SSL handshake has read 7 bytes and written 305 BytesAnd that's the Apache debug log: [Fri Oct 24 20:25:06.334119 2014] [ssl:info] [pid 28048] AH01876: mod_ssl/2.4.7 compiled against Server: Apache/2.4.7, Library: OpenSSL/1.0.1f [Fri Oct 24 20:25:06.358567 2014] [mpm_prefork:notice] [pid 28048] AH00163: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.4 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations [Fri Oct 24 20:25:06.358607 2014] [mpm_prefork:info] [pid 28048] AH00164: Server built: Jul 22 2014 14:36:38 [Fri Oct 24 20:25:06.358623 2014] [core:notice] [pid 28048] AH00094: Command line: '/usr/sbin/apache2' [Fri Oct 24 20:25:06.358628 2014] [mpm_prefork:debug] [pid 28048] prefork.c(995): AH00165: Accept mutex: fcntl (default: sysvsem) [Fri Oct 24 20:26:31.303869 2014] [core:info] [pid 28056] [client 62.226.179.39:59685] AH00566: request failed: invalid characters in URI [Fri Oct 24 20:26:31.340447 2014] [core:info] [pid 28053] [client 62.226.179.39:59686] AH00566: request failed: invalid characters in URI [Fri Oct 24 20:26:31.377385 2014] [core:info] [pid 28054] [client 62.226.179.39:59687] AH00566: request failed: invalid characters in URI Edit: Maybe this is interesting too: [Fri Oct 24 20:36:38.652940 2014] [ssl:debug] [pid 28253] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost froxlor.my-domain.de:80, skipping SSL Setup Edit2: It looks like the SSL_Modul is not enabled for some reason...
  2. Yes, it's the server.. other friends having the same problem, doesn't matter which browser.
  3. I'm using Ubuntu 14.04.1 There's no SSL log.
  4. Yes, it matches. The domain error log is empty, only the access log is filled.
  5. That's what inside the apache error.log: [Wed Oct 22 12:59:08.550531 2014] [mpm_prefork:notice] [pid 29440] AH00169: caught SIGTERM, shutting down [Wed Oct 22 12:59:09.619527 2014] [suexec:notice] [pid 29501] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec) [Wed Oct 22 12:59:09.686132 2014] [:notice] [pid 29502] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads. [Wed Oct 22 12:59:09.686167 2014] [:notice] [pid 29502] mod_python: using mutex_directory /tmp [Wed Oct 22 12:59:09.703342 2014] [mpm_prefork:notice] [pid 29502] AH00163: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.4 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations [Wed Oct 22 12:59:09.703417 2014] [core:notice] [pid 29502] AH00094: Command line: '/usr/sbin/apache2' [Wed Oct 22 13:10:03.292418 2014] [mpm_prefork:notice] [pid 29502] AH00171: Graceful restart requested, doing restart [Wed Oct 22 13:10:06.472955 2014] [:notice] [pid 29502] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads. [Wed Oct 22 13:10:06.473029 2014] [:notice] [pid 29502] mod_python: using mutex_directory /tmp [Wed Oct 22 13:10:06.486445 2014] [mpm_prefork:notice] [pid 29502] AH00163: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.4 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations [Wed Oct 22 13:10:06.486487 2014] [core:notice] [pid 29502] AH00094: Command line: '/usr/sbin/apache2'And that's the vHost config: # 22_froxlor_ssl_vhost_my-domain_de.conf # Created 22.10.2014 13:10 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 9 (SSL) - CustomerID: 4 - CustomerLogin: mydomain <VirtualHost 12.345.567.89:443> ServerName my-domain.de ServerAlias *.my-domain.de ServerAdmin email@my-domain.de SSLEngine On SSLHonorCipherOrder On SSLCipherSuite ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/my-domain.de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/my-domain.de.key DocumentRoot "/var/customers/webs/mydomain/" FcgidIdleTimeout 30 SuexecUserGroup "mydomain" "mydomain" <Directory "/var/customers/webs/mydomain/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/mydomain/my-domain.de/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted </Directory> Alias /awstats "/var/customers/webs/mydomain/awstats/my-domain.de" Alias /awstats-icon "/usr/share/awstats/icon/" ErrorLog "/var/customers/logs/mydomain-error.log" CustomLog "/var/customers/logs/mydomain-access.log" combined </VirtualHost> Without SSL it works fine.
  6. It's the only result I currently get: ssl_error_rx_record_too_long
  7. Thanks. I'm currently experiencing issues when adding a Domain. While using subdomians only everything works as expected but when I add a new tld an SSL-secured connection is no longer possible and the browser can't connect to the website. Unfortunately, apache is not giving any errors.
  8. Hi, I|m getting the following error on enabling SSL. * Restarting web server apache2 [fail] * The apache2 configtest failed. Output of config test was: AH00526: Syntax error on line 18 of /etc/apache2/sites-enabled/10_froxlor_ipandport_12.345.67.89.80.conf: Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed. The Apache error log may have more information.How to enable SSL?
×
×
  • Create New...